update intrepid and jaunty to landscape-client 1.3.2.3

Bug #347983 reported by Christopher Armstrong on 2009-03-24
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
landscape-client (Ubuntu)
Medium
Mathias Gug
Intrepid
Medium
Mathias Gug
Jaunty
Medium
Mathias Gug
smart (Ubuntu)
Medium
Unassigned
Intrepid
Medium
Mathias Gug
Jaunty
Medium
Mathias Gug

Bug Description

Landscape Client 1.3.2.3 has been released. We would like to get these changes into Intrepid and Jaunty. The required pieces of information for a SRU follow (as laid out in the "Procedure" section of https://wiki.ubuntu.com/StableReleaseUpdates):

Note that this SRU involves two source packages, landscape-client and smart (the latter being a dependency of the former) and that it follows the guidelines set forth in https://wiki.ubuntu.com/LandscapeUpdates.

====== landscape-client =======

* Statement explaining the impact:

  Some essential features have been developed since the versions of
  Landscape Client that are currently in Intrepid and Jaunty. We would
  like to make sure all of our supported customers (even those on
  Intrepid and Jaunty) have access to these features. The notable ones
  are custom graph support, managed EC2 instance support, a non-root
  mode, faster registration procedure and numerous bug fixes.

* How the bug has been addressed: We have been following the
  development procedure laid out in https://wiki.ubuntu.com/LandscapeUpdates

* The two branches for the new landscape-client intrepid and jaunty
  source packages are attached to this bug, and are were derived from

  lp:ubuntu/intrepid/landscape-client

  and

  lp:ubuntu/jaunty/landscape-client

  respectively.

* Detailed instructions how to reproduce the bug: N/A

* Discussion: The two source packages have been subject to the QA
  process detailed in the LandscapeUpdates docucment linked above. See
  also comment #14 of this bug for more details.

========= smart ==========

* Statement explaining the impact:

  The update to the version in jaunty fixes the two issues reported in
  Bug #388577 and Bug #389001, the first fixing a crash in case the
  rpm package is installed along with smartpm and the second fixing an
  HTTP timeout issue with curl (see the relevant bugs for more
  details).

  With respect to the version currently in intrepid, this SRU
  introduces a new upstream release, with bug fixes only. See

  http://lists.labix.org/pipermail/smart-labix.org/2009-March/003875.html

  In particular, beside the two fixes mentioned above, this release
  enables smart to inherit proxy settings from the landscape-client.

* The patches for the new smart intrepid and jaunty source packages
  are attached below in this bug (smart-intrepid4.patch and
  smart-jaunty3.patch), and were generated against the versions
  currently in intrepid and jaunty.

* Detailed instructions how to reproduce the bug: N/A

* Discussion: The two source packages have been subject to the same QA
  process followed for the landscape-client package. See also comment
  #14 of this bug for more details.

Christopher Armstrong (radix) wrote :

I have attached a working draft branch for the intrepid package. We are still in the process of the QA procedure outlined in https://wiki.ubuntu.com/LandscapeUpdates

summary: - update intrepid to landscape-client 1.0.28
+ update intrepid to landscape-client 1.0.29.1
description: updated
description: updated
summary: - update intrepid to landscape-client 1.0.29.1
+ update intrepid and jaunty to landscape-client 1.3.2.1

I have attached the branch to be used for the karmic upload (1.3.2.1-0ubuntu0.9.10.0). The upstream tarball consists for the mentioned branch without the debian/ directory and can be found here:

http://launchpad.net/landscape-client/1.4/1.3.2.1/+download/landscape-client-1.3.2.1.tar.gz

The source package has been uploaded and built in the Landscape PPA:

https://launchpad.net/~landscape/+archive/ppa

Andreas Hasenack (ahasenack) wrote :

Our QA according to the policy set forth in the wiki page mentioned a few comments up is starting now.

Andreas Hasenack (ahasenack) wrote :

This is the changelog for jaunty, which had 1.0.29.1:
  * New upstream release:
    - The init script does not wait for the network to be available
      before checking for EC2 user data (LP: #383336)
    - When the broker is restarted by the watchdog, the state of the client
      is inconsistent (LP: #380633)
    - Package stays unknown forever in the client with hash-id-databases
      support (LP: #381356)
    - Standard error not captured when calling smart-update (LP: #387441)
    - Changer calls reporter without switching groups, just user (LP: #388092)
    - Run smart update in the package-reporter instead of having a cronjob (LP: #362355)
    - Package changer does not inherit proxy settings (LP: #381241)
    - The ./test script doesn't work in landscape-client (LP: #381613)
    - The source package should build on all supported releases (LP: #385098)
    - Strip smart update's output (LP: #387331)
    - The fetch() timeout isn't based on activity (#389224)
    - Client can use a UUID of "None" when fetching the hash-id-database (LP: #381291)
    - Registration should use the fqdn rather than just the hostname (LP: #385730)

Andreas Hasenack (ahasenack) wrote :

Oops, plus this one:
- Fix reporting wrong version to the server (LP: #391225)

Andreas Hasenack (ahasenack) wrote :

Testing found bug #397480 which prevents 1.3.2.1 from being released. We will work on a 1.3.2.2 release and restart the process.

summary: - update intrepid and jaunty to landscape-client 1.3.2.1
+ update intrepid and jaunty to landscape-client 1.3.2.2

The proposed karmic branch doesn't include the latest version of the karmic package (1.0.29.1-0ubuntu0.9.04.1).

Could you prepare a new version that is based on the latest version in karmic (there is a bzr branch available at lp:ubuntu/karmic/landscape-client)? Could you also update the changelog to only have one entry for the upload, similar to:

landscape-client (1.3.2.2-0ubuntu0.9.10.0) karmic; urgency=low

  * New upstream release:
    - Include the README file in landscape-client (LP: #396260)
    - Fix client capturing stderr from run_command when constructing
      hash-id-databases url (LP: #397480)
    - Use substvars to conditionally depend on update-motd (LP: #393454)
    - Fix reporting wrong version to the server (LP: #391225)
    - The init script does not wait for the network to be available
      before checking for EC2 user data (LP: #383336)
    - When the broker is restarted by the watchdog, the state of the client
      is inconsistent (LP: #380633)
    - Package stays unknown forever in the client with hash-id-databases
      support (LP: #381356)
    - Standard error not captured when calling smart-update (LP: #387441)
    - Changer calls reporter without switching groups, just user (LP: #388092)
    - Run smart update in the package-reporter instead of having a cronjob (LP: #362355)
    - Package changer does not inherit proxy settings (LP: #381241)
    - The ./test script doesn't work in landscape-client (LP: #381613)
    - The source package should build on all supported releases (LP: #385098)
    - Strip smart update's output (LP: #387331)
    - The fetch() timeout isn't based on activity (#389224)
    - Client can use a UUID of "None" when fetching the hash-id-database (LP: #381291)
    - Registration should use the fqdn rather than just the hostname (LP: #385730)

 -- Free Ekanayaka <email address hidden> Tue, 09 Jun 2009 09:27:43 +0200

landscape-client (1.0.29.1-0ubuntu0.9.04.1) karmic; urgency=low

  * debian/control: depend on libpam-modules, rather than update-motd

 -- Dustin Kirkland <email address hidden> Thu, 16 Jul 2009 11:36:27 -0500

In this use case I've just merge all of the 1.3.2{,1,2} entries?

The lp:ubuntu/karmic/landscape-client/ and lp:~landscape-client/ branch have no common ancestor but you should be able to figure out which revision to merge from lp:~landscape-client/ into lp:ubuntu/karmic/landscape-client/.

Oh, I didn't notice that a new landscape-client was uploaded to karmic
last week.

I've merged the debian/changelog entry for 1.0.29.1-0ubuntu0.9.04.1
and the update-motd->libpam-modules dependency transition in

lp:~free.ekanayaka/landscape-client/jaunty

branch, and collapsed the various 1.3.2.{1,2} entries into a single
one. Doing that I've bumped the revision to 0ubuntu0.9.10.1 (note the
final 1), to differentiate it from the former 0ubuntu0.9.10.0, which
is in the Landscape PPA repository.

Please just pull the above branch and let me know if it looks better
now.

Thanks!

Queued for karmic. I'll upload once alpha3 is released.

Changed in landscape-client (Ubuntu):
status: New → Fix Committed
Mathias Gug (mathiaz) wrote :

I've modifed the Maintainer field in debian/control as specified in https://wiki.ubuntu.com/DebianMaintainerField.

As far as version is concerned, I would add a ~landscapeX suffix to the packages uploaded to the Landscape PPA so that upgrades from the archive are working correctly.

In this use case, 1.3.2.2-0ubuntu0.9.10.1~landscape1 would have been pushed to the landscape PPA, rather than 1.3.2.2-0ubuntu0.9.10.0.

Using a ~landscapeX suffix makes sense to me, thanks for the hint.

Please would you mind attaching the diff for debian/control? I'll
commit it to the branch.

On Thu, Jul 23, 2009 at 07:20:46AM -0000, Free Ekanayaka wrote:
> Using a ~landscapeX suffix makes sense to me, thanks for the hint.
>
> Please would you mind attaching the diff for debian/control? I'll
> commit it to the branch.
>

The maintainer field should be set to Ubuntu Developers [1] *only* for
packages uploaded to the Ubuntu archive. For the packages published in
the Landscape PPA it should be set to the Landscape team - so that users
of the landscape PPA don't contact the Ubuntu Developers team.

[1]: https://wiki.ubuntu.com/DebianMaintainerField

I'm not sure how many branches do you have, but I don't think that the
Maintainer field should be set to Ubuntu Developers in trunk/. If you
maintain a separate packaging branch for the ubuntu package it makes
sense to set the Maintainer field there.

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

summary: - update intrepid and jaunty to landscape-client 1.3.2.2
+ update intrepid and jaunty to landscape-client 1.3.2.3
description: updated
Mathias Gug (mathiaz) on 2009-09-01
Changed in landscape-client (Ubuntu):
assignee: nobody → Mathias Gug (mathiaz)
status: Fix Committed → Fix Released
Andreas Hasenack (ahasenack) wrote :

I completed the SRU requirements set forth in https://wiki.ubuntu.com/LandscapeUpdates with the following exceptions:
- couldn't complete the distro upgrade test from jaunty to karmic: karmic was too unstable at that point in time
- couldn't complete the distro upgrade test from hardy to intrepid: the upgrader (update-manager) crashed
- couldn't complete the distro upgrade test from dapper to hardy: the upgrader (update-manager) crashed

mvo said he would need access to a dapper machine to investigate the later, and is also aware of the hardy->intrepid crash.

During testing, I also found a bug in update-motd in jaunty: bug #422682. It doesn't clear the output of the individual scripts after they are removed. As a consequence, if someone chose to not display landscape-sysinfo output on login and removed the script, the motd would not be updated. Note this is not a bug in landscape-sysinfo, but people might think it is upon first inspection.

I attached two branches to this ticket and removed the previous ones. These branches are copies of the previous karmic branch, which was up-to-date and is even uploaded already. The only change is in debian/changelog saying each branch is a rebuilt for intrepid and jaunty.

Andreas Hasenack (ahasenack) wrote :

This update will also needs new smart packages. I'll need to attach branches for them too.

In the meantime, everything is built (landscape-client and smart) and available in the landscape ppa at https://launchpad.net/~landscape/+archive/ppa

Andreas Hasenack (ahasenack) wrote :

debdiff for jaunty

Andreas Hasenack (ahasenack) wrote :

Attached are diffs for jaunty and intrepid. These diffs were generated using simple diff -uNr in the patched source directory comparing the {jaunty,intrepid} directory with the landscape one, which represents the package I tested these last few months.

description: updated
Andreas Hasenack (ahasenack) wrote :

There is an error in the previous smart-intrepid and smart-jaunty diffs, I'm attaching the amended diffs here. The diff were generated against the smart source packages currently in intrepid and jaunty. Note that intrepid changes the upstream version (1.1.1~bzr2008101 vs 1.2).

For reference, the actual source and binary packages we tested can be found in the Landscape PPA:

https://launchpad.net/~landscape/+archive/ppa

Mathias Gug (mathiaz) wrote :

Opening relevant tasks for the smart package. Marking Fixed Released in the development version since smart 1.2 is in karmic.

Changed in smart (Ubuntu):
status: New → Fix Released
Changed in landscape-client (Ubuntu Intrepid):
status: New → Triaged
Changed in smart (Ubuntu Intrepid):
status: New → Triaged
Changed in smart (Ubuntu Jaunty):
status: New → Triaged
Changed in landscape-client (Ubuntu Jaunty):
status: New → Triaged
Changed in landscape-client (Ubuntu Intrepid):
importance: Undecided → Medium
Changed in landscape-client (Ubuntu Jaunty):
importance: Undecided → Medium
Changed in smart (Ubuntu Intrepid):
importance: Undecided → Medium
Changed in landscape-client (Ubuntu):
importance: Undecided → Medium
Changed in smart (Ubuntu):
importance: Undecided → Medium
Changed in smart (Ubuntu Jaunty):
importance: Undecided → Medium
Mathias Gug (mathiaz) wrote :

Could you clean up all the attached patch and branches to leave only the ones relevant to the sru?

All updates should be targeted to {intrepid,jaunty}-proposed instead of {intrepid,jaunty} since the latter are closed.

Each changelog entry should refer to this bug number so that SRU team can easily find this bug when they're reviewing the new package in the NEW queue.

The jaunty,intrepid sru changelog (and branches) should be based on the intrepid/jaunty changelog. There shouldn't be any mention of karmic in there. It should only document the changes between the existing version in intrepid/jaunty and the new one.

To make it easier for reviewing the diff, I'd suggest to attach a debdiff of the landscape-client SRU. Another solution is to branch the landscape-client package branch (at lp:ubuntu/jaunty/landscape-client and lp:ubuntu/intrepid/landscape-client) and import the new upstream tarball (using bzr merge-upstream from the bzr-builddeb plugin). Prepare and push the new branch and submit a merge proposal for the ubuntu/{jaunty,intrepid}/landscape-client branch and attach it to this bug. That way the diff can be easily seen and reviewed.

I've tweaked the debian/changelog of all four the packages (landscape-client intrepid/jaunty, smart intrepid/jaunty) to fix your points.

The new branches for landscape-client intrepid/jaunty now attached to the bug are derived from lp:ubuntu/jaunty/landscape-client and lp:ubuntu/intrepid/landscape-client. I've pushed them and submitted the merge request, do I have to set a particular reviewer?

For smart it's not possible to do the same, because there's no lp:ubuntu branch for it. Last week I raised the issue on #ubuntu-devel and I was told it's a bug in the importer, and that it should get eventually fixed. For now I'm attaching again the amended diffs, and changing the bug description to mention them.

Thanks for your feedback.

description: updated
description: updated
Mathias Gug (mathiaz) on 2009-10-01
Changed in landscape-client (Ubuntu Intrepid):
assignee: nobody → Mathias Gug (mathiaz)
Changed in landscape-client (Ubuntu Jaunty):
assignee: nobody → Mathias Gug (mathiaz)
Changed in smart (Ubuntu Intrepid):
assignee: nobody → Mathias Gug (mathiaz)
Changed in smart (Ubuntu Jaunty):
assignee: nobody → Mathias Gug (mathiaz)
Mathias Gug (mathiaz) on 2009-10-01
Changed in landscape-client (Ubuntu Jaunty):
status: Triaged → Fix Committed
Changed in smart (Ubuntu Jaunty):
status: Triaged → Fix Committed
Changed in smart (Ubuntu Intrepid):
status: Triaged → In Progress
Changed in landscape-client (Ubuntu Intrepid):
status: Triaged → In Progress
Mathias Gug (mathiaz) wrote :

I've uploaded both smart and landscape-client to jaunty-proposed.

Mathias Gug (mathiaz) wrote :

I've tried an intrepid version of smart using smart-intrepid3.patch. However the package fails to build from source:

1. The maintainer field should be updated as per https://wiki.ubuntu.com/DebianMaintainerField.

2. Even after updating the maintainer field the package still fails to build. It seems that some files have been removed from the .orig file:

dpkg-source: error: cannot represent change to smart-1.1.1~bzr20081010/tests/data/deb:
dpkg-source: error: new version is symlink to aptdeb/dists/component/binary-i386
dpkg-source: error: old version is directory
dpkg-source: warning: ignoring deletion of file tests/data/deb/Packages.gz
dpkg-source: warning: ignoring deletion of file tests/data/deb/name2_version2-release2_all.deb
dpkg-source: warning: ignoring deletion of file tests/data/deb/name1_version1-release1_all.deb
dpkg-source: warning: ignoring deletion of file tests/util/__init__.py
dpkg-source: unrepresentable changes to source
dpkg-buildpackage: failure: dpkg-source -i -I.bzr -I.svn -ICVS -b smart-1.1.1~bzr20081010 gave error exit status 1
debuild: fatal error at line 1329:
dpkg-buildpackage -rfakeroot -d -us -uc -i -I.bzr -I.svn -ICVS -S failed

Please post an intrepid-smart patch that works correctly.

Changed in smart (Ubuntu Intrepid):
status: In Progress → Triaged
Changed in landscape-client (Ubuntu Intrepid):
status: In Progress → Triaged
Mathias Gug (mathiaz) wrote :

The intrepid landscape-client looks good. However it should wait until the intrepid smart update is working as well.

Changed in landscape-client (Ubuntu Intrepid):
assignee: Mathias Gug (mathiaz) → nobody
Changed in smart (Ubuntu Intrepid):
assignee: Mathias Gug (mathiaz) → nobody

The problem is that there is difference between the upstream tarballs of the two versions.

In version 1.1.1~bzr20081010 (the one currently in intrepid) the tests/data/deb is a symlink to aptdeb/dists/component/binary-i386, while in version 1.2 (the target of this SRU) tests/data/deb is actually a directory, which has however the very same contents as aptdeb/dists/component/binary-i386. I'm going to check with the upstream developers if this was intentional or not.

The problem can be fixed manually by replacing the symlink with a copy of its target directory, but as far as I know these changes are not representable in a diff, so I'm attaching the diff.gz and .dsc to be used against the smart_1.2.orig.tar.gz tarball already in karmic/jaunty. This new attachment also fixes the Maintainer field.

The problem is that there is a difference between the upstream tarballs of the two versions.

In version 1.1.1~bzr20081010 (the one currently in intrepid) the tests/data/deb is a symlink to aptdeb/dists/component/binary-i386, while in version 1.2 (the target of this SRU) tests/data/deb is actually a directory, which has however the very same contents as aptdeb/dists/component/binary-i386. I'm going to check with the upstream developers if this was intentional or not.

The problem can be fixed manually by replacing the symlink with a copy of its target directory, but as far as I know these changes are not representable in a diff, so I'm attaching the diff.gz and .dsc to be used against the smart_1.2.orig.tar.gz tarball already in karmic/jaunty. This new attachment also fixes the Maintainer field.

Mathias Gug (mathiaz) on 2009-10-02
Changed in landscape-client (Ubuntu Intrepid):
status: Triaged → In Progress
assignee: nobody → Mathias Gug (mathiaz)
Changed in smart (Ubuntu Intrepid):
assignee: nobody → Mathias Gug (mathiaz)
status: Triaged → In Progress
Mathias Gug (mathiaz) wrote :

Thanks for providing an update smart package. I've uploaded both landscape-client and smart to intrepid-proposed.

Changed in smart (Ubuntu Intrepid):
status: In Progress → Fix Committed
Changed in landscape-client (Ubuntu Intrepid):
status: In Progress → Fix Committed

Thank you for all your help and feedback Mathias!

Martin Pitt (pitti) wrote :

I took a first look at the smart upload, and this seems unappropriate to me as an SRU. It is a very large delta, changes things which by far disqualify for an SRU, such as

 * bug 292542: Python 2.6 isn't even in intrepid
 * bug 388577: minor issue with a workaround
 * bug 354027: doesn't even say that intrepid is affected, or the scope of it
 * bug 268261: sounds like a new feature?
 * bug 116222: changes UI, not appropriate for stable

Also, please prepare those bugs to be proper SRUs: Add Ubuntu Karmic/Jaunty/Intrepid tasks, point out the karmic status, SRU rationale/impact, etc.

Martin Pitt (pitti) wrote :

Accepted landscape-client into intrepid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

The jaunty smart upload looks much better, just two small patches. Please prepare the bugs for SRU, as described in comment 33. I'm not that convinced that bug 388577 is worth SRUing, but please describe the impact in the bug.

Changed in smart (Ubuntu Intrepid):
status: Fix Committed → Triaged
Martin Pitt (pitti) wrote :

Accepted landscape-client into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Andreas Hasenack (ahasenack) wrote :

Regarding bug #388577, we have had landscape customers with RPM installed on their ubuntu machines, for one reason or another.

Andreas Hasenack (ahasenack) wrote :

To be more precise, the landscape package reporter (which is what is crashing) reports to the landscape server the packages installed and available on each managed machine. If it crashes, then the machine will show up in landscape has having no packages at all.

Andreas Hasenack (ahasenack) wrote :

bug #268261: this fix is critical, as we had customer installations being bitten by this bug before. smart would just hang there, doing nothing but blocking itself. As a result, landscape would not be able to manage the packages of this machine.

This still happens:
andreas@nsn2:~/canonical/scripts/queries$ ./search-stuck-smart.py 30
Computers where smart is stuck and that contacted us in the last 30 days:
xxxx
yyyy

The script above queries the landscape database. I sanitized its output.

I'm attaching a new diff for the smart intrepid SRU. It is much closer to the version currently in intrepid and contains only strictly necessary patches stripped down from the former proposed SRU. As requested, I changed the description of relevant smart bugs to meet the SRU requirements.

I've also updated the landscape-client intrepid branch for SRU, relaxing the dependency on python-smartpm.

Please Mathias, could you upload these new versions of smart and landscape-client?

Thanks!

description: updated
Chris J (chriscf) wrote :

Note that as of this time, this leaves a broken dependency in jaunty-proposed: landscape-common requires python-smartpm 1.2-0ubuntu1, available is 1.2-0ubuntu0.9.04 (bug 444743)

The broken dependency in landscape-client/jaunty-proposed is due to the new smart version not being available in proposed-updates yet. At the moment smart is still in the unapproved queue:

https://launchpad.net/ubuntu/jaunty/+queue?queue_state=1&queue_text=

but it should be processed shortly.

Martin Pitt (pitti) wrote :

Accepted smart into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Andreas Hasenack [2009-10-05 17:37 -0000]:
> Regarding bug #388577, we have had landscape customers with RPM
> installed on their ubuntu machines, for one reason or another.

And they didn't run away after this being broken a full year?

Anyway, patch is unintrusive, let's take this.

Changed in landscape-client (Ubuntu Jaunty):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Martin Pitt (pitti) wrote :

Accepted smart into intrepid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in smart (Ubuntu Intrepid):
status: Triaged → Fix Committed

I QA-ed the intrepid smart/landscape-client upload, following the guidelines here https://wiki.ubuntu.com/LandscapeUpdates. The jaunty packages were already QA-ed with the same procedure before the SRU upload.

So both the intrepid and jaunty landscape-client/smart packages in -proposed look good.

Is there something else required in order to push them to -updates?

Martin Pitt (pitti) wrote :

Thanks Free. Moving to -updates now, intrepid was in -proposed for more than 7 days.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package smart - 1.2-0ubuntu1.9.04.1

---------------
smart (1.2-0ubuntu1.9.04.1) jaunty-proposed; urgency=low

  * Bug fixing update (LP: #347983)
    - 04_detect_plugins.dpatch crasher fix (LP: #388577)
    - 05_curl_timeout.dpatch fix failures when downloading big packages (LP: #389001)

 -- Free Ekanayaka <email address hidden> Mon, 22 Jun 2009 18:27:19 +0200

Changed in smart (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 1.3.2.3-0ubuntu0.9.04.0

---------------
landscape-client (1.3.2.3-0ubuntu0.9.04.0) jaunty-proposed; urgency=low

  * New upstream release (LP: #347983):
    - Don't clear the hash_id_requests table upon resynchronize (LP #417122)
    - Include the README file in landscape-client (LP: #396260)
    - Fix client capturing stderr from run_command when constructing
      hash-id-databases url (LP: #397480)
    - Use substvars to conditionally depend on update-motd or
      libpam-modules (LP: #393454)
    - Fix reporting wrong version to the server (LP: #391225)
    - The init script does not wait for the network to be available
      before checking for EC2 user data (LP: #383336)
    - When the broker is restarted by the watchdog, the state of the client
      is inconsistent (LP: #380633)
    - Package stays unknown forever in the client with hash-id-databases
      support (LP: #381356)
    - Standard error not captured when calling smart-update (LP: #387441)
    - Changer calls reporter without switching groups, just user (LP: #388092)
    - Run smart update in the package-reporter instead of having a cronjob (LP: #362355)
    - Package changer does not inherit proxy settings (LP: #381241)
    - The ./test script doesn't work in landscape-client (LP: #381613)
    - The source package should build on all supported releases (LP: #385098)
    - Strip smart update's output (LP: #387331)
    - The fetch() timeout isn't based on activity (#389224)
    - Client can use a UUID of "None" when fetching the hash-id-database (LP: #381291)
    - Registration should use the fqdn rather than just the hostname (LP: #385730)

 -- Free Ekanayaka <email address hidden> Mon, 21 Sep 2009 17:59:31 +0200

Changed in landscape-client (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package smart - 1.1.1~bzr20081010-0ubuntu1.8.10.0

---------------
smart (1.1.1~bzr20081010-0ubuntu1.8.10.0) intrepid-proposed; urgency=low

  * Bug-fixing SRU (LP: #347983)
    - Added timeout for smart connections (LP: #268261)
    - New landscape plugin to set proxy for smart too,
      inheriting it from the landscape config (LP: #236884)
    - Added 04_detect_plugins crasher fix (LP: #388577)
    - Added 05_curl_timeout fix for failures when downloading big
      packages (LP: #389001)

 -- Free Ekanayaka <email address hidden> Wed, 07 Oct 2009 09:16:59 +0200

Changed in smart (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

landscape-client copied to intrepid-updates as well. Unfortunately the source.changes was misbuilt and didn't include the previous uploads,so the bugs need to be closed manually.

Changed in landscape-client (Ubuntu Intrepid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers