MOTD should not point to https://landscape.canonical.com if you are not a customer

Bug #268447 reported by Thierry Carrez on 2008-09-10
78
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Landscape Client
Undecided
Unassigned
update-motd
Undecided
Unassigned
ichthux-meta (Ubuntu)
Low
Ralph Janke
landscape-client (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: landscape-client

landscape-sysinfo is used to generate a MOTD message. By default, this message ends up with :

---
Graph these measurements at https://landscape.canonical.com
---

This graph service is only accessible to Landscape customers. The sysinfo module should probably differentiate between Landscape customers and regular users and avoid that sentence in the case you are not a Landscape client.

Jamie Strandboge (jdstrand) wrote :

It is an active choice to install landscape client, but as landscape-client is FLOSS and potentially can be used with other services besides Canonical, it seems clear that this advertising should not be present.

One solution might be to add an additional update-motd file can be added via a separate package that only Landscape customers would have installed.

Jamie Strandboge (jdstrand) wrote :

Actually, Thierry pointed out on IRC that landscape-client is Recommended by ubuntu-desktop, which means it will affect even more people.

Jamie Strandboge (jdstrand) wrote :

To clarify, I like the advertising in MOTD, but I think there should be a method via packaging to remove it to accommodate all users. I'm specifically thinking of users who want to use landscape-sysinfo, but not with Landscape. The current packaging requires users to modify configuration files after install, which may be problematic for certain classes of users. Another idea might be to add a low priority debconf question for landscape-sysinfo to not include the advertising, which would allow for preseeding and derivative distributions to modify this easily.

Christopher Armstrong (radix) wrote :

There's a configuration mechanism for selecting which plugins sysinfo should use, and each feature of sysinfo is implemented as a plugin, including the footer which prints the link to landscape.canonical.com. Unfortunately there is a bug which prevents the configuration from being read from /etc/landscape/, which I'll be fixing very soon.

Andreas Hasenack (ahasenack) wrote :

That other bug Chris mentions is #268560

Jeffrey Baker (jwbaker) wrote :

Landscape was automatically installed on my systems (I've never heard of it) and I consider its MOTD exhortations to visit landscape.canonical.com an intrusive form of unwanted commercial advertising. The message should be gotten rid of in MOTD, or whatever causes landscape to be installed automatically in Intrepid should be changed.

Mark Shuttleworth (sabdfl) wrote :

How intrusive is the link? My understanding is that it's a single link, and is configurable. Would there be better wording to lead folks to the ability to graph that information?

The current MOTD printed to the screen on login looks like this (and
is not intrusive at all, in my opinion):

---------------------------------------------------------------------------------------------------------------------
Linux t61p 2.6.27-4-generic #1 SMP Wed Sep 24 01:29:06 UTC 2008 x86_64

The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.

To access official Ubuntu documentation, please visit:
http://help.ubuntu.com/

  System load: 0.2 Swap usage: 0% Users logged in: 1
  Usage of /: 48.7% of 19.84GB Temperature: 43 C
  Memory usage: 35% Processes: 183

  Graph these measurements at https://landscape.canonical.com
You have new mail.
Last login: Tue Sep 30 13:19:32 2008 from localhost
---------------------------------------------------------------------------------------------------------------------

Jeffrey Baker (jwbaker) wrote :

Software written by me is shipping in Ubuntu, but a link to my commercial service is not printed in MOTD. See the problem? If everybody starts spamming up the links to their commercially supported products, the user will be seeing a lot more adverts. Basically it's a bad policy, and slight affront to the authors of the software you ship, and a nuisance to the user.

Kees Cook (kees) wrote :

I think Jeffrey put it well. If this package is installed by default, then every user logging into any stock Ubuntu server will see the advertisement. I think the fact that is it text makes it more problematic, since other kind of commercial advertisements tend to be in web applications, and blend in better (gallery2 and rt3 come to mind). Additionally, only the admin can take action with that link, so it's not really useful for other users to even see it.

Hugh Saunders (hughsaunders) wrote :

In my opinion there shouldn't be canonical adverts displayed in a default ubuntu install.
However if there are going to be adverts, it should be made obvious that they are for a product, not a free software project. Some users maybe unaware of the details of the ubuntu/canonical relationship and so wouldn't know from the URL that its not going to be free (beer).
People may think "mmm pretty graphs" and follow the link only to discover its a paid for service.

Scott Kitterman (kitterman) wrote :

I would like a clear policy statement on this. Is it OK if I add links for paid services I offer in related pacakges in Ubuntu?

Jonathan Marsden (jmarsden) wrote :

In case anyone is looking for a quick fix/workaround to this that still leaves landscape-client installed and generating hourly updated info in their /etc/motd:

Edit the last line of /etc/update-motd.d/50-landscape-sysinfo so that it reads

/usr/bin/landscape-sysinfo |/bin/grep -v https://landscape.canonical.com/

and the ad will disappear next time update-motd runs. To get rid of it right away, if you are in a really hurry for some reason, you can edit the file as above and then do:

   sudo update-motd --force

for instant ad removal.

Kees Cook (kees) wrote :

Actually, this is controllable via the contents of /etc/landscape/client.conf:

[sysinfo]
exclude_sysinfo_plugins = LandscapeLink

Thierry Carrez (ttx) wrote :

The message is not targeted only to current Landscape customers, so my bug is invalid.
See previous comment on how to disable that message by configuration.

Changed in landscape-client:
status: New → Invalid
Scott Kitterman (kitterman) wrote :

I disagree. I think it is a poor precedent to expose advertising for proprietary products in the default configuration. This should be opt-in, not opt-out. While this is not terribly intrusive, I think it sets a poor precedent.

"No advertising be default" is an easy rule to understand and implement. "Advertising shouldn't be intrusive" is much more subjective and will cause conflicts in the future. I'd prefer we had a simple, clear rule that we don't do this kind of thing in Ubuntu.

Changed in landscape-client:
status: Invalid → Confirmed
Andreas Hasenack (ahasenack) wrote :

Scott, is your main issue about Landscape being proprietary? Because there are precedents for advertising in other programs shipped with ubuntu, such as rrdtool/mrtg for example. It's the author advertising his site/project/work. In the landscape case, it's also the author of the program (canonical) advertising the site and service. And it's advertising landscape specifically, not the whole portfolio of products and services from the author.

Scott Kitterman (kitterman) wrote :

Yes. I wasn't aware of those and they aren't (AFAIK) part of the default
install. They particularly aren't presented to me every time I log in to the
system.

Consider if every package that is in the default install produces some kind of
advertising for it's developer and is present to the user on startup.
Clearly that's an untenable situation. I don't know of a sensible number
other than zero that will not be controversial. Additionally, Ubuntu
developers who happen to work for Canonical will be poorly positioned to deal
with more problematic cases (e.g. "What, it's OK for Canonical to advertise,
but no one else").

I see this as a slippery slope we're better off not starting down. If there
are other cases, as long as they aren't presented to the user by default as
part of a standard install, then I think they are not a problem.

Jonathan Marsden (jmarsden) wrote :

I can't even *find* the advertising in rrdtool.

rrdtool is not installed by default (in Intrepid), so I installed it. I then went through the tutorial to create a database and a few charts... nowhere do I see any ads for anything remotely resembling commercial services, nor links to anyone, unless you consider displaying the product name and it's author's name in the generated charts to be "advertising"? I did not read every page of rrdtool documentation, but if there are any ads in there, that's hardly obtrusive -- you have to actively read the documentation to discover them.

The contrast with the landscape-client /etc/motd ad is, I think, clear:

(a) Is the package installed by default? rrdtool: No; landscape-client: Yes

(b) Is the ad repeatedly presented to all system users, as opposed to only those who are actively choosing to use the package? rrdtool: No; landscape-client: Yes

Like ScottK, I think landscape-client sets a most unfortunate precedent, and that this should be reconsidered.

If even twenty packages (never mind two hundred packages) all added just one line of ad text each to /etc/motd , any real message of the day would be lost in the sea of ads. If this *is* permitted, the next level is to target desktop machines that use GUI logins, so presumably we will see graphical ads appearing because packages install their ad-display code into /etc/gdm/PostLogin/ ? I *really* do not think we want to go there. Applying the Golden Rule in this situation should therefore result in *no* packages placing ads in /etc/motd , or in any other way that displays ads to all users by default at login.

Perhaps the title of this bug report should be edited to something like "Packages should not display ads to all users by default" ?

IMO it would be perfectly fine for Kees' suggested configuration of landscape-client to be the default one. That looks to me like a good solution to this. Sysadmins who wish all their users to see the ad can then adjust their landscape-client configurations accordingly ;)

Steve McInerney (spm) wrote :

> I can't even *find* the advertising in rrdtool.

Which begs the question of how effective it is. :-)

fwiw, it's on *every* graph produced by rrdtool.
"rrdtool / tobi oetiker"

I'm not aware of any way to disable that string short of code hacks, but confess it's been about 8+ years since I last looked to try and find.

Nil (nicolas-limare) wrote :

@Steve: on the rrdtool graphs, the message tells us the software used, and its author; in the lansdcape motd, the message invites me to use a commercial service. it *is* very different.

Steve McInerney (spm) wrote :

@Nil: I disagree.
I see this as merely haggling over price, to abuse George Bernard Shaw's classic quote.

To rephrase my understanding of your position: Your suggestion is that advertising *is* acceptable. But you feel the line should be "here" - ie unacceptable for commercial companies.
And implying that it is quite acceptable for a developer to extol their skills, and effectively act as an (arguably :-) ) in-your-face advert to their skills and hence draw money that way.

From my perspective, the 6 pixels "height" used to write that text in RRDTool could be better spent on increasing the width of the graphs displayed - and hence increase the value of the graphs themselves. Further, the advertising text serves no purpose to enhance understanding of the graph, and thus should be excised. In line with the "rules" from several leading graphing experts (Tufte, Few et al).

Having said that? It's Tobi's project and I'm *profoundly* grateful for the existence of the tool in the first place. And if that's how he chooses to write it? So be it.

ymmv naturally. :-)

Nil (nicolas-limare) wrote :

@Steve: Well, I see the rrdtool text as "branding" : «this graph is made with the rrdtool, by tobi oetiker».

Even if, yes, there is no real value added by this text, it doesn't even suggest me to look at oetiker.ch, where I could ask for services. If landscape-client said "this is lanscape, by canonical", I would feel the same. Not very useful, but not a problem.

But lanscape-client says "use our commercial services", which is more of a "commercial", and that's why I don't feel the same.

Changed in update-motd:
status: New → Invalid

ichthux-desktop recommends landscape-client.

Ante Karamatić (ivoks) wrote :

Why not, instead of a link to landscape service it self, put a link to http://www.ubuntu.com/some/page/about/support. On that page, it could be described how to request support from Canonical, community, Canonical partners or merge landscape-client with some, in the future to be, other service.

Web page is more flexible than a hard coded link.

Bernd "Siggy" Brentrup (bsb) wrote :

I installed landscape-common after reading it's long description from the main
distribution on my 9.04, still having it on my TODO list for checking usefulness.
Only after posting to u-users about a new quality of SPAM in my /etc/motd I
learned that this package was the culprit.

Comparing the bunch of files this package installs to the limited usefulness
if you are not a landscape customer, it definitely is not worth installing.
I doubt the values diplayed in motd are of any use to anyone when login
in, they might be if current at the time of login but afaict they are generated
by a cron job, a python script generating this stuff on the fly would be <100 LOC.

Please change the wording in the long description to clarify the limited usefulness,
to non customers. If it can go into main with this restriction is another story, contrib
comes to mind in Debian terms

Thanks
  Siggy (ex-dd)

Xandros Pilosa (folivora) wrote :

Beside what was written, just another aspect to take into consideration.
As Siggy Brentrup pointed in ubuntu-users list, motd may be used for passing important information from admin to user on multi users systems and thus adding those kind of links, even in every plain user login, may be considered inefficiently redundant, especially if they are not landscape clients. If they are, I am sure they know to find landscape page.
Another question is, if it's really necessary to use web link in tty login, even if we consent with advertising?
Maybe the landscape-client motd entry should point to man pages and from there to whatever doc/www.page?

Regars

Ralph Janke (txwikinger) on 2009-09-23
Changed in ichthux-meta (Ubuntu):
assignee: nobody → Ralph Janke (txwikinger)
status: New → Confirmed
status: Confirmed → Triaged
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ichthux-meta - 1.0ubuntu12

---------------
ichthux-meta (1.0ubuntu12) karmic; urgency=low

  * Closes bug for sponsorship (LP: #435554)
  * Refreshed dependencies
  * Removed libstdc++5 (LP: #432018)
  * Removed kmplayer-konq-plugins from desktop
  * Removed gtk-qt-engine-kde4 from desktop (NBS)
  * Removed landscape-client from desktop (LP: #268447)
  * Removed armel, hppa, lpia, sparc

 -- Ralph Janke <email address hidden> Wed, 23 Sep 2009 01:37:35 +0000

Changed in ichthux-meta (Ubuntu):
status: In Progress → Fix Released
Ralph Janke (txwikinger) on 2009-09-24
Changed in ichthux-meta (Ubuntu):
importance: Undecided → Low
Benji York (benji) on 2016-01-11
Changed in landscape-client (Ubuntu):
status: Confirmed → Invalid
Changed in landscape-client:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers