Update trusty with landscape-client 16.03

Bug #1636477 reported by Bogdana Vereha on 2016-10-25
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
landscape-client (Ubuntu)
Undecided
Unassigned
Trusty
Medium
Eric Desrochers

Bug Description

[Impact]

Reference:
https://wiki.ubuntu.com/StableReleaseUpdates#New_upstream_microreleases

This SRU contains minor updates for landscape-client as follow :

- Fixed error caused by nonexistent directory on install (LP: #1546743)

- Fixed users tab issue that caused users not to be shown anymore (LP:#1508110)

- Reverted the change that introduced forced user database updates in the client (LP: #1532887)

- Stopped retrying package operations if a SystemError is raised (LP: #1444826)

- Restore behavior of the program exiting with a non-zero exit code in case of error during registration (LP: #1434546)

- Prevent backtrace during registration with inappropriate account/password combinations (LP: #1429888)

- Restore the API the charm depends on, add documentation as to its meaning and importance (LP: #1428826)

- Add a specific error message when the cause of registration failure is an SSL error. (LP: #1409700)

- Changed the package reporter so it retries running apt-get update when an error 100 is returned (LP: #1398090)

- Let the landscape-client-ui show up in Ubuntu MATE

[Test Case]

There is unfortunately no specific test cases since this is a bunch of bugfixes to improve landscape-client for Trusty users.

General dogfooding and all tests as outlined by the QA procedures here will have to be covered:
https://wiki.ubuntu.com/LandscapeUpdates

[Regression Potential]

* Potential risk is low :
 - Theses bugfixes has been proven to work for lansdcape-client Xenial and late
 - The debdiff has been provided by the Canonical Landscape team, which IMHO should bring even more confidence (CI verifications, ...)

* In term of testing, the usual SRU testing (sanity check, installation, usability, server-client scenarios using VM/container/....) will be done by the Landscape Squad within the Canonical support team.

* In addition, the "Packaging QA" testing as described here : https://wiki.ubuntu.com/LandscapeUpdates will also be performed during the testing phase. (see : https://bugs.launchpad.net/ubuntu/+source/landscape-client/+bug/1636477/comments/12)

The above should cover pretty much everything needed to make sure we have a solid new package to release in the field (trusty-updates)

[Other Info]

After a discussion with sil2100 (SRU verification member), explaining him the current situation. We came to an agreement to go ahead with a SRU + the additional Landscape testing.

[Original Description]

We would like to get the latest changes from Landscape Client release 16.03 (as released in Xenial, Yakkety and Zesty) into Trusty

As far as released version of Ubuntu are concerned, the required pieces of information for the needed SRU follow (as laid out in the "Procedure" section of https://wiki.ubuntu.com/StableReleaseUpdates).

=== Statement explaining the impact ===

This release adds bug-fixes that we would like all of our supported customers (even those on Trusty) to access. The notable ones are:

1) Bug #1546743 Fixed error caused by nonexistent directory on install
2) Bug #1508110 Fixed users tab issue that caused users not to be shown anymore
3) Bug #1532887 Reverted the change that introduced forced user database updates in the client.
4) Bug #1444826 Stopped retrying package operations if a SystemError is raised
5) Bug #1434546 Restore behavior of the program exiting with a non-zero exit code in case of error during registration
6) Bug #1429888 Prevent backtrace during registration with inappropriate account/password combinations
7) Bug #1428826 Restore the API the charm depends on, add documentation as to its meaning and importance
8) Bug #1409700 Add a specific error message when the cause of registration failure is an SSL error.
9) Bug #1398090 Changed the package reporter so it retries running apt-get update when an error 100 is returned

All changes above are mentioned in the debian/changelog of the proposed package.

=== How the bug has been addressed ===

The fixes for all the aforementioned bugs were backported from upstream.

=== Patches ===

The patch for the new landscape-client trusty source package is attached to this bug, and is derived from

lp:ubuntu/trusty-updates/landscape-client

Bogdana Vereha (bogdana) on 2016-10-25
description: updated
affects: ubuntu → landscape-client (Ubuntu)
Bogdana Vereha (bogdana) on 2016-10-25
Changed in landscape-client:
assignee: nobody → Bogdana Vereha (bogdana)
status: New → In Progress
Bogdana Vereha (bogdana) on 2016-11-01
description: updated
Bogdana Vereha (bogdana) on 2016-11-01
description: updated
description: updated
Bogdana Vereha (bogdana) on 2016-11-01
no longer affects: landscape-client
Changed in landscape-client (Ubuntu):
status: New → In Progress
assignee: nobody → Bogdana Vereha (bogdana)
Changed in landscape-client (Ubuntu Trusty):
assignee: nobody → Bogdana Vereha (bogdana)
status: New → In Progress
Bogdana Vereha (bogdana) on 2016-11-02
description: updated
Bogdana Vereha (bogdana) on 2016-11-02
description: updated
Bogdana Vereha (bogdana) on 2016-11-16
description: updated
Bogdana Vereha (bogdana) on 2016-11-16
Changed in landscape-client (Ubuntu):
assignee: Bogdana Vereha (bogdana) → nobody
Changed in landscape-client (Ubuntu Trusty):
assignee: Bogdana Vereha (bogdana) → nobody
tags: added: verification-needed
Bogdana Vereha (bogdana) wrote :

@andreas, could you please upload the package to -proposed?
It's already published in this PPA: https://launchpad.net/~ursinha/+archive/ubuntu/sandbox

Andreas Hasenack (ahasenack) wrote :

The package from that PPA has a version number we cannot use in the SRU: 14.12+bzr69-0ubuntu0

I'm going to build one from the branch attached to this bug.

Andreas Hasenack (ahasenack) wrote :

Any reason why we didn't pull in the fix for https://bugs.launchpad.net/landscape-client/+bug/1531150? I might have forgotten.

Andreas Hasenack (ahasenack) wrote :

Ah, probably because it's not in xenial and this first SRU is to bring trusty up to par with xenial.

summary: - Update trusty with the latest changes in landscape-client
+ Update trusty with the landscape-client 16.03
description: updated
description: updated
summary: - Update trusty with the landscape-client 16.03
+ Update trusty with landscape-client 16.03
Andreas Hasenack (ahasenack) wrote :

The upload was rejected:
"""
Rejected:
Rejected by Robie Basak: 14.12-0ubuntu3.14.04 has previously been published in trusty-proposed; further uploads must have a higher version, but 14.12-0ubuntu1.14.04 as uploaded is lower

landscape-client (14.12-0ubuntu1.14.04) trusty; urgency=medium

  * Minor update (LP: #1636477):
    - Fixed error caused by nonexistent directory on install (LP: #1546743)
    - Fixed users tab issue that caused users not to be shown anymore (LP: #1508110)
    - Reverted the change that introduced forced user database updates in the client (LP: #1532887)
    - Stopped retrying package operations if a SystemError is raised (LP: #1444826)
    - Restore behavior of the program exiting with a non-zero exit code in case of error during registration (LP: #1434546)
    - Prevent backtrace during registration with inappropriate account/password combinations (LP: #1429888)
    - Restore the API the charm depends on, add documentation as to its meaning and importance (LP: #1428826)
    - Add a specific error message when the cause of registration failure is an SSL error. (LP: #1409700)
    - Changed the package reporter so it retries running apt-get update when an error 100 is returned (LP: #1398090)
    - Let the landscape-client-ui show up in Ubuntu MATE

Date: Tue, 01 Nov 2016 17:39:30 +0100
Changed-By: Bogdana Vereha <email address hidden>
Maintainer: Ubuntu Developers <email address hidden>
Signed-By: Andreas Hasenack <email address hidden>
"""

Andreas Hasenack (ahasenack) wrote :

I uploaded landscape-client_14.12-0ubuntu4.14.04_source.changes with the new version and fixed changelog.

Björn Tillenius (bjornt) wrote :

The uploaded version 14.12-0ubuntu4.14.04 was rejected, because we needed to push through an SRU for bug 1668583.

Changed in landscape-client (Ubuntu Trusty):
status: In Progress → Confirmed
Changed in landscape-client (Ubuntu):
status: In Progress → Confirmed
Eric Desrochers (slashd) on 2017-08-02
tags: added: sts sts-sru-needed
removed: verification-needed
Simon Poirier (simpoir) wrote :

I've rebased the fixes in the branch on top of 14.12-0ubuntu5.14.04 and verified everything is there.

Eric Desrochers (slashd) wrote :

Thanks Simon,

I'll have a look tomorrow and will then upload it in the Trusty upload queue.

- Eric

Changed in landscape-client (Ubuntu Trusty):
status: Confirmed → In Progress
Changed in landscape-client (Ubuntu):
status: Confirmed → Fix Released
Changed in landscape-client (Ubuntu Trusty):
importance: Undecided → Medium
assignee: nobody → Bogdana Vereha (bogdana)
Changed in landscape-client (Ubuntu Trusty):
assignee: Bogdana Vereha (bogdana) → Eric Desrochers (slashd)
Eric Desrochers (slashd) wrote :

During the testing phase (trusty-proposed) .... additionally to the usual SRU verification-$RELEASE-done testing, note that extra testing (landscape-client specific) will also be needed :

https://wiki.ubuntu.com/LandscapeUpdates (Sectionl Packaging QA)

Regards,
Eric

Eric Desrochers (slashd) on 2017-08-07
description: updated
description: updated
description: updated
Simon Poirier (simpoir) wrote :

I've updated the debdiff, for patches to apply without offset.

Eric Desrochers (slashd) wrote :

Simon's work has been uploaded in the Trusty upload queue for the SRU Verification team approval before it starts building in trusty-proposed for the testing phase.

- Eric

description: updated

Hello Bogdana, or anyone else affected,

Accepted landscape-client into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/landscape-client/14.12-0ubuntu6.14.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in landscape-client (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-trusty
David Coronel (davecore) wrote :

Completed tests from https://wiki.ubuntu.com/LandscapeUpdates:

-upgrade test from previous distribution to the current one. If the current distribution is an LTS one, the upgrade path from the previous LTS distro must also be exercised. --> Success (added trusty-proposed to sources.list before do-release-upgrade to go straight to newest version of landscape-client)

-upgrade test from previous version of the package. This test must be performed with:
--apt-get install/upgrade --> Success
--using the Landscape service itself --> Success

-installation from scratch in the current distribution:
--using apt-get --> Success

-test interaction with update-motd to make sure the motd doesn't get trashed or otherwise impaired by landscape-common:
--reboot and make sure motd is displayed correctly and not trashed --> Success
--when update-motd is used by landscape-sysinfo (it's the default), make sure its call to landscape-sysinfo works and the output is included in the motd --> Success

--provoke an error (backtrace) in landscape-sysinfo plugin by running sudo chmod 0 /proc: the backtrace must not be included in the motd --> Couldn't provoke backtrace with chmod of /proc or /proc/cpuinfo:
 chmod: changing permissions of ‘/proc’: Operation not permitted
 chmod: changing permissions of ‘/proc/cpuinfo’: Operation not permitted

Completed additional tests with certain fixes:

- Add a specific error message when the cause of registration failure is an SSL error. (LP: #1409700)

BEFORE (14.12-0ubuntu5.14.04):

We were unable to contact the server. Your internet connection may be down. The landscape client will continue to try and contact the server periodically.

AFTER (14.12-0ubuntu6.14.04):

The server's SSL information is incorrect, or fails signature verification!
If the server is using a self-signed certificate, please ensure you supply it with the --ssl-public-key parameter.

- Changed the package reporter so it retries running apt-get update when an error 100 is returned (LP: #1398090)

BEFORE (14.12-0ubuntu5.14.04):

2017-08-08 18:51:40,112 WARNING [MainThread] '/usr/lib/landscape/apt-update' exited with status 100 (E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
)

AFTER (14.12-0ubuntu6.14.04):

2017-08-08 18:49:33,148 WARNING [MainThread] Could not acquire the apt lock. Retrying in 20 seconds.
2017-08-08 18:50:03,649 WARNING [MainThread] Could not acquire the apt lock. Retrying in 40 seconds.
2017-08-08 18:50:53,123 WARNING [MainThread] '/usr/lib/landscape/apt-update' exited with status 100 (E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
)

Eric Desrochers (slashd) on 2017-08-09
tags: added: verification-done-trusty
removed: verification-needed verification-needed-trusty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 14.12-0ubuntu6.14.04

---------------
landscape-client (14.12-0ubuntu6.14.04) trusty; urgency=medium

  * Minor updates (LP: #1636477):
    - Fixed error caused by nonexistent directory on install.
    - Fixed users tab issue that caused users not to be shown anymore.
    - Reverted the change that introduced forced user database updates
      in the client.
    - Stopped retrying package operations if a SystemError is raised.
    - Restore behavior of the program exiting with a non-zero exit code
      in case of error during registration.
    - Prevent backtrace during registration with inappropriate account/
      password combinations.
    - Restore the API the charm depends on, add documentation as to its
      meaning and importance.
    - Add a specific error message when the cause of registration failure
      is an SSL error.
    - Changed the package reporter so it retries running apt-get update
      when an error 100 is returned.
    - Let the landscape-client-ui show up in Ubuntu MATE.

 -- Bogdana Vereha <email address hidden> Tue, 01 Nov 2016 17:39:30 +0100

Changed in landscape-client (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for landscape-client has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers