package-reporter doesn't get proxy settings from client.conf

Bug #1531150 reported by Andreas Hasenack on 2016-01-05
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Landscape Client
High
Simon Poirier
landscape-client (Ubuntu)
High
Andreas Hasenack
Trusty
High
Andreas Hasenack
Xenial
High
Andreas Hasenack
Zesty
High
Andreas Hasenack
Artful
High
Andreas Hasenack

Bug Description

[Impact]

The package reporter is not getting the proxy settings set in /etc/landscape/client.conf. As a result, fetching hash-id-database file and running the SUID root /usr/lib/landscape/apt-update helper fail. Even though the binary it calls in turn fails (apt-get itself), the exit code is 0. It's only seen in the logs if using debug mode.

[Test Case]
Here we want to block direct access from a client to landscape.canonical.com and the ubuntu archive, forcing it to use a proxy we will setup. That's how we will determine that the bug is fixed.

DO NOT set proxy environment variables, as these will be picked up by the client when it's restarted and give a false good test result. We want to be sure the values are being grabbed from the config file, and not the environment.

DO NOT set proxy values in /etc/environment.

* Create an ubuntu container or VM, take note of its IP address, and install the proposed landscape-client package on it.

sudo apt install landscape-client

Also make sure dnsutils is installed:
sudo apt install dnsutils

* Enable debugging on the client. Edit /etc/landscape/client.conf and make sure this line is there:
log_level = debug

* Block direct access to landscape.canonical.com:
for ip in $(dig +short landscape.canonical.com); do sudo iptables -A OUTPUT -d $ip -j REJECT; done

Do the same for your ubuntu archive or whatever mirror you are using (note: this won't work if you have ipv6 enabled):
for ip in $(dig +short archive.ubuntu.com; do sudo iptables -A OUTPUT -d $ip -j REJECT; done

* Confirm that this access is indeed blocked:
$ telnet landscape.canonical.com 80
Trying 91.189.90.173...
Trying 91.189.89.90...
telnet: Unable to connect to remote host: Connection refused
$ telnet landscape.canonical.com 443
Trying 91.189.89.90...
Trying 91.189.90.173...
telnet: Unable to connect to remote host: Connection refused

* Verify that apt-get update is blocked for the archive (your ips might differ, here I'm using a mirror):
$ sudo apt update
(...)
Err:2 http://br.archive.ubuntu.com/ubuntu xenial InRelease
  Cannot initiate the connection to br.archive.ubuntu.com:80 (2801:82:80ff:8000::5). - connect (101: Network is unreachable) [IP: 2801:82:80ff:8000::5 80]

* In a xenial container, install the squid proxy server:
sudo apt install squid3

* Take note of the IP of this container

* Edit /etc/squid/squid.conf and make these changes:
- locate the "#acl localnet src" block of lines and add one for the network where the landscape-client container you created before has an IP. For example:
acl localnet src 10.0.0.0/8
- locate the "#http_access allow localnet" line and remove the comment:
http_access allow localnet

* Restart squid:
sudo service squid restart

* Keep tailing the squid access logs:
sudo tail -f /var/log/squid/access.log

* Go back to the landscape-client container

* Verify that the proxy is allowing your connections, and that without the proxy it fails:
ubuntu@xenial-client-sru:~$ http_proxy=http://xenial-proxy.lxd:3128/ curl http://landscape.canonical.com/ping ;echo
ds5:errors19:provide insecure_id;
ubuntu@xenial-client-sru:~$ curl http://landscape.canonical.com/ping ;echo
curl: (7) Failed to connect to landscape.canonical.com port 80: Connection refused

* Same for https:
ubuntu@xenial-client-sru:~$ https_proxy=http://xenial-proxy.lxd:3128 curl https://landscape.canonical.com/message-system;echo
Landscape message server
ubuntu@xenial-client-sru:~$ curl https://landscape.canonical.com/message-system;echo
curl: (7) Failed to connect to landscape.canonical.com port 443: Connection refused

* in a terminal, tail the (still non existing) package-reporter logs:
sudo tail -F /var/log/landscape/package-reporter.log

* in another terminal, tail the (still non existing) broker log:
sudo tail -F /var/log/landscape/broker.log

* register the client with a landscape server. In this example we are going to use landscape.canonical.com and the proxy we just configured (replace <proxy> with the IP of the squid container we created above):

sudo landscape-config -a <youraccount> -u https://landscape.canonical.com/message-system --ping-url http://landscape.canonical.com/ping -t sru-proxy-test --silent --http-proxy=http://<proxy>:3128/ --https-proxy=http://<proxy>:3128/ --apt-update-interval=300

* the proxy access logs should show some activity already:
1511531199.415 1230 127.0.0.1 TCP_TUNNEL/200 4474 CONNECT landscape.canonical.com:443 - HIER_DIRECT/91.189.89.90 -
1511531229.909 485 127.0.0.1 TCP_MISS/200 357 POST http://landscape.canonical.com/ping - HIER_DIRECT/91.189.89.90 text/html

That's the registration request (port 443) and the ping (port 80)

* go to landscape.canonical.com, login and accept the new pending computer we just created

* monitor package-reporter.log. At some point it should log that it downloaded the hash-id-database:
2017-11-24 14:31:24,203 INFO [MainThread] Downloaded hash=>id database from https://landscape.canonical.com/hash-id-databases/af6f2dcf-1967-11de-8dd0-001a4b4d8d10_xenial_amd64

Since this is via https, it will be hard to match it to a proxy access log, but since we blocked direct access to landscape, we know this download happened via the proxy. That's one bug fix confirmed.

* also in package-reporter.log, keep an eye out for the apt run. Something like this indicates it worked:
2017-11-24 14:35:17,736 DEBUG [MainThread] '/usr/lib/landscape/apt-update' exited with status 0 (out='Hit:1 http://br.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://br.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:3 http://br.archive.ubuntu.com/ubuntu xenial-backports InRelease
Hit:4 http://br.archive.ubuntu.com/ubuntu xenial-security InRelease
Reading package lists...
', err='')
i.e., no error reported

There should also be matching entries in the proxy access logs:
1511534116.438 27 10.0.100.95 TCP_MISS/304 251 GET http://br.archive.ubuntu.com/ubuntu/dists/xenial/InRelease - HIER_DIRECT/200.236.31.4 -
1511534116.442 3 10.0.100.95 TCP_MISS/304 251 GET http://br.archive.ubuntu.com/ubuntu/dists/xenial-updates/InRelease - HIER_DIRECT/200.236.31.4 -
1511534116.445 3 10.0.100.95 TCP_MISS/304 251 GET http://br.archive.ubuntu.com/ubuntu/dists/xenial-backports/InRelease - HIER_DIRECT/200.236.31.4 -
1511534116.449 3 10.0.100.95 TCP_MISS/304 251 GET http://br.archive.ubuntu.com/ubuntu/dists/xenial-security/InRelease - HIER_DIRECT/200.236.31.4 -

That confirms that apt-update was given the proxy information by landscape from the package-reporter, and confirms that the package-reporter got the proxy information.

These two verifications (hash-id download, and apt update run) confirm this bug is fixed.

[Regression Potential]
Regressions in this area will basically prevent the client from fetching package information from the ubuntu archive and whatever other repositories are configured. This situation would be obvious enough by checking the lack of updates available for the registered computers, which is the problem this patch is fixing. What's important is that communication with the server would remain unaffected.

Should a major regression creep in, something that prevents the client from communicating with the server, then the server would eventually issue a "computer offline" alert and the admin would have to investigate. What could be troublesome is if the only means of accessing the computer is via landscape. This should be rare, as ssh usage is widespread.

[Other Info]

* Upstream revision:
http://bazaar.launchpad.net/~landscape/landscape-client/trunk/revision/919

This PPA has test packages built from the attached branches, using a ~ppaN suffix:
https://launchpad.net/~ahasenack/+archive/ubuntu/lsclient-sru-1721383

--- Original description ---

The package reporter is not getting the proxy settings set in /etc/landscape/client.conf. It will honor the environment variables if they are somehow set when landscape-client is started, but not if the values are just defined in that configuration file.

As a result, the following fails:
- fetching hash-id-database file
- running the SUID root /usr/lib/landscape/apt-update helper. Even though the binary it calls in turn fails (apt-get itself), the exit code is 0. It's only seen in the logs if using debug mode.

Logs from a run on a test system which is prohibited from accessing the internet directly, but does have the proxy settings in client.conf:
2016-01-05 12:41:25,678 DEBUG [MainThread] '/usr/lib/landscape/apt-update' exited with status 0 (out='Err http://archive.ubuntu.com trusty InRelease

Err http://archive.ubuntu.com trusty-updates InRelease

Err http://archive.ubuntu.com trusty-security InRelease

Err http://archive.ubuntu.com trusty Release.gpg
  Unable to connect to archive.ubuntu.com:http:
Err http://archive.ubuntu.com trusty-updates Release.gpg
  Unable to connect to archive.ubuntu.com:http:
Err http://archive.ubuntu.com trusty-security Release.gpg
  Unable to connect to archive.ubuntu.com:http:
Reading package lists...
', err='W: Failed to fetch http://archive.ubuntu.com//ubuntu/dists/trusty/InRelease

W: Failed to fetch http://archive.ubuntu.com//ubuntu/dists/trusty-updates/InRelease

W: Failed to fetch http://archive.ubuntu.com//ubuntu/dists/trusty-security/InRelease

W: Failed to fetch http://archive.ubuntu.com//ubuntu/dists/trusty/Release.gpg Unable to connect to archive.ubuntu.com:http:

W: Failed to fetch http://archive.ubuntu.com//ubuntu/dists/trusty-updates/Release.gpg Unable to connect to archive.ubuntu.com:http:

W: Failed to fetch http://archive.ubuntu.com//ubuntu/dists/trusty-security/Release.gpg Unable to connect to archive.ubuntu.com:http:

W: Some index files failed to download. They have been ignored, or old ones used instead.
')
2016-01-05 12:41:27,861 WARNING [MainThread] Couldn't download hash=>id database: Error 7: Failed to connect to landscape.canonical.com port 443: Connection refused
2016-01-05 12:41:28,012 DEBUG [MainThread] Started firing stop.
2016-01-05 12:41:28,012 DEBUG [MainThread] Finished firing stop.

Broker exchanges work just fine, as do the client pings.

One has to be careful when trying to reproduce this bug, as there are many ways the environment values can leak into the process and invalidate the test.

For example, if you have the http_proxy and https_proxy variables in root's environment, and restart the client, it will inherit those, and invalidate the test.

Or let's say you have them in ubuntu's environment, and use sudo to restart the client. They won't be propagated to the daemon by default unless -E is used, and/or the proxy variables are whitelisted in /etc/sudoers.

Related branches

tags: added: proxy theme-proxy
tags: added: bug-squad kanban
Andreas Hasenack (ahasenack) wrote :

A workaround is two-fold:

a) add the proxy lines to /etc/default/landscape-client;
export http_proxy=http://<your-proxy>/
export https_proxy=http://<your-proxy>/
export no_proxy=localhost,127.0.0.1,<others-if-needed>

Obviously replace <your-proxy> with your proxy IP/hostname, and port if needed.

That takes care of the hash-id download problem.

b) for the apt-get update suid root wrapper, create this file /etc/apt/apt.conf.d/50-proxy:
Acquire::http::Proxy "http://<your-proxy>/";
Acquire::https::Proxy "http://<your-proxy>/";

Again, replace <your-proxy> as before.

Chad Smith (chad.smith) on 2016-01-06
tags: removed: kanban

The following patch fixes the problem by reading the settings from client.conf and exporting them during startup of landscape-client:
--- landscape-client~ 2015-01-05 13:58:29.000000000 +0100
+++ landscape-client 2016-01-08 08:13:37.371883059 +0100
@@ -55,6 +55,10 @@
                        fi
                fi

+ # Read proxy settings from /etc/landscape/client.conf, fixes
+ # https://bugs.launchpad.net/landscape-client/+bug/1531150
+ eval `grep -E ^https?_proxy /etc/landscape/client.conf | sed 's/[[:space:]]//g;s/^/export /'`
+
                FULL_COMMAND="start-stop-daemon --start --quiet --oknodo --startas $DAEMON --pidfile $PIDFILE -g $DAEMON_GROUP -- --daemon --pid-file $PIDFILE"
                if [ x"$DAEMON_USER" != x ]; then
                        sudo -u $DAEMON_USER $FULL_COMMAND

Attached patch as file since launchpad garbled it in the previous comment.

Andreas Hasenack (ahasenack) wrote :

Thanks, but that won't fix the other case we identified where the reporter calls apt-get update via a suid root wrapper. The suid wrapper strips the environment variables, so the proxy ones never get there and the call silently fails.

True, it's a partial fix only (fixes the part that affected me). We still need to fix /usr/lib/landscape/apt-update to properly report the error from apt-get.

The setup of the proxy configuration for apt is usually done during the initial installation of a machine, so I doubt the problem would go unnoticed for long (you can't even install landscape using apt unless the proxy is setup correctly).

Andreas Hasenack (ahasenack) wrote :

Actually, it's apt-get itself that is returning zero...:

root@trusty-landscape-devel:~# iptables -A OUTPUT -p tcp --dport 80 -j REJECT
root@trusty-landscape-devel:~# apt-get update
Err http://br.archive.ubuntu.com trusty InRelease

Err http://br.archive.ubuntu.com trusty-updates InRelease

Err http://br.archive.ubuntu.com trusty Release.gpg
  Cannot initiate the connection to br.archive.ubuntu.com:80 (2801:82:80ff:8000::5). - connect (101: Network is unreachable) [IP: 2801:82:80ff:8000::5 80]
Err http://br.archive.ubuntu.com trusty-updates Release.gpg
  Cannot initiate the connection to br.archive.ubuntu.com:80 (2801:82:80ff:8000::5). - connect (101: Network is unreachable) [IP: 2801:82:80ff:8000::5 80]
(...)
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/trusty-security/Release.gpg Cannot initiate the connection to security.ubuntu.com:80 (2001:67c:1562::17). - connect (101: Network is unreachable) [IP: 2001:67c:1562::17 80]

W: Some index files failed to download. They have been ignored, or old ones used instead.
root@trusty-landscape-devel:~# echo $?
0
root@trusty-landscape-devel:~#

The problem of apt-get returning zero was fixed in 1999:
  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=41053

... but reintroduced again later:
  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=696335

tags: added: lds-squad
Changed in landscape-client:
status: New → Triaged
tags: added: kanban
tags: removed: kanban
Simon Poirier (simpoir) on 2016-07-21
Changed in landscape-client:
assignee: nobody → Simon Poirier (simpoir)
Simon Poirier (simpoir) on 2016-07-21
Changed in landscape-client:
status: Triaged → In Progress
Changed in landscape-client:
status: In Progress → Fix Committed
Andreas Hasenack (ahasenack) wrote :

This is indeed fixed now. If someone wants to try it before we make an official landscape-client release, the daily builds ppa has it: ppa:landscape/trunk

Roy Zuo (roylez) wrote :

Is there any plan to backport the fix to trusty build? This issue affects many.

Simon Poirier (simpoir) wrote :
Simon Poirier (simpoir) wrote :
Simon Poirier (simpoir) on 2017-09-28
Changed in landscape-client:
status: Fix Committed → Fix Released

The attachment "Proposed patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in landscape-client (Ubuntu):
status: New → In Progress
assignee: nobody → Andreas Hasenack (ahasenack)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 16.03-0ubuntu4

---------------
landscape-client (16.03-0ubuntu4) bionic; urgency=medium

  [ Simon Poirier]
  * Update landscape-client with upstream fixes (LP: #1721383):
    - Add proxy handling to package reporter. (LP: #1531150)
    - Fix regression in configuration hook under install-cd chroot (LP: #1699789)
    - Report autoremovable packages (LP: #1208393)
    - Do not re-register client by default (LP: #1618483)
    - Remove diff "noise" from d/p/ignore-backports-1668583.diff

 -- Andreas Hasenack <email address hidden> Fri, 10 Nov 2017 12:26:23 -0200

Changed in landscape-client (Ubuntu):
status: In Progress → Fix Released
Eric Desrochers (slashd) on 2017-11-23
description: updated
Eric Desrochers (slashd) on 2017-11-23
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
Changed in landscape-client (Ubuntu Trusty):
status: New → In Progress
Changed in landscape-client (Ubuntu Xenial):
status: New → In Progress
Changed in landscape-client (Ubuntu Zesty):
status: New → In Progress
Changed in landscape-client (Ubuntu Artful):
status: New → In Progress
Changed in landscape-client (Ubuntu Trusty):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in landscape-client (Ubuntu Xenial):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in landscape-client (Ubuntu Zesty):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in landscape-client (Ubuntu Artful):
assignee: nobody → Andreas Hasenack (ahasenack)

Hello Andreas, or anyone else affected,

Accepted landscape-client into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/landscape-client/16.03-0ubuntu3.17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in landscape-client (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
Łukasz Zemczak (sil2100) wrote :

Hello Andreas, or anyone else affected,

Accepted landscape-client into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/landscape-client/16.03-0ubuntu3.17.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in landscape-client (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed-zesty
Łukasz Zemczak (sil2100) wrote :

Hello Andreas, or anyone else affected,

Accepted landscape-client into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/landscape-client/16.03-0ubuntu2.16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in landscape-client (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hello Andreas, or anyone else affected,

Accepted landscape-client into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/landscape-client/14.12-0ubuntu6.14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in landscape-client (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed-trusty
David Coronel (davecore) wrote :

I tested upgrading the new landscape-client on artful, zesty, xenial and trusty from the current most recent landscape-client version currently available in each release. I didn't test this particular fix but I confirm the package upgrade works fine and the client runs fine afterwards.

Changed in landscape-client (Ubuntu):
importance: Undecided → High
Changed in landscape-client (Ubuntu Trusty):
importance: Undecided → High
Changed in landscape-client (Ubuntu Xenial):
importance: Undecided → High
Changed in landscape-client (Ubuntu Zesty):
importance: Undecided → High
Changed in landscape-client (Ubuntu Artful):
importance: Undecided → High
Eric Desrochers (slashd) wrote :

Please test with the above [Test Case] in the description.

- Eric

David Coronel (davecore) wrote :

I tested this fix on trusty, xenial, zesty and artful. I followed the test case in the description. I confirm I see the hash-id download and apt update run messages.

One small note, on artful I get the following:

2017-12-04 14:50:20,311 WARNING [MainThread] Couldn't download hash=>id database: Server returned HTTP code 404

But this is probably the database really not existing on the server, otherwise I wouldn't get a 404.

Attaching screenshot of my tests.

David Coronel (davecore) wrote :
Eric Desrochers (slashd) on 2017-12-04
tags: added: verification-done-artful verification-done-trusty verification-done-xenial verification-done-zesty
removed: verification-needed-artful verification-needed-trusty verification-needed-xenial verification-needed-zesty

On Mon, Dec 04, 2017 at 02:54:17PM -0000, David Coronel wrote:
> 2017-12-04 14:50:20,311 WARNING [MainThread] Couldn't download hash=>id
> database: Server returned HTTP code 404
>

Linked related MP up in the private landscape project:
https://code.launchpad.net/~simpoir/landscape/add-artful-hashids/+merge/334680

Note, this warning should not block verification as it is purely a
server side change and the client deals with this missing hash-id
database files right now gracefully.

--
David Britton <email address hidden>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 16.03-0ubuntu3.17.10.1

---------------
landscape-client (16.03-0ubuntu3.17.10.1) artful; urgency=medium

  [ Simon Poirier ]
  * Add proxy handling to package reporter. (LP: #1531150)
  * Fix regression in configuration hook under install-cd chroot (LP: #1699789)
  * Report autoremovable packages (LP: #1208393)
  * No not re-register client by default (LP: #1618483)

 -- Andreas Hasenack <email address hidden> Fri, 10 Nov 2017 15:44:17 -0200

Changed in landscape-client (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for landscape-client has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 16.03-0ubuntu3.17.04.1

---------------
landscape-client (16.03-0ubuntu3.17.04.1) zesty; urgency=medium

  [ Simon Poirier ]
  * Add proxy handling to package reporter. (LP: #1531150)
  * Fix regression in configuration hook under install-cd chroot (LP: #1699789)
  * Report autoremovable packages (LP: #1208393)
  * No not re-register client by default (LP: #1618483)

 -- Andreas Hasenack <email address hidden> Fri, 10 Nov 2017 16:06:54 -0200

Changed in landscape-client (Ubuntu Zesty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 16.03-0ubuntu2.16.04.2

---------------
landscape-client (16.03-0ubuntu2.16.04.2) xenial; urgency=medium

  [ Simon Poirier ]
  * Add proxy handling to package reporter. (LP: #1531150)
  * Fix regression in configuration hook under install-cd chroot (LP: #1699789)
  * Report autoremovable packages (LP: #1208393)
  * No not re-register client by default (LP: #1618483)

 -- Andreas Hasenack <email address hidden> Fri, 10 Nov 2017 16:09:30 -0200

Changed in landscape-client (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 14.12-0ubuntu6.14.04.1

---------------
landscape-client (14.12-0ubuntu6.14.04.1) trusty; urgency=medium

  [ Simon Poirier ]
  * Add proxy handling to package reporter. (LP: #1531150)
  * Fix regression in configuration hook under install-cd chroot (LP: #1699789)
  * Report autoremovable packages (LP: #1208393)
  * No not re-register client by default (LP: #1618483)

 -- Andreas Hasenack <email address hidden> Fri, 10 Nov 2017 16:21:54 -0200

Changed in landscape-client (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.