About Kubuntu information box

Bug #215383 reported by Dread Knight on 2008-04-10
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
about-distro (Ubuntu)
Wishlist
Unassigned
kde4libs (Ubuntu)
Wishlist
Harald Sitter
kubuntu-meta (Ubuntu)
Low
Unassigned
kubuntu-settings (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: kubuntu-kde4-desktop

It's funny how I don't find any "About Kubuntu" buttons anywhere.
I'm using kde4 and hardy beta.

Pretty much every kde application has an "about kde" button under the help menu, but Kubuntu != kde.

I know ubuntu has an "about ubuntu" button, i think it would be very great for kubuntu also... or i am just missing it...

Well, kde4 needs an "about running distro" button to say so.

Yuriy Kozlov (yuriy-kozlov) wrote :

Kubuntu/KDE3 used to have this for the firefox home page as well as somewhere else I think. I don't think it's anywhere in Kubuntu/KDE4.

Changed in kubuntu-kde4-meta:
importance: Undecided → Wishlist
status: New → Confirmed
Harald Sitter (apachelogger) wrote :

We just discussed this a bit.

Places for such a dialog are:
* Context menu of panel
* Item in kickoff
* Item in the Help menu

We concluded the latter would be the most sensible. The current plan is to rename About KDE to About Kubuntu and change the underlying dialog to present Kubuntu information and the KDE information in a way that one understands KDE is part of the Kubuntu product. Ultimately implemented in a way that upstreams would consider including it for use by other distros.

This of course means that we need to ensure this stuff gets actually translated (which is TBH very unlikely at this point).

Changed in kde4libs (Ubuntu):
status: Confirmed → Triaged
Harald Sitter (apachelogger) wrote :

work in progress in kde:scratch/sitter/kcm-about-distro

we decided to use a KCM for the time being as that way we can easily integrate the component in just about every KDE application, however present tendencies are either to either list it in systemsettings (which is what gnome does) or in the regular application menu (which is what gnome used to do) or patch integration into the regular about kde dialog (though that is no long-term approach to it). final decisions still be made though.

Changed in kde4libs (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
status: Triaged → In Progress
Harald Sitter (apachelogger) wrote :
Harald Sitter (apachelogger) wrote :

FWIW, since the dialog will in fact be a KCM we can easily embed it also in KInfoCenter.

Jonathan Riddell (jr) wrote :

Comments:
"KDE SC Version" should be KDE Libraries Version (or KDE Frameworks if >= 5)
might be an idea to mention the codename (raring,saucy etc) somewhere?
not convinced that top bit is very pretty, could be tidied up somehow
X version might be an idea?
supported until date somehow?

James Cain (ronnoc) wrote :

"Harald Sitter (apachelogger) wrote on 2012-12-10: #5
FWIW, since the dialog will in fact be a KCM we can easily embed it also in KInfoCenter."

That would be awesome as it would kill two birds with one stone :)

Harald Sitter (apachelogger) wrote :

current version

Dread Knight (dread.knight) wrote :

Looking good!

Harald Sitter (apachelogger) wrote :

libs task not valid anymore as the implementation was independent of libs.

still requiring changes to -settings (branding override/ensuring the desktop file is everywhere it is supposed to be) and -meta (getting it pulled in by default)

Changed in kde4libs (Ubuntu):
status: In Progress → Invalid
Changed in about-distro (Ubuntu):
status: New → Fix Released
importance: Undecided → Wishlist
Changed in kubuntu-settings (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in kubuntu-meta (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Harald Sitter (apachelogger) wrote :

about-distro has been integrated for 13.10.

Changed in kubuntu-meta (Ubuntu):
status: Triaged → Fix Released
Changed in kubuntu-settings (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers