Icons missing in Plasma/KDE after upgrade to Ubuntu 15.04

Bug #1450068 reported by James Ring on 2015-04-29
90
This bug affects 18 people
Affects Status Importance Assigned to Milestone
kubuntu-meta (Ubuntu)
High
Unassigned

Bug Description

(Not sure if this is the right package to file against)

This bug refers to KDE/Plasma under Ubuntu 15.04.

After do-release-upgrade from 14.10 to 15.04, my "Games" menu is missing a lot of icons. See missing.png (attached). What's notable is that the icons still appear in the list view in the menu editor, but when you select one of the applications to edit, the icon is gone again. I'll attach another screenshot as apparently I can only attach one file at a time.

James Ring (sjr-f) wrote :
affects: tasque (Ubuntu) → kubuntu-meta (Ubuntu)
James Ring (sjr-f) wrote :

In the attached menu-editor.png you can see the icons in the menu editor tree view, but not in the detailed view when you click on one of the entries.

description: updated
Konrad Bucheli (konrad-bucheli) wrote :

I also miss some icons. After do-release-upgrade I miss many icons in the start menu, e.g the Thunderbird icon. Also the system settings are missing some icons, e.g. Printers.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kubuntu-meta (Ubuntu):
status: New → Confirmed
James Ring (sjr-f) wrote :

This appears to be a more general problem than just Steam icons. I just upgraded to 15.10 and I still have the same problem but with lots of other icons too.

Is there anything more I can do to help get some movement on the issue?

Potentially related: I am not able to change the icon theme in the system settings window. When I choose a new theme and hit apply, I get a dialog saying "Updating system configuration" which quickly disappears and then the old icon theme is still there.

eris23 (jdkatz23) wrote :

If this isn't specifically a steam issue, I have a similar problem with missing toolbar icons after upgrading to wily with KShisen on Xubuntu.

James Ring (sjr-f) on 2015-08-19
summary: - Steam icons missing in Plasma/KDE after upgrade to Ubuntu 15.04
+ Icons missing in Plasma/KDE after upgrade to Ubuntu 15.04
tags: added: vivid
tags: added: xenial
Changed in kubuntu-meta (Ubuntu):
importance: Undecided → High

I have this bug with i.e. the firefox-icon. It also appeared minimized in the menu-editors sidebar but I could never set it via the submenu "select icon". It also never appeared in the submenu "Icon Source -> System icons", only under "Icon Source -> Other icons".

Since the Menu Editor never accepted it, if I selected the correct one from there, I came to the Idea to move the .png files into the subfolder of breeze. When I moved them from /usr/share/pixmaps/ to /usr/share/icons/breeze/apps/48/ and rebooted the system all missing icons where in place (After I set the symlinks of firefox and thunderbird to an absolut path).

Following this, it seems to me, that there is a problem within the menu-editor to use the icons present under /usr/share/pixmaps/.

Oddly this only happend to me if I added KDE Plasma 5 to a already running system. In a native installed Kubuntu Xenial these icons are in place.

zeine77 (mohamed-eyil) wrote :

I had the same issue after upgrading from Kubuntu 15.10 to 16.04. The workaround mentioned in the comment #7 worked for me.

James Ring (sjr-f) wrote :

Adding

export QT_QPA_PLATFORMTHEME=kde

to ~/.profile fixed a LOT of style-related issues for me in Kubuntu.

Lars Risan (lars-risan) wrote :

Thanks James Ring (#9). That worked for me as well (on Kubuntu 16.04, where KDE was added to an originally Ubuntu 16.04 installation).

Marc Branchaud (marcnarc) wrote :

James's suggestion (comment 9) also worked for me -- thanks!

Note that the setting has to be in ~/.profile, not ~/.bash_profile.

Like Lars, I too am using a machine that was originally (many releases ago) a Ubuntu box.

stmazzoni (stmazzoni) wrote :

Many thanks! Now it works fine in my 16.04 !

My system was originally installed as Ubuntu 14.04 and converted to Kubuntu 14.04 by installing the relevant packages (I forget which). After upgrading to 16.04, icons for custom launchers in /home/chaos/.local/share/applications stopped working; where I would expect an icon, there was nothing. This was present in Application Launcher, Application Dashboard, and Quicklaunch.

Applying James Ring's suggestion from comment #9 worked around the problem. Icons are again what I would expect.

Miles Sharpe (msdomdonner) wrote :

I have tried all the fixes but after one or two reboots I again have missing icons

hotellina (hotellinaweb) wrote :

I installed Ubuntu 16.04 and added packages to run Kubuntu.

I had icon issues in the launchern but Adding

export QT_QPA_PLATFORMTHEME=kde

to ~/.profile fixed the problem.

Praxis (ejbiow) wrote :

I just logged in to thank Mr. Ring, again, I know saying it doesn't add any new information, it his advise made my life a log less annoying as I was dragged kicking and screaming into KDE 5.

KDE seems to take great delight making icons incompatible from one major release to the next, I remember when I first upgraded to KDE 4 and suddenly all my folder icons from KDE 3 were invisible! But at least they keep plugging away at their 'social desktop' file search, maybe one of these years it will actually work. For those of you who have had a snoot-full of KDE, I might suggest checking out LXQT.

I'm like Praxis, came in just to thank James Ring for comment #9

I had Ubuntu 16.04, then installed Kubuntu desktop and many icons were not appearing correctly. Same applied for application launcher icons I had defined myself. I gave them the path to an existing icon but I would get nothing in the end.

After applying the export command everything works great.

diehard67 (diehard67) wrote :

adding
export QT_QPA_PLATFORMTHEME=kde
to .profile in my home folder fixed the problem for me too, I wonder if it should be added by default when KDE is installed

not sure if it makes a difference but I installed the Kubuntu-desktop package on vanilla ubuntu 17.10, I had a problem with gnome unrelated to this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers