Korean fonts displayed as boxes

Bug #1335639 reported by Jung-Kyu Park on 2014-06-29
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kubuntu-meta (Ubuntu)
Undecided
Jinkyu Yi
Trusty
Undecided
Unassigned
Utopic
Undecided
Jinkyu Yi

Bug Description

Kubuntu 14.10
I ran the ubuntu-bug ,and it bring me here
I don't know if it is related to xorg , though
It happens from the install screen to normal KDE desktop
please see the screen shot
All the korean fonts displayed as boxes, even at the ubiquity window of language selector.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: xorg 1:7.7+1ubuntu8
ProcVersionSignature: Ubuntu 3.15.0-6.11-generic 3.15.0
Uname: Linux 3.15.0-6-generic i686
NonfreeKernelModules: wl
ApportVersion: 2.14.3-0ubuntu2
Architecture: i386
CurrentDesktop: KDE
Date: Mon Jun 30 00:43:13 2014
InstallationDate: Installed on 2014-06-29 (0 days ago)
InstallationMedia: Kubuntu 14.10 "Utopic Unicorn" - Alpha i386 (20140624.2)
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: No upgrade log present (probably fresh install)

TEST CASE:
Look at this web page
If Jung Kyu Park's name is boxes then it's broken

Jung-Kyu Park (bagjunggyu) wrote :
Jung-Kyu Park (bagjunggyu) wrote :

Kubuntu 14.10

affects: xorg (Ubuntu) → ubuntu
Jung-Kyu Park (bagjunggyu) wrote :

kubuntu 14.10

description: updated
Jinkyu Yi (jincreator) on 2014-06-29
affects: ubuntu → kubuntu-meta (Ubuntu)
Changed in kubuntu-meta (Ubuntu):
assignee: nobody → Jinkyu Yi (jincreator)
Jung-Kyu Park (bagjunggyu) wrote :

It reveals that it doesn't contain any Hangul Fonts for Korean such as nanum , unfonts-core , NotoSansKorean-hinted, etc...
Why did you do that? I must listen, mean it!

Jung-Kyu Park (bagjunggyu) wrote :

I have a temporary cure for this issue.
Installing language-selector-gnome solved this issue for me.
After installation of laguage-selector-gnome ,running /usr/share/applications/language-select.desktop
During running language support, Korean fonts will be installed automatically
Which means that "kde-l10n-ko" package doesn't have a Korean fonts in itself I guess

jong (agitato816) wrote :

Thanks for your effort, Mr. Park.

Jonathan Riddell (jr) wrote :

sorry for the delay in looking at this, I've merged the seed change and uploaded kubuntu-desktop to utopic

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-meta - 1.313

---------------
kubuntu-meta (1.313) utopic; urgency=medium

  * Refreshed dependencies
  * Added elfspe2 to full [powerpc]
  * Added fonts-nanum to desktop-recommends, full-recommends LP: #1335639
   - Korean fonts displayed as boxes
  * Added printer-driver-brlaser to desktop-recommends
  * Added ps3pf-utils to full [powerpc]
  * Added ttf-ancient-fonts-symbola to desktop-recommends
  * Removed plasma-active from active
  * Removed plasma-active-settings from active
  * Removed plasma-active-webbrowser from active
  * Removed plasma-widgets-active from active
 -- Jonathan Riddell <email address hidden> Wed, 08 Oct 2014 15:30:22 +0200

Changed in kubuntu-meta (Ubuntu):
status: New → Fix Released
Jung-Kyu Park (bagjunggyu) wrote :

Thank you Jonathan , This is very happy news
By the way, Suddenly It reminds me of Kubuntu 14.04.1 has the same issue with Kubuntu 14.10 for Korean Fonts diplayed as boxes.
So that I checked it now , right before commenting here
And , yes,There is a same issue about Korean fonts for Kubuntu 14.04.1 with Kubuntu 14.10

Shoud I file another report for Kubuntu 14.04.1 ?

Jung-Kyu Park (bagjunggyu) wrote :

Screenshot for case of Kubuntu 14.04.1

Jinkyu Yi (jincreator) wrote :

Hi, Jonathan, thanks for review.
But after read Park's report, I notice out trusty has same problem.
So I open merge proposal to kubuntu.trusty branch.
Could you please have a look at it, too?

Hi, Park.
I think we don't need to open new bug for ᅟ14.04.1 because both are same symptom caused by same reason.

Jonathan Riddell (jr) wrote :

Uploaded kubuntu-meta 1.308.2 to trusty-proposed which adds fonts-nanum to the meta package. We will need to watch how this affects image size. Awaiting in unapproved queue for approval by ~ubuntu-sru.

Jung-Kyu Park (bagjunggyu) wrote :

Thank you , Jonathan.
We would be waitng for it with you.

Jonathan Riddell (jr) wrote :

Uploaded kubuntu-meta 1.308.1.2 to trusty-proposed. Awaiting in unapproved queue for approval by ~ubuntu-sru.

description: updated
Jung-Kyu Park (bagjunggyu) wrote :

Thank you Jonathan and Thank you for happy news

Hello 박정규(Jung-Kyu, or anyone else affected,

Accepted into trusty-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in kubuntu-meta (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Jung-Kyu Park (bagjunggyu) wrote :

Thank you Scott , I am so glad to hear this news.
I will test it right away with a fresh installation of native Kubuntu 14.04.1
Thank you

Jung-Kyu Park (bagjunggyu) wrote :

Thank you It worked fine!
On first booting after fresh installation , it has seen already fixed
though I checked it and it worked fine
Thank you Scott , Thank you Joathan , Thank you Jinkyu Yi

tags: added: verification-done
removed: verification-needed
Jung-Kyu Park (bagjunggyu) wrote :

By the way , it donesn't related to this issue but
I want to hear your opinion

Kubuntu 14.04 and 14.10 have the same issue of mesa
I think that it is the same issue with this report for Unity
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1232940

without removing xserver-xorg-video-nouveau , there are crashed windows to the full of screen
plesase see the screentshot
I always remove xserver-xorg-video-nouveau on first booting both of the the installation process, after installation process
and also installing nvidia-current works for it

Should I file another report for this?
then Can you help me to file a proper report by commenting right project to me here ?

attached file : screenshot for installation screen of Kubuntu 14.04

Jung-Kyu Park (bagjunggyu) wrote :

attached file : screenshot for installation screen of Kubuntu 14.10

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-meta - 1.308.1.2

---------------
kubuntu-meta (1.308.1.2) trusty; urgency=medium

  * Refreshed dependencies
  * Added fonts-nanum to desktop-recommends, full-recommends, LP: #1335639
 -- Jonathan Riddell <email address hidden> Wed, 15 Oct 2014 15:21:16 +0200

Changed in kubuntu-meta (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for kubuntu-meta has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Jung-Kyu Park (bagjunggyu) wrote :

Thank you.

tags: removed: aas boxes displayed fonts korean
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers