appearing color bar instead of unity and panel

Bug #1232940 reported by Jung-Kyu Park on 2013-09-29
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Maarten Lankhorst
unity (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
Undecided
Maarten Lankhorst

Bug Description

It occured whenever I installed ubuntu 13.10 still now
Color bar appear instead of Unity with app launchers and Panel with indicators

And It disappear whenever I install nvidia-current driver

sudo apt-get install nvidia-current
sudo reboot

During the color bar rule the unity , malfunction occured
ex) from the unity-lense , some apps launched automatically even though I didn't click at all
but mouse hover the area of unity lense

ex) scrolliing the unity lense then apps launched automatically

but. It works properly , after I install nvidia-current

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: unity 7.1.1+13.10.20130927.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-9.16-generic 3.11.2
Uname: Linux 3.11.0-9-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.12.5-0ubuntu1
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Mon Sep 30 08:07:07 2013
DistUpgraded: Fresh install
DistroCodename: saucy
DistroVariant: ubuntu
GraphicsCard:
 NVIDIA Corporation G73 [GeForce 7600 GS] [10de:0392] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: LeadTek Research Inc. Device [107d:20a2]
InstallationDate: Installed on 2013-09-29 (0 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Beta i386 (20130929)
Lsusb:
 Bus 001 Device 003: ID 10a9:1104 SK Teletech Co., Ltd Sky Vega IM-A650S
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 002: ID 0603:1605 Novatek Microelectronics Corp.
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-9-generic root=UUID=c40a54c7-ee81-46a6-b3a7-649f3e779766 ro quiet splash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/17/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.50
dmi.board.name: N68-S
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.50:bd07/17/2009:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnN68-S:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz 1:0.9.10+13.10.20130927.1-0ubuntu1
version.libdrm2: libdrm2 2.4.46-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.14.2.901-2ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu9
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.14-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.9-2ubuntu1
xserver.bootTime: Mon Sep 30 08:00:39 2013
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.14.2.901-2ubuntu6
xserver.video_driver: nouveau

Jung-Kyu Park (bagjunggyu) wrote :
Stephen M. Webb (bregma) wrote :

It sounds suspiciously like this is a bug in the nouveau driver, since it only occurs when using the nouveau driver and not the nVidia driver, and has not been reported against the intel or AMD drivers.

Changed in unity (Ubuntu):
status: New → Triaged
Maarten Lankhorst (mlankhorst) wrote :

I've noticed the same, it might be a regression from the 9.2 upload, I'll test against 9.1 again to be certain, then bisect..

Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in xserver-xorg-video-nouveau (Ubuntu):
assignee: nobody → Maarten Lankhorst (mlankhorst)
status: New → Triaged
Maarten Lankhorst (mlankhorst) wrote :

Yeah, 9.1.4 works as expected.

Maarten Lankhorst (mlankhorst) wrote :

Looks like upstream 9.2 fixed this too, with commit 3b852f9d52732066bffd498313b3ccae4b615481 "nv30: find first unused texcoord rather than bailing if first is used". This means the fix will be in 9.2.1.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Changed in mesa (Ubuntu):
assignee: nobody → Maarten Lankhorst (mlankhorst)
status: Confirmed → Fix Committed
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Triaged → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 9.2.1-1ubuntu1

---------------
mesa (9.2.1-1ubuntu1) saucy; urgency=low

  [ Robert Hooker ]
  * Add i915-dont-default-to-2.1.patch: Stop defaulting to OpenGL 2.1 that is not
    fully implemented in hardware on gen3 GPUs, the software fallbacks make Unity
    unusably slow. (LP: #1222602)
  [ Maarten Lankhorst ]
  * New upstream bugfix release. (LP: #1232940)

mesa (9.2.1-1) experimental; urgency=low

  * New upstream release.
 -- Maarten Lankhorst <email address hidden> Mon, 07 Oct 2013 10:39:18 +0200

Changed in mesa (Ubuntu):
status: Fix Committed → Fix Released
vmc (vmclark) wrote :

I just installed today's ubuntu saucy ISO [ saucy-desktop-amd64.iso 07-Oct-2013 07:48], which still had the "color rainbow" on the launcher and panels.

After it was installed I ran all current updates which included mesa. Now everything is fixed.

This also fixed gnome saucy which had some unusual display behaviors as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers