Ubuntu

Localized Kubuntu documents missing

Reported by Martin Böhm on 2006-11-26
14
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
kubuntu-docs (Ubuntu)
High
Richard Johnson

Bug Description

In Kubuntu Edgy Eft the Kubuntu-specific documentation (About Kubuntu, Kubuntu Desktop Guide etc.) is present only in C (English), although it is translated into other languages in Rosetta. Those languages should probably be included as well. Translations of those documents were present in Kubuntu 6.06.

Richard Johnson (nixternal) wrote :

kubuntu-docs package does not contain any translations.

Changed in kubuntu-docs:
assignee: nobody → nixternal
importance: Undecided → High
status: Unconfirmed → Confirmed
Jonathan Jesse (jjesse) wrote :

Rich,

What needs to be done to get this bug fixed? Is there something that Riddell needs to do or is it something that one of us can do?

Let's get this solved

I confirm that this bug affects Edgy and Feisty.
I think that kubuntu-docs should include the translations because it was in the Dapper package.

After a quick look, the content of kubuntu-docs 6.10 source package seems very strange to me, at least it's very different from release 6.06. There's no .po files in it, and some bash scripts like translate.sh are present.
I wonder if there's a problem in building the source package or if the way to translate kubuntu-docs has completely change since release 6.06 (but I didn't see anything about that in the changelog).

Richard Johnson (nixternal) wrote :

This isn't going to get fixed in Edgy and will be taken care of with Feisty.

Changed in kubuntu-docs:
status: Confirmed → Rejected
Richard Johnson (nixternal) wrote :

Reopening, in progress. Debdiff is locally on laptop, when I get home this evening and it is approved, fix will get uploaded. Sorry for the confusion!

Changed in kubuntu-docs:
status: Rejected → In Progress

It's really a good news (I was very disappointed by your last comment ;)), thanks for your great work Richard !

Richard Johnson (nixternal) wrote :

http://www.nixternal.com/docs/kubuntu/6.10-2/

If anybody is still using Edgy ;) I have committed the fixes for translations :) ENJOY!

Changed in kubuntu-docs:
status: In Progress → Fix Committed
Jonathan Riddell (jr) wrote :
Jonathan Riddell (jr) wrote :
Jonathan Riddell (jr) wrote :

ubuntu-sru subscribed, pitti please review above two patches for -proposed

Richard Johnson (nixternal) wrote :

Any updates on this?

Unfortunately, this issue is still present on an up-to-date Kubuntu Feisty (with backport repository activated), and also on Gutsy...
That's quite frustrating for translators and for non-English speaking users ;)

Martin Pitt (pitti) wrote :

Ah, "fix committed" is in appropriate for an SRU bug (see policy), thus it fell off my radar. I'll review it on my archive day on Friday.

Changed in kubuntu-docs:
status: Fix Committed → In Progress
Martin Pitt (pitti) wrote :

Quite intrusive build system changes, but if you tested the resulting packages, it's fine for me. Please go ahead and upload.

Richard Johnson (nixternal) wrote :

Jonathan, when you get back can you upload this package and close this bug please. Thank you! Thanks Martin for the 'ack'.

Jonathan Jesse (jjesse) wrote :

Has Jonathan uploaded this yet? If not can we get this uploaded ASAP?

Thanks,

Jonathan

Guillaume Martres (smarter) wrote :

The bug seems to be fixed with latest kubuntu-docs package for Gutsy.

Jonathan Jesse (jjesse) wrote :

Rich,

Can you take a look at this bug and see what is going on?

Jonathan

Richard Johnson (nixternal) wrote :

@Riddell: Poke on this one? Are we going to upload the fixed package, or just close this out since Edgy is within 6 months of EOF?

Martin Pitt (pitti) wrote :

No action here for quite some time, and Edgy is becoming old. Please reopen if you are still interested in fixing this and upload to edgy-proposed.

Changed in kubuntu-docs:
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers