ktoon version 0.8.1-5 failed to build on armel

Bug #823698 reported by Ricardo Salveti on 2011-08-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ktoon (Ubuntu)
Undecided
Unassigned

Bug Description

ktoon version 0.8.1-5 failed to build on armel
Link to failed build: https://launchpad.net/ubuntu/+source/ktoon/0.8.1-5/+build/3080437

Direct link to the build log: https://launchpadlibrarian.net/89423602/buildlog_ubuntu-precise-armel.ktoon_0.8.1-5_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 2306 lines into the build log:

agldevice.cpp: In member function 'virtual void AGLDevice::initializeGL()':
agldevice.cpp:35:15: error: 'GL_FLAT' was not declared in this scope
agldevice.cpp:35:22: error: 'glShadeModel' was not declared in this scope
agldevice.cpp:38:12: error: 'GL_LINE_SMOOTH' was not declared in this scope
agldevice.cpp:40:12: error: 'GL_POINT_SMOOTH' was not declared in this scope
make[5]: *** [.obj/agldevice.o] Error 1
make[5]: Leaving directory `/build/buildd/ktoon-0.8.1/src/modules/arthury/illustration'
make[4]: *** [sub-illustration-make_default] Error 2
make[4]: Leaving directory `/build/buildd/ktoon-0.8.1/src/modules/arthury'
make[3]: *** [sub-arthury-make_default] Error 2
make[3]: Leaving directory `/build/buildd/ktoon-0.8.1/src/modules'
make[2]: *** [sub-modules-make_default] Error 2
make[2]: Leaving directory `/build/buildd/ktoon-0.8.1/src'
make[1]: *** [sub-src-make_default] Error 2
make[1]: Leaving directory `/build/buildd/ktoon-0.8.1'
make: *** [build-stamp] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20120109-0802

tags: added: opengles
Changed in ktoon (Ubuntu):
status: New → Confirmed
summary: - ktoon version 0.8.1-4.2ubuntu1 failed to build on armel
+ ktoon version 0.8.1-5 failed to build on armel
description: updated
Christian Reis (kiko) wrote :

If this is failing with GL calls, is there any chance this will run on an OpenGLES-only ARM system?

Or should it at least not FTBFS, since there should be Mesa swrast available?

Ricardo Salveti (rsalveti) wrote :

The problem is the conflict between OpenGL and OpenGL ES definitions, as built is build with GLES support, but the application also uses GL directly, so even with Mesa it'll fail anyway.

The fix would probably skip building the GL specific bits, or to use the glproxy lib created by the GWG, but both is not trivial.

Jani Monoses (jani) wrote :

This seems to no longer FTBFS

Changed in ktoon (Ubuntu):
status: Confirmed → Fix Released
Jani Monoses (jani) wrote :

Oh it still FTBFS.

Changed in ktoon (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers