kompozer-bin crashed with SIGSEGV in nsTimerImpl::Fire()

Bug #260021 reported by Tanath on 2008-08-21
378
This bug affects 8 people
Affects Status Importance Assigned to Milestone
kompozer (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: kompozer

There were two successive crashes, the report was autogenerated, and I'm not sure which one was picked up on. The first and most likely was while editing link properties, changing the target. The second was while trying to open the Recent Documents drop-down list from the File menu.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/lib/kompozer/kompozer-bin
Package: kompozer 1:0.7.10-0ubuntu4
ProcCmdline: /usr/lib/kompozer/kompozer-bin
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
Signal: 11
SourcePackage: kompozer
StacktraceTop:
 ?? () from /usr/lib/kompozer/components/libgklayout.so
 nsTimerImpl::Fire () from /usr/lib/kompozer/libxpcom.so
 handleTimerEvent () from /usr/lib/kompozer/libxpcom.so
 PL_HandleEvent () from /usr/lib/kompozer/libxpcom.so
 PL_ProcessPendingEvents ()
Title: kompozer-bin crashed with SIGSEGV in nsTimerImpl::Fire()
Uname: Linux 2.6.26-5-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy games lpadmin plugdev sambashare scanner video

Tanath (tanath) wrote :

StacktraceTop:nsMenuFrame::Notify () from /usr/lib/kompozer/components/libgklayout.so
nsTimerImpl::Fire () from /usr/lib/kompozer/libxpcom.so
handleTimerEvent () from /usr/lib/kompozer/libxpcom.so
PL_HandleEvent () from /usr/lib/kompozer/libxpcom.so
PL_ProcessPendingEvents () from /usr/lib/kompozer/libxpcom.so

Changed in kompozer:
importance: Undecided → Medium
Changed in kompozer:
status: New → Confirmed

Can we get the importance of this bug raised? The number of duplicates is getting ridiculous.

Here's the basic status: Kompozer doesn't work, at all, for anyone. Attempting to use any menu that contains submenus crashes the program, so it's impossible to use for even the simplest functions.

At the very least, the current package should be removed.

AndyOsi (andres-osinski) wrote :

Agreed. This package is simply useless as it stands.

John O'Neall (joneall) wrote :

In my case, it may crash or it may just hang when I try to open the Recent Documents drop-down list from the File menu.

The only log message I can find is in /var/log/apport.log:

apport (pid 15554) Sun Mar 15 17:24:17 2009: called for pid 15550, signal 11
apport (pid 15554) Sun Mar 15 17:24:17 2009: executable: /usr/lib/kompozer/kompozer-bin (command line "/usr/lib/kompozer/kompozer-bin")
apport (pid 15554) Sun Mar 15 17:24:17 2009: apport: report /var/crash/_usr_lib_kompozer_kompozer-bin.1000.crash already exists and unseen, doing nothing to avoid disk usage DoS

whatever that may indicate.

Yes, please increase the importance of this.

Ben Crisford (bencrisford) wrote :

I have had to stop work on my new site for several weeks now due to this problem.

The delays have been ridiculous...

John O'Neall (joneall) wrote :

I just dist-upgraded to 2.6.28-11-generic. Now I can't even start Kompozer:

$ kompozer
*** buffer overflow detected ***: /usr/lib/kompozer/kompozer-bin terminated
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6(__fortify_fail+0x48)[0xb745ada8]
/lib/tls/i686/cmov/libc.so.6[0xb7458eb0]
/lib/tls/i686/cmov/libc.so.6[0xb7459618]
/usr/lib/kompozer/kompozer-bin[0x804e968]
/usr/lib/kompozer/kompozer-bin[0x804ba43]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5)[0xb7373775]
/usr/lib/kompozer/kompozer-bin[0x804b971]

@John: Yeah, I'm seeing the same thing with the most current 9.04 and komposer. It immediately crashes without so much as opening a window. It's totally borked.

Can someone *please* delete the package from the repos until such time as there is a working version? The current one's going to do nothing but frustrate people. 39 people cared enough to come here and opened duplicate bugs - there's no telling how many people actually ran into the problem and just gave up.

Marc Higgins (mhiggins) wrote :

Kompozer does not even start in 9.04 / Jaunty Jackalope RC if the box is a clean build. (Is this a separate bug or not?)

Interestingly on a box upgraded from 8.10 to 9.04rc it opens, but still has the menu crash issues but on a clean 9.04rc it failed to start at all. Attached is the output of kompozer when run from a shell. You can see the buffer overflow issue.

Floyd B. (fbufkin) wrote :

This morning's update included an upgrade for kompozer and it seems to be working correctly in Jaunty now. My thanks to whoever worked on this.

On Tue, 2009-04-21 at 12:56 +0000, Floyd B. wrote:

> This morning's update included an upgrade for kompozer and it seems to
> be working correctly in Jaunty now. My thanks to whoever worked on
> this.

That was a different bug. This bug is about using the "Table->Insert"
menu entry (or any other sub-menu).

--
Laurent Bonnaud.
http://www.lis.inpg.fr/pages_perso/bonnaud/

Floyd B. (fbufkin) wrote :

Yes, I just checked, and although kompozer now loads, it does still crash if you try to use the menu as noted in the previous post. Well, it seems some progress is being made.

Launchpad Janitor (janitor) wrote :
Download full text (6.5 KiB)

This bug was fixed in the package kompozer - 1:0.8~alpha3+dfsg+svn152-1

---------------
kompozer (1:0.8~alpha3+dfsg+svn152-1) unstable; urgency=low

  * [23957fd] Imported Upstream version 0.8~alpha3+dfsg+svn152
    - Now the help menu works.(Closes: #525891)
  * [eee96d0] Updated files in debian/conf/ needed by clean target
  * [de5e181] 01_add_lfontocnfig.patch, 02_fix_overflow.patch,
    03_add_lfontconfig.patch, 04_fix_path.patch,
    05_remove_nonfree.patch, 06_syspref_folder_support.patch,
    07_cairo_xlib.patch, 08_security.patch,
    09_add_missing_tab_indentation.patch, 90_CVE-2009-1044.patch, are
    now in upstream, deleted.
  * [2609c1e] debian/patches/01_r153.patch: Fixed a chrome registration
    problem related to the "help" window.

kompozer (1:0.8~alpha2+dfsg+svn129-3) UNRELEASED; urgency=low

  * [92f61aa] debian/patches/19_gcc4.4.patch: Fix FTBFS with GCC 4.4.
    (no longer allows #elif without an expression) (Closes: #526161)
  * [6c824b4] debian/patches/90_CVE-2009-1044.patch: Fix Arbitrary code
    execution via XUL tree element (CVE-2009-1044)
  * [27275e6] debian/patches/90_CVE-2009-1311.patch: Fix POST data sent
    to wrong site when saving web page with embedded frame (CVE-2009-1311)
    (MFSA 2009-21)
  * [3b1eb19] debian/patches/90_CVE-2009-0776.patch: Updated fix for
    CVE-2009-0776, previous fix was incomplete. (MFSA 2009-09)
  * [8feadce] debian/patches/20_mips64_build.patch: Patch from Martin
    Michlmayr for mips64 builds. bz#330626
    debian/patches/21_mips_xpcom.patch: Patch from Thiemo Seufer to fix
    mips. bz#258429
    debian/patches/22_mips_performance.patch: Patch from Thiemo Seufer to
    increase stability and performance on mips.
  * [e7add6a] debian/rules: Fix get-orig-source target for working also
    with epoch in version

kompozer (1:0.8~alpha2+dfsg+svn129-2) unstable; urgency=low

  * [5577bd3] Build with "-O2 -fno-strict-aliasing -g", hopefully it
    fixes FTBFS in s390
  * [ebcecc1] debian/kompozer.desktop: Added Network in Categories
  * [32daadd] debian/patches/13_kbsd.patch: GNU/kFreeBSD support.
    bz#356011
  * [db6d79f] debian/patches/14_distclean.patch: Make distclean cleaner.
    bz#333308.
  * [dd57bbd] debian/patches/15_system_libs.patch: Make sure we won't be
    bitten by upstream changing libjpeg, libpng or zlib internal
    version, which makes system library not used even though --with-
    system-* argument is given to configure.
  * [a59f082] debian/patches/16_uname.patch: Use ${host_*} variables
    instead of uname in configure.in. This is a minimalist patch to
    solve the particular bad assembler choice issue. It would need a
    much greater work to actually do something totally clean, but the
    current patch should be enough for Linux builds. Also incorporates
    fix for bz#363263.
  * [c39c0c3] debian/patches/17_locale.patch: use OS locale. bz#331779
  * [f62a517] Refreshed debian/patches/99_configure.patch
  * [c2aec04] debian/patches/18_crmf.patch: Put the crmf library before
    the NSS libraries.

kompozer (1:0.8~alpha2+dfsg+svn129-1) unstable; urgency=low

  * New upstream svn version. This fixes a lot of Ubuntu bugs:
    (LP: #347779) (LP: #26002...

Read more...

Changed in kompozer (Ubuntu):
status: Confirmed → Fix Released
Thomas (thomas13) wrote :

Just installed Komposer 0.8b1 from their website and it works now under Jaunty Jackalope

To post a comment you must log in.