modprobe: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed

Bug #1073062 reported by dino99 on 2012-10-30
852
This bug affects 197 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
fglrx
Invalid
Undecided
Unassigned
kmod (Debian)
Fix Released
Unknown
kmod (Ubuntu)
Medium
Alberto Milone

Bug Description

get this output after upgraded RR i386 (no proposed repo):

oem@oem-desktop:~$ sudo update-initramfs -u
[sudo] password for oem:
update-initramfs: Generating /boot/initrd.img-3.7.0-030700rc2-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)
WARNING: could not open /tmp/mkinitramfs_pu9szv/lib/modules/3.7.0-030700rc2-generic/modules.builtin: No such file or directory
oem@oem-desktop:~$

note: also confirmed by other users on ubuntuforums. That was with nvidia-current 310, so i've also tried 304 but got the same result. So it seems related to 3.7 kernel.

Nvidia patch:
http://www.nvnews.net/vbulletin/showthread.php?t=194465

dino99 (9d9) on 2012-10-30
tags: added: i386 raring
dino99 (9d9) on 2012-10-30
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kmod (Ubuntu):
status: New → Confirmed
dino99 (9d9) on 2012-10-30
description: updated
dino99 (9d9) wrote :

doing: echo "module-init-tools install"|dpkg --set-selections

unlocked module-init-tools. I crossed my fingers and did update-initramfs. Same warning appeared. I rebooted and I'm writing from new kernel images. So, that warning is not announcing obstruction...
Conclusion: there is a problem still in kmod but it is not fatal, at least I dodged a bullet this time...

John Swing (john-swing) wrote :

I've got the same kind of warning when upgrading RR (amd64)

update-initramfs: Generating /boot/initrd.img-3.7.0-2-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)
WARNING: could not open /tmp/mkinitramfs_Vb1xyJ/lib/modules/3.7.0-2-generic/modules.builtin: No such file or directory

Michael Neuffer (neuffer) wrote :

Same here.

root@kyle:/usr/src/debian# update-initramfs -u -k 3.7.0-3-generic
update-initramfs: Generating /boot/initrd.img-3.7.0-3-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)
WARNING: could not open /tmp/mkinitramfs_AdiCYG/lib/modules/3.7.0-3-generic/modules.builtin: No such file or directory

tags: added: amd64
dino99 (9d9) wrote :

hi Michael,

it indedd looks very close to that 674110 report.

oem@oem-desktop:~$ sudo modprobe -vvvvvvvv `uname -r`
libkmod: DEBUG ../libkmod/libkmod-module.c:519 kmod_module_new_from_lookup: input alias=3.7.0-030700rc6-generic, normalized=3.7.0_030700rc6_generic
libkmod: DEBUG ../libkmod/libkmod-module.c:525 kmod_module_new_from_lookup: lookup modules.dep 3.7.0_030700rc6_generic
libkmod: DEBUG ../libkmod/libkmod.c:542 kmod_search_moddep: use mmaped index 'modules.dep' modname=3.7.0_030700rc6_generic
libkmod: DEBUG ../libkmod/libkmod-module.c:529 kmod_module_new_from_lookup: lookup modules.symbols 3.7.0_030700rc6_generic
libkmod: DEBUG ../libkmod/libkmod-module.c:533 kmod_module_new_from_lookup: lookup install and remove commands 3.7.0_030700rc6_generic
libkmod: DEBUG ../libkmod/libkmod-module.c:537 kmod_module_new_from_lookup: lookup modules.aliases 3.7.0_030700rc6_generic
libkmod: DEBUG ../libkmod/libkmod.c:422 kmod_lookup_alias_from_alias_bin: use mmaped index 'modules.alias' for name=3.7.0_030700rc6_generic
libkmod: DEBUG ../libkmod/libkmod-module.c:541 kmod_module_new_from_lookup: lookup modules.builtin 3.7.0_030700rc6_generic
libkmod: DEBUG ../libkmod/libkmod.c:492 kmod_lookup_alias_from_builtin_file: use mmaped index 'modules.builtin' modname=3.7.0_030700rc6_generic
libkmod: DEBUG ../libkmod/libkmod-module.c:546 kmod_module_new_from_lookup: lookup 3.7.0_030700rc6_generic=0, list=(nil)
DEBUG: lookup failed - trying to check if it's builtin
libkmod: DEBUG ../libkmod/libkmod.c:390 kmod_pool_get_module: get module name='3' found=(nil)
libkmod: DEBUG ../libkmod/libkmod.c:398 kmod_pool_add_module: add 0xb8df1480 key='3'
libkmod: DEBUG ../libkmod/libkmod-module.c:1651 kmod_module_get_initstate: could not open '/sys/module/3/initstate': No such file or directory
libkmod: DEBUG ../libkmod/libkmod-module.c:1661 kmod_module_get_initstate: could not open '/sys/module/3': No such file or directory
libkmod: DEBUG ../libkmod/libkmod-module.c:435 kmod_module_unref: kmod_module 0xb8df1480 released
libkmod: DEBUG ../libkmod/libkmod.c:406 kmod_pool_del_module: del 0xb8df1480 key='3'
FATAL: Module 3.7.0-030700rc6-generic not found.

About that comment: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=674110#27

I'm actually using "nouveau" as i get only low graphic definition with "nvidia", but was using it before with 3.6 kernel. So maybe its something to check, but i've no idea where to start searching.

Changed in kmod (Debian):
status: Unknown → Incomplete
Rainer Rohde (rainer-rohde) wrote :

I have the same issue after stepping up to 13.04.

Rainer Rohde (rainer-rohde) wrote :

This is what happens when I try and update initramfs manually:

# update-initramfs -u
update-initramfs: Generating /boot/initrd.img-3.7.0-4-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)
WARNING: could not open /tmp/mkinitramfs_z5DMUt/lib/modules/3.7.0-4-generic/modules.builtin: No such file or directory.

I am on NVDIA Driver Version: 310.19

dino99 (9d9) wrote :

Today i got an upgrade to initramfs-tools 0.103ubuntu0.4 on RR i386, and it seems fixing that issue: does not get error now when running "sudo update-initramfs -u"
So i declare that report as fixed.

Changed in kmod (Ubuntu):
status: Confirmed → Fix Released
John Swing (john-swing) wrote :

I still have this problem after upgrading to initramfs-tools 0.103ubuntu0.4 :

(Reading database ... 521693 files and directories currently installed.)
Preparing to replace initramfs-tools 0.103ubuntu0.3 (using .../initramfs-tools_0.103ubuntu0.4_all.deb) ...
Unpacking replacement initramfs-tools ...
Preparing to replace initramfs-tools-bin 0.103ubuntu0.3 (using .../initramfs-tools-bin_0.103ubuntu0.4_amd64.deb) ...
Unpacking replacement initramfs-tools-bin ...
Processing triggers for doc-base ...
Processing 1 changed doc-base file...
Processing triggers for man-db ...
Setting up initramfs-tools-bin (0.103ubuntu0.4) ...
Setting up initramfs-tools (0.103ubuntu0.4) ...
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.7.0-4-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)

John Swing (john-swing) wrote :

Am I the only one still getting this ?

sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-3.7.0-4-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)

Sworddragon (sworddragon) wrote :

> Am I the only one still getting this ?

No, I'm getting this issue since the first reports in the forum appeared. On Linux 3.7.0 RC8 with the NVIDIA driver 304.64 I'm getting this:

root@ubuntu:~# update-initramfs -u
update-initramfs: Generating /boot/initrd.img-3.7.0-5-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted

Michael Neuffer (neuffer) wrote :

I'm also still getting it.

dino99 (9d9) wrote :

Confirming that issue is gone here on i386 with "nouveau" driver on RR with only genuine repos.
As some other users still have that issue with different configs (amd64 and/or nvidia), then i revert the "fixed" status to "confirmed" like it was previously.

Changed in kmod (Ubuntu):
status: Fix Released → Confirmed
Christian (beckcb) wrote :

Desember 11th 2012

For your information only.
I was affected by this error
after the daily fresh upgrade of Ubuntu 13.04 by using the commands
sudo apt-get update;sudo apt-get dist-upgrade

The error is gone after reinstalling the two initramfs-tools packages, as
the following command output will show.

=================
sudo update-initramfs -u
[sudo] password for cbe:
update-initramfs: Generating /boot/initrd.img-3.7.0-5-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)

cbe@B9Lap:~$ sudo dpkg -l initram*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==================-==============-==============-=========================================
ii initramfs-tools 0.103ubuntu0.4 all tools for generating an initramfs
ii initramfs-tools-bi 0.103ubuntu0.4 amd64 binaries used by initramfs-tools
cbe@B9Lap:~$

sudo apt-get update; sudo apt-get install --reinstall initramfs-tools

update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.7.0-5-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)
cbe@B9Lap:~$

sudo apt-get update; sudo apt-get install --reinstall initramfs-tools-bin

Preparing to replace initramfs-tools-bin 0.103ubuntu0.4 (using .../initramfs-tools-bin_0.103ubuntu0.4_amd64.deb) ...
Unpacking replacement initramfs-tools-bin ...
Setting up initramfs-tools-bin (0.103ubuntu0.4) ...
cbe@B9Lap:~$
sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
cbe@B9Lap:~$

So now everything works ok.
Thanks for your time.

Christian.

andrew@drup.org (andrew-drup) wrote :

I'm getting it on amd64

John Swing (john-swing) wrote :

Christian, I tried your workaround and nothing has changed, I'm still getting the error when I do "sudo update-initramfs -u". Have you tried it after the reinstall ? Because your log don't show it. Thanks

Johannes (johannes-claesson) wrote :

Bug still present in 3.7.0-6.

Martin Pitt (pitti) on 2012-12-13
summary: - RR i386 : kmod_module_builtin failed
+ modprobe: Assertion `kmod_module_get_initstate(m) ==
+ KMOD_MODULE_BUILTIN' failed
Sune Keller (sune-keller) wrote :

I have kmod 9-2ubuntu3 in raring and have this problem, also after reinstalling initramfs-tools and initramfs-tools-bin.

dino99 (9d9) wrote :

Get that issue on RR i386 while trying the latest nvidia driver 313.09 from edgers on the 3.7.0.7 kernel

note: on the same system but with "nouveau" there is no problem.

fejes (anthony-fejes) wrote :

seeing this on Kubuntu 13.04 as well, on upgrade from 12.10. Running Nvidia drivers. The "fix" above does not solve the issue.

Changed in kmod (Debian):
status: Incomplete → New

im still having the issues after upgrade from 12.10 to 13.04

John Swing (john-swing) wrote :

I'm not affected by this bug anymore, but I don't know what stopped it from happening.

Timo Witte (spacefish) wrote :

i have this bug again. virtualbox kernel module is not build when it happens and i have to build it by hand!

update-initramfs: Generating /boot/initrd.img-3.7.0-7-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)
Trigger für menu werden verarbeitet ...

Blackpaw (blackpaw) wrote :

I'm getting this bug installing nvidia-current-updates on latest raring (kernel 3.8.0.0)

dino99 (9d9) wrote :

Have found something that could be related to this problem:

inside /var/log/upstart/kmod.log.1.gz:

ERROR: could not insert 'w83627ehf': Device or resource busy

dino99 (9d9) wrote :

Comment #26 above is with RR i386 & 3.8.0-0 .3 kernel, when i've tried to install the newest nvidia-310 package.

C de-Avillez (hggdh2) on 2013-01-13
tags: added: rls-r-incoming
Jelle Foks (jellefoks) wrote :

I saw this error last week while doing a kernel bisect, and the message went away when I removed the radeon module from the kernel config, probably related to the following error message:

$ sudo modprobe radeon
libkmod: ERROR ../libkmod/libkmod-module.c:791 kmod_module_insert_module: could not find module by name='off'
ERROR: could not insert 'off': Function not implemented

Now, why (or if really) the radeon module needs a module or symbol named 'off' is at this moment mystery to me...

I'm getting this on latest raring with nvidia-current...

alan@wopr:~$ sudo apt-get install nvidia-current
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libatk-bridge2.0-dev
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
  nvidia-settings
The following NEW packages will be installed
  nvidia-current nvidia-settings
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/69.5 MB of archives.
After this operation, 208 MB of additional disk space will be used.
Do you want to continue [Y/n]?
Selecting previously unselected package nvidia-current.
(Reading database ... 1188687 files and directories currently installed.)
Unpacking nvidia-current (from .../nvidia-current_304.51.really.304.43-0ubuntu2_amd64.deb) ...
Selecting previously unselected package nvidia-settings.
Unpacking nvidia-settings (from .../nvidia-settings_304.51-0ubuntu2_amd64.deb) ...
Processing triggers for man-db ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Setting up nvidia-current (304.51.really.304.43-0ubuntu2) ...
update-alternatives: using /usr/lib/nvidia-current/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode
update-alternatives: using /usr/lib/nvidia-current/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-current
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Processing quirk Latitude E6530
DEBUG:Failure to match MSI with Dell Inc.
DEBUG:Quirk doesn't match
DEBUG:Processing quirk ThinkPad T420s
DEBUG:Failure to match MSI with LENOVO
DEBUG:Quirk doesn't match
Loading new nvidia-current-304.43 DKMS files...
First Installation: checking all kernels...
Building only for 3.8.0-2-generic
Building for architecture x86_64
Building initial module for 3.8.0-2-generic
Done.

nvidia_current:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.8.0-2-generic/updates/dkms/

depmod....

DKMS: install completed.
Setting up nvidia-settings (304.51-0ubuntu2) ...
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/nvidia-settings/ld.so.conf because link group nvidia_settings_conf is broken
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.8.0-2-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)

dino99 (9d9) wrote :

Feedback on fully updated RR i386

Got the new 310.32 nvidia-310-updates, and got again the kmod fail on upgrading

but i still get that module problem with 3.8 rc5 (maybe its related ? ):

inside /var/log/upstart/kmod.log.1.gz:

ERROR: could not insert 'w83627ehf': Device or resource busy

dino99 (9d9) wrote :

update-initramfs: Generating /boot/initrd.img-3.8.0-3-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)

Blackpaw (blackpaw) wrote :

Same for 3.8.0.4

update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-current-updates
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Processing quirk Latitude E6530
DEBUG:Failure to match System manufacturer with Dell Inc.
DEBUG:Quirk doesn't match
DEBUG:Processing quirk ThinkPad T420s
DEBUG:Failure to match System manufacturer with LENOVO
DEBUG:Quirk doesn't match
Loading new nvidia-current-updates-304.64 DKMS files...
First Installation: checking all kernels...
Building only for 3.8.0-4-generic
Building for architecture x86_64
Building initial module for 3.8.0-4-generic
Error! Bad return status for module build on kernel: 3.8.0-4-generic (x86_64)
Consult /var/lib/dkms/nvidia-current-updates/304.64/build/make.log for more information.
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.8.0-4-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)

Clint Byrum (clint-fewbar) wrote :

And same for 3.8.0.5 as well.

Ronni (ronni-jensen) wrote :

I upgraded my desktop to raring and got the same error trying to install fglrx.

Andy Whitcroft (apw) wrote :

This seems to be a 'limitation' of kmod. Previously modprobe was able to understand aliases which pointed to 'off' as meaning it should silently do nothing. These seem to throw and error now. I will have a look to see if we can make kmod understand these in the interim while they are repaired.

Jelle Foks (jellefoks) wrote :

Andy, that makes total sense with what I've been seeing. Perhaps for the future it would also help if kmod (or update-initramfs) could print some more information in the error message, such as which exact module triggers the assertion.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1073062

tags: added: iso-testing
Srdjan Grubor (srdjan-grubor) wrote :

Bug is related to nvidia video drivers;

Commenting out:
alias nouveau off
alias lbm-nouveau off

from /etc/modprobe.d/nvidia-304_hybrid.conf allowed the update-initramfs to complete

Ronni (ronni-jensen) wrote :

@ Srdjan: See post 28 and 35

Im affected by this on both my laptop and my desktop - and they are both running AMD-graphics.

Blackpaw (blackpaw) wrote :

In reply to #38

It was:

  /etc/modprobe.d/nvidia-graphics-drivers.conf

for me, but that worked. Thanks Srdjan.

fglrx: Commenting those blacklisted modules caused X to show blank screen.

2013/3/2 Blackpaw <email address hidden>

> In reply to #38
>
> It was:
>
> /etc/modprobe.d/nvidia-graphics-drivers.conf
>
> for me, but that worked. Thanks Srdjan.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1132334).
> https://bugs.launchpad.net/bugs/1073062
>
> Title:
> modprobe: Assertion `kmod_module_get_initstate(m) ==
> KMOD_MODULE_BUILTIN' failed
>
> Status in NVIDIA Drivers Ubuntu:
> New
> Status in “kmod” package in Ubuntu:
> Confirmed
> Status in “kmod” package in Debian:
> New
>
> Bug description:
> get this output after upgraded RR i386 (no proposed repo):
>
> oem@oem-desktop:~$ sudo update-initramfs -u
> [sudo] password for oem:
> update-initramfs: Generating /boot/initrd.img-3.7.0-030700rc2-generic
> modprobe: ../tools/modprobe.c:550: print_action: Assertion
> `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
> Aborted (core dumped)
> WARNING: could not open
> /tmp/mkinitramfs_pu9szv/lib/modules/3.7.0-030700rc2-generic/modules.builtin:
> No such file or directory
> oem@oem-desktop:~$
>
> note: also confirmed by other users on ubuntuforums. That was with
> nvidia-current 310, so i've also tried 304 but got the same result. So
> it seems related to 3.7 kernel.
>
> Nvidia patch:
> http://www.nvnews.net/vbulletin/showthread.php?t=194465
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/nvidia-drivers-ubuntu/+bug/1073062/+subscriptions
>

Ronni (ronni-jensen) wrote :

@Ilari Yup that's what I got as well - as I tried just out of curiosity.

Srdjan Grubor (srdjan-grubor) wrote :

@Ronni If you have Radeon cards, I'm curious as to why do you have a nvidia kernel module? Either way, I think the issue is caused by dkms' handling of "alias xxxx off" commands so it might be good to grep though that directory (modprobe.d) to find occurrences of it

Srdjan Grubor (srdjan-grubor) wrote :

@Ronni after reading the full thread (my fault for not being diligent enough) you are correct and post 35 is what I found as well. The fix I mentioned got my machine hardware configuration in a working state to be able to use it but it definitively is not the permanent solution.

Ronni (ronni-jensen) wrote :

@Srdjan, I can't blame you, this thread has been pretty focused on nvidia-drivers.

I haven't investigated /etc/modprobe.d/ yet, but I suspect that only nvidia and fglrx exhibit this, because they exclude the opensource-drivers upon installation.

SweX (swexru) wrote :

update-initramfs: Generating /boot/initrd.img-3.8.0-9-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
testing raring, got this 2day.

Download full text (17.7 KiB)

I commented out both lines in BOTH files (nvidia-graphics-drivers.conf and nvidia-304_hybrid.conf), but apparently this has not helped, here is the latest output of apt-get upgrade:

Setting up nvidia-304 (304.84-0ubuntu1) ...
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/nvidia-304/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken
update-initramfs: deferring update (trigger activated)
update-initramfs: Generating /boot/initrd.img-3.8.0-8-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)
INFO:Enable nvidia-304
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
Loading new nvidia-304-304.84 DKMS files...
Building for 3.8.0-8-generic and 3.8.0-9-generic
Building for architecture x86_64
Building initial module for 3.8.0-8-generic
Done.

nvidia_304:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.8.0-8-generic/updates/dkms/

depmod....

DKMS: install completed.
Building initial module for 3.8.0-9-generic
Done.

nvidia_304:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.8.0-9-generic/updates/dkms/

depmod....

DKMS: install completed.
Setting up ubuntu-artwork (1:13.04daily13.03.05-0ubuntu1) ...
Setting up unity-lens-music (6.8.1daily13.03.04-0ubuntu1) ...
Setting up unity-lens-shopping (6.8.0daily13.03.04-0ubuntu1) ...
Setting up unity-lens-video (0.3.14daily13.03.04-0ubuntu1) ...
Setting up unity-scope-musicstores (6.8.1daily13.03.04-0ubuntu1) ...
Setting up unity-scope-video-remote (0.3.14daily13.03.04-0ubuntu1) ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Setting up nvidia-current (304.84-0ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.8.0-9-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)Setting up nvidia-304 (304.84-0ubuntu1) ...
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/nvidia-304/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken
update-initramfs: deferring update (trigger activated)
update-initramfs: Generating /boot/initrd.img-3.8.0-8-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)
INFO:Enable nvidia-304
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
Loading new nvidia-304-304.84 DKMS files...
Building for 3.8.0-8-generic a...

Rob Fargher (fargher-gmail) wrote :

Brand new install of Raring, done a dist-upgrade. Tried to instll the nvidia drivers and get:

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.8.0-9-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)

andornaut (andornaut) wrote :

I tried:

1) Comment out from /etc/modprobe.d/nvidia-graphics-drivers.conf:

#alias nouveau off
#alias lbm-nouveau of

2) sudo apt-get install linux-image-3.8.0-9-generic --reinstall

$ sudo apt-get install linux-image-3.8.0-9-generic --reinstall
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/12.5 MB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 239135 files and directories currently installed.)
Preparing to replace linux-image-3.8.0-9-generic 3.8.0-9.18 (using .../linux-image-3.8.0-9-generic_3.8.0-9.18_amd64.deb) ...
Done.
Unpacking replacement linux-image-3.8.0-9-generic ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.8.0-9-generic /boot/vmlinuz-3.8.0-9-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.8.0-9-generic /boot/vmlinuz-3.8.0-9-generic
Setting up linux-image-3.8.0-9-generic (3.8.0-9.18) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Not updating initrd symbolic links since we are being updated/reinstalled
(3.8.0-9.18 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(3.8.0-9.18 was configured last, according to dpkg)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.8.0-9-generic /boot/vmlinuz-3.8.0-9-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.8.0-9-generic /boot/vmlinuz-3.8.0-9-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.8.0-9-generic /boot/vmlinuz-3.8.0-9-generic
update-initramfs: Generating /boot/initrd.img-3.8.0-9-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)

andornaut (andornaut) wrote :

After commenting otu Comment out "alias nouveau off and "alias lbm-nouveau off" from nvidia-graphics-drivers.conf and re-running apt, I fould that that file gets overwritten during install / upgrade.

So, I worked around this issue by opening nvidia-graphics-drivers.conf in a text editor and continuously saving it while the install proceeded. This enabled the install to complete.

Executing "update-initramfs -u" manually may also work.

Srdjan Grubor (srdjan-grubor) wrote :

@andornaut makes sense. when mine worked, i was doing the manual "sudo update-initramfs -u"

Irishbandit (irishbandit) wrote :

After following the advice found in post #50. And commenting out "alias nouveau off and "alias lbm-nouveau off" from nvidia-graphics-drivers.conf updating initramfs works.

With out editing the nvidia-graphics-driver.conf, manually running sudo update-initramfs -u
does not work.

I am also experiencing this bug since I upgraded to raring last week. I am using an AMD Radeon HD 4300 card and have tried installing the most recent drivers for this hardware only to receive this same error message. I have tried to comment those lines in /etc/modprobe.d/fglrx.conf but this has had no effect.

Jelle Foks (jellefoks) wrote :

When I saw the message, it was related to the radeon driver, so perhaps turning that off in addition to nouveau may help.

Jelle Foks (jellefoks) wrote :

To me more clear, if the command below shows any file with an 'alias bla off' with bla something with radeon or nouveau in it, then edit that file and comment that line out by adding a '#' at the beginning of the line.

egrep \ off$ /etc/modprobe.d/*

Jelle Foks (jellefoks) wrote :

And after that... your nvidia or fglrx module probably won't load anymore (because it may be loading the nouveau or radeon first/instead)... So, you may have to add a 'blacklist bla' for each module for which you commented out the 'alias bla off' (bla is probably one or more of these: nouveau, lbm-nouveau, radeon, lbm-radeon) ... Just do the egrep command above again to find which files.

And, then you may still not have a nvidia/fglrx because the dkms modules may need to be rebuilt (they did for me), for which I use this command as root:

dkms status | sed s/,//g | awk '{print "-m",$1,"-v",$2}' | while read line; do ls /var/lib/initramfs-tools | xargs -n 1 dkms install $line -k; done

Then maybe another 'sudo update-initramfs -u' for good measure, and things should be good going forward without the error message of this bug report.

Changed in kmod (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → Medium
status: Confirmed → In Progress
Changed in nvidia-drivers-ubuntu:
status: New → Invalid
Changed in fglrx:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kmod - 9-2ubuntu8

---------------
kmod (9-2ubuntu8) raring; urgency=low

  * Add debian/patches/do_not_raise_on_null_alias to avoid
    raising errors when dealing with modules whose aliases
    are set to either "null" or "off" (LP: #1073062).
 -- Alberto Milone <email address hidden> Wed, 13 Mar 2013 18:02:53 +0100

Changed in kmod (Ubuntu):
status: In Progress → Fix Released
galen (galen-technomage) wrote :

----- Ubuntu 13.04 x86_64 ------

Now fix!

Alberto, great job :)

AttilioSuccio (ehol) wrote :

I can confirm it is fixed :)
Thanks, Alberto :)

Changed in kmod (Debian):
status: New → Fix Released
moueza (mouezapeter) wrote :

Still not solved on my Ubuntu 13.10 with kmod 9-3ubuntu1

sudo modprobe nouveau
libkmod: ERROR ../libkmod/libkmod-module.c:791 kmod_module_insert_module: could not find module by name='off'
ERROR: could not insert 'off': Function not implemented
libkmod: ERROR ../libkmod/libkmod-module.c:791 kmod_module_insert_module: could not find module by name='off'
ERROR: could not insert 'off': Function not implemented
libkmod: ERROR ../libkmod/libkmod-module.c:791 kmod_module_insert_module: could not find module by name='off'
ERROR: could not insert 'off': Function not implemented

Alberto Milone (albertomilone) wrote :

moueza: ok, you can see an error but it's not an actual failure. The problem described in this report was causing the modprobe to exit with an error status, whereas in your case it only prints what it considers unsupported.

To post a comment you must log in.