qt patch introduces fatal gdk_x_error handler

Bug #1195007 reported by Patrick Oßmann on 2013-06-26
130
This bug affects 44 people
Affects Status Importance Assigned to Milestone
kile (Ubuntu)
Medium
Unassigned
Raring
Undecided
Unassigned
Saucy
Medium
Unassigned
qt4-x11 (Ubuntu)
High
Unassigned
Raring
Medium
Unassigned
Saucy
High
Unassigned

Bug Description

Kile crashes when doing "file new", "file open" or any similar operation. The crash just appears since the latest ubuntu kernel update. In case of a crash, the console says:

The program 'kile' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 6878 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

** (kile:8047): WARNING **: 1 dictionaries weren't free'd.

kile(8047)/konsole Konsole::SessionManager::~SessionManager: Konsole SessionManager destroyed with sessions still alive
^C
[1]+ Exit 1 kile

OS is Ubuntu 13.04

Installiert: 1:2.1.3-0ubuntu2
  Installationskandidat: 1:2.1.3-0ubuntu2
  Versionstabelle:
 *** 1:2.1.3-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
        100 /var/lib/dpkg/status

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kile (Ubuntu):
status: New → Confirmed
Alet Roux (alet-roux) wrote :

I have the same problem. While trying to solve the problem, I deleted kile's config files, and now when I run kile, it opens up, I get a dialog saying "The standard tool list need to be reloaded because of the switch from KDE3 to KDE4. This will overwrite any changes in the tools you have made. Do you want to reload the list now (recommended)?", and, independent of whether I click "Yes" or "No", kile then crashes and leaves the following error message on the console:

kile(9877)/kdecore (KLibrary) findLibraryInternal: plugins should not have a 'lib' prefix: "libkonsolepart.so"
kile(9877)/konsole Konsole::Session::run: Attempted to re-run an already running session.
kile(9877)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."
The program 'kile' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 2084 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
kile(9877)/konsole Konsole::SessionManager::~SessionManager: Konsole SessionManager destroyed with sessions still alive

I discovered this problem for the first time today, and suspect it started just after a massive update of kde related packages. I wouldn't know where to start debugging this, but would be happy to provide further info - just ask.

m (martin-posch-mail) wrote :

As a workaround if you start kile via
sudo kile
then the crash does not occur.

By the way I get the same error at startup when I try to start kile (or any other kde program) via Xrdp from a windows machine. Again using sudo appears to resolve the problem.

Philip Muškovac (yofel) wrote :

I managed to reproduce it and get some backtraces

Philip Muškovac (yofel) wrote :

full trace

Changed in kile (Ubuntu):
importance: Undecided → Medium

I can confirm the statement given by Martin Posch that kile runs stable when starting it as sudo.

Jan (jcgb) wrote :

I have the same problem:

"File new", "File open" -> crash
rm .kde/share/config/kilerc; kile -> dialog of which both answers lead to crash
sudo kile -> all works fine

Richard Hansen (rhansen) on 2013-07-08
tags: added: badwindow
Philip Muškovac (yofel) wrote :

The now fatal X error handling is a nasty side effect by the fix for bug 1180067. It's being investigated.

tags: added: raring regression-update
Dimitri John Ledkov (xnox) wrote :

https://launchpad.net/ubuntu/+source/qt4-x11/4:4.8.4+dfsg-0ubuntu9.2

has been uploaded to revert last SRU to workaround this regression.

At a later stage an improved fix for bug #1180067 will be upload, that doesn't cause crashes.

Changed in qt4-x11 (Ubuntu):
status: New → Confirmed
Changed in kile (Ubuntu):
status: Confirmed → Invalid
Changed in qt4-x11 (Ubuntu):
importance: Undecided → High
Changed in kile (Ubuntu Raring):
status: New → Invalid
Changed in qt4-x11 (Ubuntu Raring):
status: New → Confirmed
importance: Undecided → Medium

Hello Patrick, or anyone else affected,

Accepted into raring-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in qt4-x11 (Ubuntu Raring):
status: Confirmed → Fix Committed
tags: added: verification-needed

Running kile in Ubuntu Unity 13.04 if I do Help->About Kile it crashes the application. If I update to Qt 4:4.8.4+dfsg-0ubuntu9.2 from raring-proposed I can run Help->About Kile and it does not crash.

Alet Roux (alet-roux) wrote :

The new package solves the problem for me too.

In detail, I am on Ubuntu 13.04 64-bit, using Kile 2.1.3-0ubuntu2. With Qt 4:4.8.4+dfsg-0ubuntu9.1 (I think) I am unable to start Kile (see details in my post #2), open a new file, save a file or use Save As. After updating to to Qt 4:4.8.4+dfsg-0ubuntu9.2 from raring-proposed I can do all of these things without any difficulties.

tags: added: verification-done
removed: verification-needed
Scott Kitterman (kitterman) wrote :

Fix released to raring-updates.

Changed in qt4-x11 (Ubuntu Raring):
status: Fix Committed → Fix Released
summary: - kile crashes when click on "file new + save"
+ qt patch introduces fatal gdk_x_error handler

Dear *,

After updating to Qt 4:4.8.4+dfsg-0ubuntu9.2, the bug does not appear anymore. Everything works fine again.

Thanks for support and best regards,
Patrick

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.8.4+dfsg-0ubuntu14

---------------
qt4-x11 (4:4.8.4+dfsg-0ubuntu14) saucy; urgency=low

  * Fix regression caused by LP: #1180067. (LP: #1195007)
 -- Dmitrijs Ledkovs <email address hidden> Mon, 08 Jul 2013 15:40:39 +0100

Changed in qt4-x11 (Ubuntu Saucy):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers