kdesudo fails with non-ascii passwords

Bug #400851 reported by Victor Marin on 2009-07-17
118
This bug affects 9 people
Affects Status Importance Assigned to Milestone
kdesudo (Ubuntu)
Medium
Felix Geyer
Lucid
Medium
Unassigned
Maverick
Medium
Unassigned
Natty
Medium
Felix Geyer

Bug Description

The KdeSudo window asking for the admin password which appears when I try to change
/ add software sources in KpackageKit gives me an "Invalid password" reply.

However, KpackageKit accepts the password for installing / uninstalling programs
just fine, as always.

I then have installed Adept 3.0. But this another package manager does even not
start as KdeSudo asks for the admin password before opening Adept... And it
happens the same thing. Everytime the answer it's "invalid password".

It didn't happen some time ago. So, perhaps this has to do with the fact that
when I start kate with sudo for viewing or editing system text files, one window
with the following message appears: "Could not start ksmserver. Check your
installation".

Then, when clicking on the "okay" of such window, Kubuntu brings me to the
initial login screen. (Bug: https://bugs.launchpad.net/bugs/378394 or
https://bugs.launchpad.net/bugs/400594 ).

If I do not click in the okay of such small, white xmessage window, then I can
continue normally running the OS, except that I can't get KdeSudo to accept
passwords anymore.

But, now, restarting Kubuntu does not solve this problem concerning kdesudo not
accepting the password.

So, I think I not longer can use programs which require KdeSudo to put the password.

Software: Kubuntu 9.04 (i386), KDE 4.2.4.

TEST CASE:
* change the user password to "12345§"
* run the command: kdesudo konsole
  - kdesudo doesn't accept the password
* update the kdesudo package
* run "kdesudo konsole" again
  - konsole opens with root privileges

Philip Muškovac (yofel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in kdesudo.

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → kdesudo (Ubuntu)
Victor Marin (vms368) wrote :

Thanks. I will keep in mind your advices regarding how to associate the bugs with the appropriate package so it is sure it can be viewed by the right team.

Otherwise, I tried to uninstall kdesudo then to run KpackageKit for changing software sources and it worked with su... the first time. Next times it does not open the window of the software sources.

I then have re-installed KdeSudo. But it continues the same. Also kate not longer works if trying to use KdeSudo as the password is not longer accepted.

I am considering to format and re-install Kubuntu 9.04, THEN to be very careful for NOT using sudo at all, anymore.

But I think it shouldn't be this way... The system should not break just for using a normal linux command like sudo, whatsoever.

Victor Marin (vms368) wrote :

I just formatted and re-installed Kubuntu 9.04... The operating system it's
absolutely new now... But KdeSudo still does NOT accept the password, also once
installed all current updates (to KDE 4.2.4, too) and restarting the OS.

I can't access to the NTFS partition, unless I modify PolicyKit authorisations
for mounting internal drives (for which there is not need to use KdeSudo), nor I
can modify the software sources at KpackageKit, or the parameters of
StartUpManager, or to start Kate using KdeSudo. Any applications using KdeSudo
can't start or work properly as do not accept the password.

However I can install programs normally using KpackageKit (and the same
password, even by copy & paste).

Therefore, it has nothing to do with to have used sudo previously, as I thought.
It simply seems to be a KdeSudo bug. And, surprisingly, the OS worked fine for most
a month, before starting to happen this bug.

NOTE.- I have downloaded another Kubuntu 9.04 (i386) image and have checked its
md5sum before burning it with K3b. It also burned Ok. Then I have checked the CD
for possible errors before installing Kubuntu for the third time. Everything went Ok,
but the same bug has appeared once again.

Hardware: Laptop HP 6735b, AMD Turionx2 Ultra ZM80, 2Gb/160Gb.
Software: Kubuntu 9.04 (i386).

pandora (pandora12) wrote :

I can confirm the presence of this bug in Kubuntu Jaunty. The problem only manifests when using passwords with non-alphanumeric ("special" characters) characters. Synaptic starts a kdesudo dialog which asks for the password, but fails to accept it. Starting synaptic from the command-line (sudo synaptic) works as expected.

pandora (pandora12) wrote :

Forgot to add machine information:

Software: 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux
Hardware: Laptop Acer Aspire 7530G, AMD Turion X2 Ultra ZM-80

Terrax (tball-es) wrote :

This bug still persists on karmic alpha 6. kdesudo doesn't work if your password contains specialcharacters like æ,ø or å.
Is this an encoding problem?

Terrax (tball-es) wrote :

Og btw.

I got a danish keyboard and layout.
$ locale
LANG=da_DK.UTF-8
LANGUAGE=
LC_CTYPE="da_DK.UTF-8"
LC_NUMERIC="da_DK.UTF-8"
LC_TIME="da_DK.UTF-8"
LC_COLLATE="da_DK.UTF-8"
LC_MONETARY="da_DK.UTF-8"
LC_MESSAGES="da_DK.UTF-8"
LC_PAPER="da_DK.UTF-8"
LC_NAME="da_DK.UTF-8"
LC_ADDRESS="da_DK.UTF-8"
LC_TELEPHONE="da_DK.UTF-8"
LC_MEASUREMENT="da_DK.UTF-8"
LC_IDENTIFICATION="da_DK.UTF-8"
LC_ALL=

vmsiam (vmsiam) wrote :

I have a similar problem. Just installed Kubuntu 9.10 on a toshiba satellite
Kdesudo does not accept passwords at all. I do not have foreign characters in it.
I only can use the admin password in the admin account.
when I switch to a new user, I am not able to install or change the system, because it would not accept any admin password.
even if I go to the terminal in that user account, neither su nor sudo nor kdesudo work
cant launch any programs from the terminal that require password. any ideas??

Giuseppe Pennisi (giupenni78) wrote :

I can confirm this bug with Kubuntu 10.10 too.
I think this is a huge bug.

Changed in kdesudo (Ubuntu):
status: New → Confirmed
Mazzhe (mazzhe) wrote :

I think I've got the same bug :
kdesudo doesn't accept every passwords. When I choose a password starting with § (for example : "§kdesudo"), kdesudo says "invalid password". (but I can use sudo without problems) If I choose another one, it works...

Using Kubutu10.10 (KDE 4.5.1)

tags: added: kubuntu
Changed in kdesudo (Ubuntu):
milestone: none → ubuntu-11.04
Felix Geyer (debfx) on 2011-01-27
summary: - KdeSudo not longer accepts the password
+ kdesudo fails with non-latin1 passwords
Felix Geyer (debfx) on 2011-01-27
Changed in kdesudo (Ubuntu):
assignee: nobody → Felix Geyer (debfx)
importance: Undecided → Medium
milestone: ubuntu-11.04 → natty-alpha-2
status: Confirmed → In Progress
Changed in kdesudo (Ubuntu Lucid):
importance: Undecided → Medium
Changed in kdesudo (Ubuntu Maverick):
importance: Undecided → Medium
Changed in kdesudo (Ubuntu Lucid):
status: New → Triaged
Changed in kdesudo (Ubuntu Maverick):
status: New → Triaged

This bug was fixed in the package kdesudo - 3.4.2.3-2ubuntu3

---------------
kdesudo (3.4.2.3-2ubuntu3) natty; urgency=low

  * Fix encoding of non Latin-1 passwords. (LP: #400851)
    - Add fix_password_encoding.patch
  * Pass the sequence as the first parameter to dh.
 -- Felix Geyer <email address hidden> Sat, 29 Jan 2011 12:25:00 +0100

Changed in kdesudo (Ubuntu Natty):
status: In Progress → Fix Released

Thanks for the fix. Will be fixed in Maverick too?

Felix Geyer (debfx) on 2011-02-01
Changed in kdesudo (Ubuntu Maverick):
assignee: nobody → Felix Geyer (debfx)
status: Triaged → In Progress
Felix Geyer (debfx) on 2011-02-01
summary: - kdesudo fails with non-latin1 passwords
+ kdesudo fails with non-ascii passwords
Felix Geyer (debfx) on 2011-02-04
description: updated
Felix Geyer (debfx) wrote :

debdiff for maverick

Felix Geyer (debfx) wrote :

debdiff for lucid (needs to wait until 10.04.2 is released)

Changed in kdesudo (Ubuntu Maverick):
assignee: Felix Geyer (debfx) → nobody
status: In Progress → Triaged
Martin Pitt (pitti) wrote :

Felix, please feel free to upload the lucid update. It's ok to sit in the -proposed queue for some time, and now lucid-proposed has thawed again, too.

Changed in kdesudo (Ubuntu Maverick):
status: Triaged → Fix Committed
tags: added: verification-needed

Accepted kdesudo into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Victor Marin (vms368) wrote :

Hi,

I was using Ubuntu 64 - 10.10 in my HP laptop lately... Not problem, I installed Kubuntu 10.10 again ;)

So I do have now three OS: Ubuntu and Kubuntu 10.10 (and... Windows Vista 64 for playing some non-Linux-games-yet, from time to time).

In the fresh Kubuntu 64 10.10, KDE 4.5.1 install, I firstly have arranged for a "normal" password (only letters and numbers without symbols and shorter than 8 characters long).

Then, I have changed my password to a whopping 28 characters long one, mixing letters (uppercase and lowercase) and numbers with ASCII symbols like: @, $, (, >, =, ], or {.

The "complicated" passwords now work just nice in Kubuntu using KDE 4.5.1.

Finally, I have updated KDE to 4.6.0 and, then, for this time I have arranged for another "just" 15 characters long password, including also some non-ASCII, like: ñ, Ñ, ç, Ç, ¡ or ¿ (from my Spanish keyboard).

Despite the warning message about setting-up a password more than 8 characters long (displayed both in KDE 4.5.1 and in the 4.6.0 version), the new mixed passwords are now accepted and confirmed (in both quoted KDE versions).

Then it also work OK all kinds of passwords I have set-up for authenticating the administrative tasks.

I just have to say a BIG Thanks.

Victor Marin (vms368) wrote :

Of course, I firstly updated Kubuntu with all updates available right upon installing Kubuntu 10.10; And, then, I also updated to the proposed-updates repository then restarted the system, before starting the tests.

Martin Pitt (pitti) wrote :

Accepted kdesudo into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in kdesudo (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: iso-testing
Jonathan Thomas (echidnaman) wrote :

Comments 18 and 19 are verification for maverick, but the verification-needed tag probably needs to stay around for lucid?

Jonathan Riddell (jr) wrote :

I loaded up a lucid image, set the password to contain some non-ascii characters, set sudoers to require a password. kdesudo returned "incorrect password" when I ran it. I installed 3.4.2.3-0ubuntu1.1 ran kdesudo and it accepted the password.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdesudo - 3.4.2.3-0ubuntu1.1

---------------
kdesudo (3.4.2.3-0ubuntu1.1) lucid-proposed; urgency=low

  * Fix encoding of non-ASCII passwords. (LP: #400851)
    - kdesudo/kdesudo.cpp: replace toLatin1() calls with toLocal8Bit().
 -- Felix Geyer <email address hidden> Fri, 04 Feb 2011 17:18:07 +0100

Changed in kdesudo (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdesudo - 3.4.2.3-2ubuntu2.1

---------------
kdesudo (3.4.2.3-2ubuntu2.1) maverick-proposed; urgency=low

  * Fix encoding of non-ASCII passwords. (LP: #400851)
    - Add fix_password_encoding.patch
 -- Felix Geyer <email address hidden> Fri, 04 Feb 2011 17:01:57 +0100

Changed in kdesudo (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers