Ubuntu

Unable to set Kmail as default email provider in Gnome

Reported by Alfred on 2011-06-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KDE PIM
Fix Released
Low
kdepim (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-control-center

On Natty 11.04 AMD64, I am using Kmail as my default mail client, but it is not possible to select Kmail from gnome-default-applications-properties. It is not even possible to give a command line option as in older Ubuntu versions, only Opera, Opera Next, Evolution are shown.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-control-center 1:2.32.1-0ubuntu15
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic 2.6.38.4
Uname: Linux 2.6.38-9-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Jun 2 02:46:12 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
ProcEnviron:
 LANGUAGE=de_AT:en
 LANG=de_AT.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

lp:~fougner/ubuntu/oneiric/kdepim/fix-for-791635
Jamie Strandboge: Needs Information on 2011-07-13
Jeremy Bicha (community): Needs Fixing on 2011-06-18
Ubuntu branches: Pending requested 2011-06-17
Alfred (alfred-egger) wrote :
Austin Dempewolff (adempewolff) wrote :

this bug also affects me. I filed a report at https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/793212 before I noticed this one. I'm not going to mark mine as a duplicate for now because it has a little more background information about the functionality that use to be present--and mine doesn't concern the auto-detecting of kmail, just the missing custom option.

I can root around a little to see if this is reported at all in the forums and I'll confirm if I find anything. Otherwise I'll wait for someone else to reproduce the problem and confirm (should be easy enough to reproduce).

Jeremy Bicha (jbicha) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. I have classified this bug as a bug in kdepim, the source package for kmail.

The ability to set custom default email apps was already reported as bug 708382. Kmail just needs the right fields added to its .desktop file for it to be supported out of the box.

affects: gnome-control-center (Ubuntu) → kdepim (Ubuntu)
Changed in kdepim (Ubuntu):
importance: Undecided → Low
status: New → Triaged
summary: - gnome-default-applications-properties gives no option for Kmail (or any
- other custom mail client) if installed
+ Unable to set Kmail as default email provider in Gnome
Jeremy Bicha (jbicha) wrote :

This is a relatively easy bug for someone new to contributing. Just look at the .desktop files for other email providers like Evolution or Thunderbird and add the missing lines to Kmail.

This should also be reported to KDE upstream and fixed there.

tags: added: bitesize
Changed in kdepim:
importance: Unknown → Low
status: Unknown → New
Changed in kdepim:
status: New → Fix Released
Harald Sitter (apachelogger) wrote :

Closing in favor of upstream report.

FWIW, 4.7.3 will land in oneiric-updates some time novemberish.

Changed in kdepim (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.