custom option missing for email in preferred applications

Bug #793212 reported by Austin Dempewolff on 2011-06-05
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-control-center

One used to be able to use a custom application (or run a custom script) for email in the Preferred Applications gui (gnome-default-applications-properties). For example see this tutorial: http://www.linux-geek.co.nz/2011/06/04/set-gmail-as-default-mail-client-in-ubuntu/, or bugs filed against this functionality, such as this one: https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/252253.

However, in 11.04 the custom item is no longer present in the drop-down menu. The custom option is still present in the menus for the applications in the other tabs (Multimedia, System, and Accessibility), but it is not present in the two drop-down menus in the Internet tab.

The ability to choose custom default mail and web applications is vital for those who use applications that are not automatically detected by Ubuntu. Furthermore, for those who prefer to use a browser-based email client such as Gmail or Outlook Web App, we need to be able to run a custom script to launch a browser.

As I don't believe I've made any modifications to this part of the OS, this bug should be reproducible by anyone using Natty Narwhale by going to 'System Settings' in the power-menu, then clicking 'Preferred Applications', and then clicking on either of the two drop-down menus in the Internet tab. This GUI can also be accessed by pressing alt-F2, then typing 'gnome-default-applications-properties', or searching for 'Preferred Applications' using Unity.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-control-center 1:2.32.1-0ubuntu15
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Sun Jun 5 13:44:40 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Austin Dempewolff (adempewolff) wrote :
description: updated
Austin Dempewolff (adempewolff) wrote :
Austin Dempewolff (adempewolff) wrote :
Austin Dempewolff (adempewolff) wrote :
Jacob Godin (jacobgodin) wrote :

I second this. Also running Natty amd64.

Jeremy Bicha (jbicha) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 708382, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers