Ubuntu

kde samba sharing doesn't work - remove msdfs proxy option in smb.conf

Reported by Romain Despland on 2007-03-24
76
Affects Status Importance Assigned to Milestone
KDE Network
Fix Released
Medium
kdenetwork (Ubuntu)
Medium
Unassigned

Bug Description

I have kubuntu feisty fawn and ubuntu feisty fawn on two different computers. I first shared a folder with Ubuntu, it automatically installed smb and nfs and the sharing of a directory worked perfectly.

Then I tried in Kubuntu, firstly I had to do a manual install of smb and nfs, is that normal ?, because the sharing application told me smb and/or nfs was missing but no automatic installation like on Ubuntu. Then when I shared a folder I could not access it even though i could see it from both Ubuntu and Kubuntu. Something like this folder cannot be found. I looked at the differences between the smb.conf of Ubuntu and Kubuntu.

Kubuntu :

[name]
path = /home/folderpath
guest ok = yes
read only = no
case sensitive = no
strict locking = no
msdfs proxy = no

Ubuntu :
[name]
path = /home/folderpath
available = yes
browsable = yes
public = yes
writable = yes

So I deleted all the options of the smb.conf of kubuntu and wrote the ones found in Ubuntu.

Why is there such a difference, especially when it doesn't work out of the box with kubuntu ?

ProblemType: Bug
Architecture: i386
Date: Sat Mar 24 13:35:53 2007
DistroRelease: Ubuntu 7.04
Uname: Linux Tux 2.6.20-12-generic #2 SMP Wed Mar 21 20:55:46 UTC 2007 i686 GNU/Linux

Exact same problem on Xubuntu. File sharing via samba works great from Ubuntu, but fails from a Xubuntu server.

I can see the shared folder on the network from ubuntu machines, but attempts to access yield only "The folder contents could not be displayed"

If I share via NFS, it works, but since Ubuntu doesn't support NFS auto-discovery, that's not much consolation.

I even tried copying the smb.conf from the ubuntu box to the xubuntu box - same error.

Thom Pischke (thom-pischke) wrote :

Well, after examining the samba logs, seems this is actually some sort of permissions problem. I don't know why unfortunately since I already tried smbpasswd -a <user> on the server, using the username of the account on the client computer.

What baffles me is that using an identical smb.conf on an Ubuntu server works hassle-free, with no passwords and no errors. Only with Xubuntu does the permissions problem occur.

The 'Contents could not be displayed' error in the GUI is also quite uninformative.

At any rate, my problem seems unrelated to that described in bug #91221, but is maddening nonetheless. Seems like Ubuntu and Xubuntu would function identically here, but they just don't.

ivan (ivan.tg) wrote :

Hi everyone,
I just installed the Kubuntu and had this problem. I read the description above. And i played with the sharing options. Here is what i found... the problem comes from these two options :
case sensitive
msdfs proxy

And it does not matter to what value you set them (no/yes) it just does not work. Below i have commented out the Ubuntu options and put back the Kubuntu ones... but with case sensitive and msdfs proxy commented too. It worked.

[share]
path = /home/ivan/share/
#available = yes
#browseable = yes
#public = yes
guest ok = yes
read only = no
guest account = ivan
#case sensitive = no
strict locking = no
guest only = yes
#msdfs proxy = no

Sztefan (daniel-mucha) wrote :

THX ivan :* smb sharing works perfectly for me now

[share]
path = /media/hda6/share/
guest ok = yes
strict locking = no
force user = nobody
force group = nogroup
##########Evil############
#case sensitive = no
#msdfs proxy = no

commenting those 2 options really fix the problem

erikja (erik-ja) wrote :

Hi.

How did You do this ??:

"I first shared a folder with Ubuntu, it automatically installed smb and nfs and the sharing of a directory worked perfectly."

TIA

Henrik Nilsen Omma (henrik) wrote :

Probably not a problem with Samba but rather kdenetwork. RFE: please add better out-of-the-box samba support.

Changed in samba:
importance: Undecided → Medium
status: New → Confirmed
Changed in kdenetwork:
status: Unknown → New
Changed in kdenetwork:
status: New → Confirmed
Changed in kdenetwork:
status: Confirmed → Fix Released
philippe (pgu-tiscali) wrote :

Had to fight with this problem. According to what I read, the line "msdfs proxy = no" does not make sense. See from the smb.conf doc :

=========================
msdfs proxy (S):

This parameter indicates that the share is a stand-in for another CIFS share whose location is specified by the value of the parameter. When clients attempt to connect to this share, they are redirected to the proxied share using the SMB-Dfs protocol.

Only Dfs roots can act as proxy shares. Take a look at the msdfs root and host msdfs options to find out how to set up a Dfs root share.

No default

Example: msdfs proxy = \otherserver\someshare
===========================

Maybe an old version (or a newer one) of samba can interpet "no" as a tag, but obviously not the on you get from gusty repository. So unless "no" points to a location in your system ... this drives you nowhere. SO this is definitevly a bug from the front end kdenetwork

Wim (eindjedrop) wrote :

Using Kubuntu Gutsy
Work around by commenting 2 lines works
##########Evil############
 #case sensitive = no
 #msdfs proxy = no

Another work around is to make sure that the section "Misc" in smb.conf has the folling option:
############ Misc ############
...
host msdfs = no

The above option can be set from the Kcontrol module and is by default "host msdfs = yes"
Kcontrol-> Internet -> Samba -> Advanced -> VFS -> Host msdfs checkbox.
I could not find the option in the standard System settings.

If this option is set it is not necessary to comment the lines "msdfs proxy" and "case sensitive = no"

Richard Johnson (nixternal) wrote :

Fix released with the 3.5.9 packages. Thanks!

Changed in kdenetwork:
assignee: nobody → nixternal
status: Confirmed → Fix Released
alfredo (alacis) wrote :

This is still broken in a new install of kubuntu 8.04.

I heard why it was broken. People who are in the pay of a b-i-i-i-g, unnamed company are doing these changes, to make a certain commercial product shipped with many PCs, look better.

Who knows how to find out who did these changes? *I* don't. Do you know who they are, and who they work for?

I also heard a rumour that these paid soldiers also forced UUIDs on ubuntu file systems, thus breaking the mount-points on upgraded systems, again, forcing many Mom & Pop users, in frustration, to return to the commercial world.

Still broken in new install of Kubuntu 8.10.

I don't know that The-Company-That-Should-Not-Be-Named is directly behind the lack of progress on this bug. I think it is more of an inherent distaste for fraternization between OS's on the part of the coders involved...

Jan Hlodan (wewek) wrote :

same problem in Kubuntu 9.04

Changed in kdenetwork (Ubuntu):
status: Fix Released → New
imackee (iwm) wrote :

same problem in Kubuntu 9.04 as of 4th Aug 2009. There is something wrong with share setting. If you go to properties in Dolphin and click on the sharing button it will sometimes put up the password prompt but not always. Filling in the admin password does not open any further dialogue. Similarly in the Samba entry of Computer settings, clicking on the Samba icon does not reveal and fresh dialogue.
Something works, however, as it is possible to connect to my laptop, which is linked to a wireless router, as I can see shared directories on the laptop. The laptop temporarily runs Win XP. The problem is that I cannot set any directory on the Kubuntu box to shared. This used to be easier with Gnome in previous incarnations.

Hi,
doesn't work also with karmic.

Hi,
actually it works installing the 'kdenetwork-filesharing' package in addition to samba (since it isn't pulled automatically).

Changed in kdenetwork (Ubuntu):
assignee: Richard Johnson (nixternal) → nobody
status: New → Triaged
Jonathan Thomas (echidnaman) wrote :

New issues are different.

Changed in kdenetwork (Ubuntu):
status: Triaged → Fix Released
Changed in kdenetwork:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.