pppd dies on connection

Bug #36655 reported by Germ
36
Affects Status Importance Assigned to Milestone
kdenetwork (Ubuntu)
Fix Released
High
Daniel Hahler

Bug Description

Kubuntu Flight 5

kppp dials, does the handshake, then pppd dies when logging onto the network.

error message: pppd died unexpectedly

WORKAROUND (for Dapper, should be fixed since Edgy):
Edit /etc/ppp/peers/kppp-options and replace #noauth with noauth

See also /usr/share/doc/kppp/README.Debian

Revision history for this message
Alexandre Otto Strube (surak) wrote :

Germ, does this still happens on flight 6?

Revision history for this message
Germ (stephengermany) wrote :

I'm just downloading Flight 6 at work. I'll try it when I get home and post back.

Matt Zimmerman (mdz)
Changed in isdnutils:
status: Unconfirmed → Needs Info
Revision history for this message
Germ (stephengermany) wrote :

Finally got Flight 6 installed. It has the same problem.

I did find a solution. Edit /etc/ppp/peers/kppp-options and uncomment "noauth". Then kppp dials, connects, and stays connected.

This really needs to be fixed. Not many new users are going to know to do that or how to figure it out and will just give up.

Revision history for this message
Alexandre Otto Strube (surak) wrote :

Ok, confirming the bug. It's up to developers now.

Changed in isdnutils:
status: Needs Info → Confirmed
Revision history for this message
Germ (stephengermany) wrote :

Same behavior on beta 2.

Revision history for this message
Matthias Klose (doko) wrote :

reassign to kppp

Revision history for this message
Alexandros Papadopoulos (apapadop) wrote :

Same behavior on 6.06 LTS! Both this and the relevant kppp bugs are still open...

Revision history for this message
Vassilis Pandis (pandisv) wrote :

actually assigning to kdenetwork

Revision history for this message
Germ (stephengermany) wrote :

Any progress?

There are still a lot of people still stuck with dialup and this is a real show-stopper.

Revision history for this message
Paul Dufresne (paulduf) wrote :

Looking in feisty I see that
/etc/ppp/peers/kppp-options just contains 'noauth'.
But I have no 56k modem to test that it actually works.
If someone have a 56k modem that works well with Linux, he could
try:
https://wiki.kubuntu.org/FeistyFawn/Herd5/Kubuntu
and tell here if it goes well?

Paul Dufresne (paulduf)
Changed in kdenetwork:
assignee: nobody → kubuntu-team
Revision history for this message
Germ (stephengermany) wrote :

I'll try it and report back. It will be a couple of days. I'll have to download the ISO at work and then take it home. I'm on a 31.2 dialup connection at home so I can't download there.

Revision history for this message
Germ (stephengermany) wrote :

Downloaded the alternate ISO. md5sum checked OK.

Burned and verified the CD using K3b.

Booted the install disk and after choosing Guided Partitioning the install hung at "Computing the new partitions" with the keyboard LEDs flashing.

Revision history for this message
Germ (stephengermany) wrote :

OK, got it installed using manual partitioning.

/etc/ppp/peers/kppp.options is now configured correctly.

/etc/resolv.conf is still not created. I had to manually create the file.

Kppp then connected after manually creating resolv.conf.

Revision history for this message
Pierre Bauduin (pierrebauduin) wrote :

Hello,

I can confirm this bug still happens on Ubuntu 6.06 LTS, even with latest updates.

Revision history for this message
Germ (stephengermany) wrote :

Apparently those of us stuck with dial up are low on the priority list...

Revision history for this message
Pierre Bauduin (pierrebauduin) wrote :

Well it's rather "bugs in Ubuntu 6.06 LTS are low on the priority list..."

It's a pain, though. Installed 6.06 LTS on my neighbour's computer thinking "I won't have to upgrade it every six months". Now it appears the only way to get rid of this bug is to install Feisty...

Revision history for this message
Uqbar (uqbar) wrote : Re: [Bug 36655] Re: pppd dies on connection

On Tuesday 12 June 2007 23:18:23 Pierre Bauduin wrote:
> Well it's rather "bugs in Ubuntu 6.06 LTS are low on the priority
> list..."
>
> It's a pain, though. Installed 6.06 LTS on my neighbour's computer
> thinking "I won't have to upgrade it every six months". Now it
> appears the only way to get rid of this bug is to install Feisty...

I did it (to Edgy actually) for that reason.
In my opinion "LTS" is not really working unless it means
"what's working is bein supported".

--
Vincenzo Romano
--
Maybe Computer will never become as intelligent as Humans.
For sure they won't ever become so stupid. [VR-1988]

Revision history for this message
Pierre Bauduin (pierrebauduin) wrote :

Finally fixed the problem.

After some discussion with people from #ubuntu-devel, it appears the solution is to edit /etc/ppp/peers/kppp-options and replace #noauth with noauth. That's what I just did and indeed this solves the problem of ppp crashing.

But, hey, this bug is in Ubuntu 6.06 LTS since it was out, in June 2006.
Would be nice if it could be fixed.
There's just one line to uncomment.

Revision history for this message
Daniel Hahler (blueyed) wrote :

Fixed since Edgy in Ubuntu, so marking as such.
For Dapper, there's a workaround and it's documented in /usr/share/doc/kppp/README.Debian.
Debian still disables "noauth" for security reasons.

Please file new bugs for any other issues, which are not caused by having "noauth" no enabled.

Changed in kdenetwork:
assignee: kubuntu-team → blueyed
status: Confirmed → Fix Released
description: updated
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers