Ubuntu

KRDC no longer connects to RDP over VNC-connection

Reported by Sokraates on 2008-08-27
4
Affects Status Importance Assigned to Milestone
kdenetwork (Ubuntu)
Undecided
Unassigned

Bug Description

Latest Intrepid Ibex updates a few minutes ago.

krdc:
  Installed: 4:4.1.0-0ubuntu2
  Candidate: 4:4.1.0-0ubuntu2
  Version table:
 *** 4:4.1.0-0ubuntu2 0
        500 http://at.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

Access some needed applications for work, I have to connect to our company network (Cisco) over VNC and then access the desktop on the server (Win 2003) over RDP. It's the same procedure when using Windows, too.

Connecting to the network via KVNC works. Connecting to the server worked on Saturday and Sunday (23rd and 24th August, I did a clean install of Intrepid on the 23rd), then it stopped working. KRDC says, he's connecting to the server, but nothing happens.

When I try to connect without specifying a username or password, I'm duly asked for the data. I also tried to connect to fake servers and I received an appropriate error message. So KRDC seems to at least recognize that the server exists. But it won't connect.

Ther have been not changes to our servers in the last weeks.

There have been several updates to krdc since you reported this bug. Does it still occur with the latest version?

Changed in kdenetwork:
status: New → Incomplete
Sokraates (sokraates) wrote :

Yes, it does. Using a Hardy installation, it works.

I tried to connect using gnome-rdp, but tehre I get other errors, so I'm no longer absolutely convinced that the error lies with KRDC. Maybe it's KVPN that erroneously reports a VPN-connection, which doesn't exist.

Is there any (easy) way I can verify, whether the VPN-connection atually exists?

Sokraates (sokraates) wrote :

I tried a lot in the past hours and it seems that the problem was not (only?) KRDC but rather (also?) related to KVPNC, NetworkManager and/or resolv.conf.

This is surprising given that KRDC recognized whether the server I wanted to connect to within the VPN exists, so the connection as well as the name resolution must have worked in some way. Maybe someone could give me a clue on what I could do to triage this further?

Anyway, I didn't change anything within KRDC. First I created /etc/vpnc.conf and added all the details. If this missing file caused a problem, there must be a bug within KVPNC.

Then I also edited /etc/resolv.conf and added the nameserver within the VPN as new nameserver and also added "search my.vpn.com" (where my.vpn.com is replaced by the acctual domain).

After all these changes, the connection worked.

A restart or new connection will, unfortunately, destroy the resolv.conf so it needs to be restored every time.

I'm using network-manager-gnome for connecting with my USB-modem (since knetworkmanager is currently busted), but connecting through ppp and the command line will require the same workaround. My VPN- connection is established through KVPNC.

In any case, the connection works "out of the box" under Hardy (install KVPNC, configure, connect through KRDC) and it also did so in the early stages of Intrepid. So there's definitely a bug. Is it resolv.conf? Is it the missing vpnc.conf? Or both?

Could anyone help me out how to triage this further? Are there any files worth attaching?

Sokraates (sokraates) wrote :

The problem was solved after removing the package resolvconf.

The root of the problem seems to be that resolvconf and network-manager conflict in writing to /etc/resolv.conf. resolvconf seems to get priority here but does not seem to have all relevant information, which network-manger obviously has, even though I connect through KVPNC.

It's strange, but this seems to be the only logical explanations, since network-manager has always produced a correct /etc/resolv.conf after the removal of resolvconf.

I've also switched from network-manager-gnome to network-manager-kde once it has been adapted to the new API. However, the problem persisted until I removed resolvconf.

So is this a bug in resolvconf, kdenetwork, both or something else entirely? Someone with more understanding of the matter should please correct the affected package, if necessary.

Changed in kdenetwork:
status: Incomplete → New
John Doe (johndoe32102002) wrote :

This is a bug in KVPNC. I confirmed it both on Ubuntu Hardy / Intrepid and the Nokia N810 (ARM architecture).

Thomas Hood (jdthood) wrote :

Reported to be a bug in krdc rather than in resolvconf.

affects: resolvconf (Ubuntu) → kdenetwork (Ubuntu)
Thomas Hood (jdthood) wrote :

Just a comment about the earlier alleged bug in resolvconf. If resolvconf and NetworkManager are fighting over resolv.conf then the solution is to make NetworkManager use resolvconf rather than fight it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers