Cannot create samba user with kcontrol samba module

Bug #16575 reported by Zoltan Peczoli on 2005-04-29
50
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KDE Base
Unknown
Medium
kdebase (Debian)
Confirmed
Unknown
kdenetwork (Ubuntu)
Low
Unassigned

Bug Description

Using kcontrol's samba configuration tool (Internet & Network -> Samba), adding
a user on the Users tab does not take effect (eg. After adding a user, trying to
assign users to a share pops up an empty list of users - at this time on the
console a 'QFile::open: No file name specified' message appears). Moreover,
after adding a user leave the samba module, then come back again - voila, the
user list is empty.

See debian bug #293960.

Version: (using KDE KDE 3.3.2)
Installed from: SuSE RPMs
OS: Linux

In KDE configuration control center, I have added my personal UNIX account into samba user list to be able to browse shared directories on the local server.

Next time, I came back into users tab. I could not see my account into samba users list. Only root user was left.

samba security level is " user ".

I can reproduce this problem with KDE 3.4.0 (kubuntu)

Also, I want to add that when I add a user, apply remains disabled. This is not a problem for any other setting in this particular module, so I thought it might be related.

Thanks for this module. It's tools like this that make Linux easy to use.

Zoltan Peczoli (peczoli) wrote :

Using kcontrol's samba configuration tool (Internet & Network -> Samba), adding
a user on the Users tab does not take effect (eg. After adding a user, trying to
assign users to a share pops up an empty list of users - at this time on the
console a 'QFile::open: No file name specified' message appears). Moreover,
after adding a user leave the samba module, then come back again - voila, the
user list is empty.

See debian bug #293960.

Debian Bug Importer (debzilla) wrote :
Download full text (3.4 KiB)

Message-Id: <email address hidden>
Date: Sun, 06 Feb 2005 23:14:24 -0500
From: Filipus Klutiero <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: kdenetwork-filesharing: Adding Samba user fails with no feedback

Package: kdenetwork-filesharing
Version: 4:3.3.2-1
Severity: normal

Adding a Samba user seems to work, but nothing changes after the module
is left.

1.Open control center.
2.Choose the Samba Configuration module.
3.Administrator Mode.
4.Switch to the "Users" tab.
5.Choose a UNIX user and click "Add".
6.Choose password and click "Apply".
7.Leave Samba Configuration module and come back to the Users tab.

Expected result : The UNIX user added is shown.

Actual result : No new user appears.

I'm joining my smb.conf.

# Samba config file created using SWAT
# from 127.0.0.1 (127.0.0.1)
# Date: 2005/01/16 20:35:16

# Global parameters
[global]
workgroup = MSHOME
server string = %h server
security = share
obey pam restrictions = yes
passdb backend = tdbsam, guest
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n
*Retype\snew\sUNIX\spassword:* %n\n .
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
dns proxy = no
preload = global homes printers
panic action = /usr/share/samba/panic-action %d
invalid users = root
restrict anonymous = no
domain master = no
preferred master = no
max protocol = NT
ldap ssl = No
server signing = Auto

[homes]
comment = Home Directories
valid users = chealer
read only = no
create mask = 0700
directory mask = 0700
case sensitive = no
msdfs proxy = no
admin users = chealer
guest ok = yes

[printers]
comment = All Printers
path = /tmp
read only = No
create mask = 0700
guest ok = Yes
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers
read only = No
guest ok = Yes

[HP]
path = /tmp
read only = No
guest ok = yes
printable = Yes
printer name = HP
printing = cups

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.8-2-k7
Locale: LANG=fr_CA, LC_CTYPE=fr_CA (charmap=ISO-8859-1)

Versions of packages kdenetwork-filesharing depends on:
ii kdelibs4 4:3.3.2-1 KDE core libraries
ii libart-2.0-2 2.3.16-6 Library of functions for 2D graphi
ii libc6 2.3.2.ds1-18 GNU C Library: Shared libraries an
ii libfam0c102 2.7.0-6 client library to control the FAM
ii libgcc1 1:3.4.3-6 GCC support library
ii libice6 4.3.0.dfsg.1-8 Inter-Client Exchange library
ii libidn11 0.5.2-3 GNU libidn library, implementation
ii libpng12-0 1.2.8rel-1 PNG library - runtime
ii libqt3c102-mt 3:3.3.3-7 Qt GUI Library (Threaded runtime v
ii libsm6 4.3.0.dfsg.1-8 X Window System Session Management
ii libstdc++5 1:3.3.5-6 The GNU Standard C++ Library v3
ii libx11-6 4.3.0.dfsg.1-8 X Window System protocol client li
ii libxext6 4.3.0.dfsg.1-8 X Wi...

Read more...

I can completely confirm this. Actually I've never seen this particular feature work and I've tested it in every new KDE version since 3.3.x. Using "smbpasswd -a" from command line works no problem. The user also shows up in kcmsamba.

Package: kdenetwork-filesharing
Version: 4:3.5.1-2
Followup-For: Bug #293960

It seems that in KDE 3.5.1, the Apply button is not enabled after adding
a UNIX user. So, something is still wrong.

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15-1-686
Locale: LANG=fr_CA.UTF-8, LC_CTYPE=fr_CA.UTF-8 (charmap=UTF-8)

Versions of packages kdenetwork-filesharing depends on:
ii kdelibs4c2a 4:3.5.1-2 core libraries for all KDE applica
ii libc6 2.3.6-3 GNU C Library: Shared libraries an
ii libgcc1 1:4.0.3-1 GCC support library
ii libstdc++6 4.0.3-1 The GNU Standard C++ Library v3
ii perl-suid 5.8.8-3 Runs setuid Perl scripts

kdenetwork-filesharing recommends no packages.

-- no debconf information

Barry deFreese (bddebian) wrote :

What version of Ubuntu is this for? Even Breezy had 3.4.3?? Thank you.

Changed in kdebase:
status: Unconfirmed → Needs Info

Excactly the seame problem in KDE 3.5.1 and 3.5.2 (SUSE 10.1). Users are not added to /etc/samba/smbpasswd file and I have to use the smbpasswd command.

I don't know if it's the same problem but you cannot modify the "passwd chat" field in advanced security options.

i hope this will be corrected soon because there is a long time this bug is present...

Richard Johnson (nixternal) wrote :

Is this bug still present in the latest Dapper packages?

If it is not, or if someone knows that this bug has been fixed by a subsequent upload, please let us know so we can close this. The last activity on this bug was over 9 months ago.

Thank you for reporting this bug.

Jerky Penguin (jerkypenguin) wrote :

Yep - I see this in Dapper as well.

Marco Cimmino (cimmo) wrote :

still an issue with Edgy, possible that there was no time to fix it? :(

Changed in kdebase:
status: Needs Info → Confirmed

Hi...

I can second this bug and i searched for the problem.

To see what causes this issue i modified the kdenetowrk-3.5.6 sources:
=>kdenetwork/filesharing/advanced/kcm_sambaconf/smbpasswdfile.cpp

  KProcess p;
  p << "smbpasswd" << "-a" << user.name;

  p << password;

  connect( &p, SIGNAL(receivedStdout(KProcess*,char*,int)),
           this, SLOT(smbpasswdStdOutReceived(KProcess*,char*,int)));

  _smbpasswdOutput = "";

...
...
...

I changed "smbpasswd" into "smbdebug" and created a new executable /usr/bin/smbdebug file:

#!/bin/sh
echo "$3" >/tmp/PASSWD
echo "$3" >>/tmp/PASSWD
smbpasswd -a $2 <</tmp/PASSWD

so smbdebug just get the user+pass and call smbpasswd itself. Using this "workaround" will at least create the new user in /etc/samba/private/smbpasswd.

When i enable "PASSWORD DEBUGGING" in the options i get this when starting kcontrol from shell after adding a new user to Samba:

 kcontrol
 filesharing: loading /etc/samba/smb.conf
 filesharing: SambaFile::load: path=/etc/samba/smb.conf
 filesharing: Samba version = 3
 Load smb config files from /dev/null
 Loaded services file OK.
 Server role: ROLE_STANDALONE
 filesharing: setOn : 2
 filesharing: setOn : 3
 filesharing: setOn : 2
 filesharing: setOn : 3
 filesharing: setOn : 2
 filesharing: setOn : 3
 filesharing: When run by root:
 smbpasswd [options] [username]
 otherwise:
 smbpasswd [options]

 options:
 -L local mode (must be first option)
 -h print this usage message
 -s use stdin for password prompt
 -c smb.conf file Use the given path to the smb.conf file
 -D LEVEL debug level
 -r MACHINE remote machine
 -U USER remote username

 extra options when run by root or in local mode:
 -a add user
 -d disable user
 -e enable user
 -i interdomain trust account
 -m machine trust account
 -n set no password
 -W use stdin ldap admin password
 -w PASSWORD ldap admin password
 -x delete user
 -R ORDER name resolve order

 filesharing:
 filesharing: setOn : 2
 filesharing: setOn : 3

Looks like the smbpasswd command does not work properly when called from kcontrol but it seem to work nice when called from my temp script.

Markus

P.S.

Sorry... i posted the wrong smbdebug script:

#!/bin/sh
echo "$0" >/root/LOGFILE
echo "$1" >>/root/LOGFILE
echo "$2" >>/root/LOGFILE
echo "$3" >>/root/LOGFILE
echo "$4" >>/root/LOGFILE
echo "$5" >>/root/LOGFILE
echo "$3" >/root/PASSWD
echo "$4" >>/root/PASSWD
smbpasswd -a $2 <</root/PASSWD

Sorry for that. But here is the output from kcontrol after using this script:

kcontrol
filesharing: loading /etc/samba/smb.conf
filesharing: SambaFile::load: path=/etc/samba/smb.conf
filesharing: Samba version = 3
Load smb config files from /dev/null
Loaded services file OK.
Server role: ROLE_STANDALONE
filesharing: setOn : 2
filesharing: setOn : 3
filesharing: setOn : 2
filesharing: setOn : 3
filesharing: setOn : 2
filesharing: setOn : 3
New SMB password:
Retype new SMB password:
filesharing: Added user slacker.
filesharing:
filesharing: setOn : 2
filesharing: setOn : 3

Markus

I just see that "Platform" of this bug is set to "SuSE RPMs"... i compiled KDE 3.5.6 from source on Slackware 11.0/Samba 3.0.23c. Just in case that this could be helpful to solve that issue.

Markus

Changed in kdebase:
status: Unknown → Unconfirmed

Bug present also under kununtu 6.10 Edgy with KDE 3.5.6, any chance to have fixed for the last kde 3.5.7?

*** This bug has been confirmed by popular vote. ***

Changed in kdebase:
status: Unconfirmed → Confirmed

Hi,

I ran into this bug bug recently and found a reference on
https://bugs.launchpad.net/debian/+source/kdebase/+bug/16575/+activity and
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=293960 but nothing more.

I actually think it's a pretty important bug for anyone trying to use Samba
securely in a mixed OS environment.

Strange that such an important bug affecting a mixed OS environment has not
been seemingly generated so little interest or been reported more.

My solution was to use the pdbedit command in a root terminal to add/edit
users, but very few ordinary punters are going to figure that one out.

Thank you for your attention.

Andrew

This is still an issue in Feisty. Same behavior

Borahshadow (codyregister) wrote :

I too have this problem in Edgy I can add users with the smbpasswd command but they never show up in the GUI and any users added in the GUI never work or are never actually added

I have the same problem as well. This may also be related to an issue where clicking to add users to a share brings up a list of blank users. Only through the advanced button can users be added.

I can't believe this isn't a problem or a priority for anyone other than us, considering it's been around since 2005!

Kieran Hogg (xerosis) wrote :

Still present in gutsy.

The J (me100313) wrote :

I experience this in Kubuntu Feisty (AMD64). Also, I noticed that I cannot click the Apply button after I add a user in this dialog. Go to the Advanced tab and look at the Security options. From there, click on the Password tab. You'll see a box for "SMB passwd file" that points to /etc/samba/smbpasswd, but that file does not exist. I tried creating the file there to see if that would help, but nothing happens. I then tried using smbpasswd from the console to add a user with "smbpasswd -a [user]", but still nothing shows up in that file or in the KControl dialog (though I could be using the command line tool incorrectly).

found 360554 0.5.8.1-9
found 293259 0.57.11.1
found 285270 0.57.11.1
found 293960 4:3.5.5-5
found 302119 0.3.6-2.2
found 303642 0.52.2-10
found 320651 1.6.10-3
found 355667 0.6.0-3
found 375283 2.6.18.dfsg.1-11
found 405715 2.1.2
found 405716 2.1.2
found 405740 2.1.2
found 405743 2.1.2
found 405881 2.1.2
found 339138 0.5.11.1
found 405758 2.1.2
found 293958 4:3.5.5-5

AndrewBC (ajbc) wrote :

Kubuntu Feisty 32 - to my surprise, bug still present.

This is a real showstopper for folks who are uncomfortable on the commandline.

naught101 (naught101) wrote :

Still present in gutsy final. This is annoying.

Maxim Levitsky (maximlevitsky) wrote :

I Confirm this.

This is very old bug, and it is related to the fact that the above panel looks at smbpasswd file
which isn't present anymore on newer samba.

It is possible to make samba use smbpasswd file, but it doesn't worth the hassle since
even then this panel just shows the current users, but still doesn't add them corectly

Just use sudo smbpasswd -a username

Sorry, the bug has been assigned to Alexander Neundorf, but I am the responsible developer. It seems that Alexander has overseen this and did not complain.

*** Bug 137685 has been marked as a duplicate of this bug. ***

Jan Schaefer (janschaefer) wrote :

I am sorry that this bug has not been fixed yet. The bug has been assigned to the wrong developer in the KDE bug database, and I was not informed about it. I am working on it, now.

*** Bug 132557 has been marked as a duplicate of this bug. ***

is there a way to get this fixed for 3.5.9? Is 4 years old :(

No it will not be fixed in 3.5.9, I am sorry. The bug is more difficult to fix then expected.

*** Bug 139623 has been marked as a duplicate of this bug. ***

Changed in kdebase:
status: Confirmed → Triaged
Changed in kdebase:
assignee: jr → nobody
importance: Medium → Low

Created attachment 28068
fixes bug when unable to add samba user, and another bug when unable to add samba user to a user list of a share

This patch fixes two bugs in samba kcontrol module.
The first one: it was impossible to add new samba user.
The second one: it was impossible to add samba users to a list of (for example rejected) users of a share.

murdock (buckyorin) wrote :

Hello!

I am running 3.5.10 and the error still exists. Since version 3.5.10 has been determined to be the final version, does this mean that this bug will not be dealt with anymore in KDE 3 and I should begin implementing KDE4?

Thanks,
Murdock

Jonathan Thomas (echidnaman) wrote :

Yes, it would be recommended that you fix this for KDE4.

I can confirm that this bug is still present in Kubuntu 9.04, Jaunty.

AndrewBC (ajbc) wrote :

Its hard to believe that a bug SO important to smooth networking with other machines STILL has not been fixed and apparently is seen as of little importance.

Of course the more instructed of us can work round it but that isn't the point.

I installed a KDE based distro for someone a few months ago and they later tried to bring it into a network - only after many days of frustrated tinkering did it occur to them that perhaps something was busted and they called me. Their comments when I replied that it was a very old and known bug were unprintable. They plan to rip Linux out and install Windows 7.

"Not a serious environment" was their comment and I have to agree with them.

This bug report was filed almost four years ago. This is a standard use case: add a user to allow sharing files. And still this hasn't been resolved? Balmer must be laughing very hard.

Gurubie (gurubie) wrote :

Hey, WTH? This appears to be first filed in 2005. I also have clients that are turning away from open software because they see this as a serious (basic networking) OS flaw. What am I missing here?

Maxim Levitsky (maximlevitsky) wrote :

Probably wrongly marked this as invalid
Is this module included in KDE4?

Changed in kdenetwork (Ubuntu):
status: Triaged → Invalid
status: Invalid → Incomplete
AndrewBC (ajbc) on 2009-10-10
Changed in kdenetwork (Ubuntu):
status: Incomplete → Confirmed
Sergio Callegari (callegar) wrote :

I confirm that the bug exists in kubuntu karmic.

Changed in kdebase (Debian):
status: New → Confirmed

Thank you for posting this bug.

Does this occur in Lucid?

Changed in kdenetwork (Ubuntu):
status: Confirmed → Incomplete

What's the status of this bug? A patch has been proposed in 2008, since then no reaction.

Stefaan (seven7) wrote :

Yes, I can confirm this bug still happens in Lucid (Kubuntu). And let me echo the sentiment that having such a serious bug open for 5 years makes "Linux is ready for the desktop" a sad, sad joke.

Also, switching a bug's status to "incomplete" because it's not confirmed in the last version, when it's been in the code for 5 full years,
 reeks of wishful thinking or laziness. Sorry for the hears words, but with Maverick Meerkat out, I'd hate to see the next entry be "Does this occur in Maverick?"

Jonathan Riddell (jr) wrote :

This is a known missing feature from upstream. We are working to fix it but unfortunately did not manage in time for maverick.

Changed in kdebase:
importance: Unknown → Medium
Changed in kdenetwork (Ubuntu):
status: Incomplete → Confirmed
AndrewBC (ajbc) wrote :

I'd forgotten all about this!

D'ja mean to stay that this major usability bug, first reported in 2005, is still not fixed?

As someone said, "This is a standard use case: add a user to allow sharing files. "

Note that this isn't an obscure kernel regression - it's just ordinary code looking for the wrong database file.

Depressing.

Hello! Sorry to be the bearer of bad news, but this project has been unmaintained for many years so I am closing this bug. Kcontrol has been replaced by System Settings in Plasma. Please give the latest version of that a try, and open a new bug in "systemsettings" if you continue to have an issue. Thank you!

Changed in kde-baseapps:
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.