[hardy] crash when choosing upload to picasa

Bug #178360 reported by Andreas Wenning on 2007-12-23
24
Affects Status Importance Assigned to Milestone
Gwenview
Unknown
Unknown
kdegraphics (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gwenview

Gwenview crashes when choosing export to picasa (kipi-plugins). I've tried the same from digicam, which doesn't crash, so is most likely a gwenview bug.

kipi-plugins: 0.1.5~beta1-3
gwenview: 1.4.2-2ubuntu2

Thank you for your bug report. The stack trace you provided lacks debugging symbols (it's full of ????), could you please follow http://wiki.ubuntu.com/DebuggingProgramCrash to provide a good stacktrace ? Thank you.

Changed in gwenview:
importance: Undecided → Medium
status: New → Incomplete

No -dbg or -dbgsym packages are avaible for either gwenview or kipi-plugins. Which kind of stacktrace should I provide?

I have attached a strace, which is the best I could generate, but it is rather long.

If you had the following repos :
deb http://ddebs.ubuntu.com hardy main universe
deb http://ddebs.ubuntu.com hardy-updates main universe
deb http://ddebs.ubuntu.com hardy-proposed main universe
deb http://ddebs.ubuntu.com hardy-security main universe

There should be a gwenview-dbgsym and kipi-plugins-dbgsym package. Then you could follow https://wiki.ubuntu.com/Backtrace . Thenk you.

Still no -dpgsym packages. Should a bug be filed about that against the two packages?

andreas@andreas-laptop:~$ tail -n4 /etc/apt/sources.list
deb http://ddebs.ubuntu.com hardy main universe
deb http://ddebs.ubuntu.com hardy-updates main universe
deb http://ddebs.ubuntu.com hardy-proposed main universe
deb http://ddebs.ubuntu.com hardy-security main universe
andreas@andreas-laptop:~$ sudo aptitude search gwenview | cut -f1
i gwenview - image viewer for KDE
p gwenview-i18n - Internationalization (i18n) for Gwenview,
p gwenview-kde4 - image viewer for KDE4
andreas@andreas-laptop:~$ sudo aptitude search kipi-plugins | cut -f1
i kipi-plugins - image manipulation/handling plugins for KI
p kipi-plugins-doc - kipi-plugins documentation

A kipi-plugins-dbgsym package has now appeared. gwenview-dbgsym is still missing, but I hope that the attached trace is better anyway.

It's better but not perfect, I think we should wait for the gwenview-dbgsym package.

-dbgsym packages has arrived. Here is a backtrace with both kipi-plugins-dbgsym and gwenview-dbgsym packages installed.

Thank you, I'm marking this as triaged.

Changed in gwenview:
status: Incomplete → Triaged
Arthur Penn (arthur-penn) wrote :

Would it be the same bug if the crash occurs when importing pictures into Picasa (specifically when clicking to choose the camera as part of the import process)?

From http://groups.google.com/group/Google-Labs-Picasa-for-Linux/browse_thread/thread/873a739464161bfb:

I updated my folks' computer with the 2.7 beta (http://dl.google.com/
linux/deb/pool/non-free/p/picasa/picasa_2.7.3736-15_i386.deb) on
Kubuntu Hardy. When they attempt to import pictures and select the
camera (a Kodak DX7630), the system freezes and they have to reboot to
regain control. Here's what they told me:

> Yes, when I turn on the camera first Picasa does recognize it. I had tried it both ways (it used to work either way) and (now I remember) it did recognize the camera. However, the problem comes when I select the camera - Picasa locks up and will do nothing but beep when I try to do anything. I have to use your "Alt, Print screen, s-u-b" to get out of it.

digiKam doesn't have any problem accessing their camera and importing
pictures. Any ideas? I'm going to revert them to the last stable
version to see if it clears it up. I know it worked under Kubuntu
Gutsy.

Thanks.

Jonathan Thomas (echidnaman) wrote :

Is this still a problem in Kubuntu 9.04? (We should be able to actually test now, since kipi-plugins has been updated for KDE4) :D

Changed in gwenview (Ubuntu):
status: Triaged → Incomplete

Got it to crash in jaunty as well, see bug 349416. Let's hope that the retracing service does it's magic...

Changed in gwenview:
status: Incomplete → Confirmed
Maarten Bezemer (veger) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect 178360 and any other logs that are relevant for this particular issue.

Changed in kdegraphics (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.