KDM cannot display userlist when themes are enabled

Bug #22218 reported by aftertaf on 2005-09-22
10
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
Wishlist
kdebase (Ubuntu)
Medium
Unassigned

Bug Description

I searched around and this is apparently a problem for a few people:

when kdm uses themes, the userlist cannot be displayed, even when selected in login manager
prefs. The only way to get the list to show is to disable themes.
Is this a bug, or is it a problem with the themes that are badly made?

Jonathan Riddell (jr) wrote :

It's a lack of a feature. SuSE has some patches which I'll look at but it's essentially an
upstream issue.

Richard Johnson (nixternal) wrote :

Is this bug still present in the latest Dapper packages?

If it is not, or if someone knows that this bug has been fixed by a subsequent upload, please let us know so we can close this. The last activity on this bug was over 8 months ago.

Thank you for reporting this bug.

barbolani (barbolani) wrote :

I can confirm that the only way of making kdm display the list of users is by changing in /etc/kdm/kdm.conf the UseTheme setting to false. No other way that I've tried works.

Changed in kdebase:
status: Unconfirmed → Confirmed
Changed in kdebase:
status: Unknown → Confirmed
Changed in kdebase:
status: Confirmed → Rejected
Kai Kasurinen (kai-kasurinen) wrote :

Bug 111265 has been marked as a duplicate of 37349

Changed in kdebase:
status: Unknown → Confirmed
Changed in kdebase:
status: Confirmed → Fix Released
Ville Aakko (ville-aakko) wrote :

Maybe bug 27302 is a duplicate?

However, I can confirm I can't change any KDM settings (theme or whatsoever) via control center. If I change UseTheme to false in kdmrc as suggested above, I do get some of the changes I've made (clock, greeting text) but the user list is useless (very small and you can't actually choose a user) and the right part of the greeting window is cut out, because it extends over the screen edge. The latter could be explained by a too long greeting text (though I think KDM should handle that more cleverly, and there should be a separate bug for it). See my comment in bug 27302 also.

Ville Aakko (ville-aakko) wrote :

Maybe bug 87302 is a duplicate?

However, I can confirm I can't change any KDM settings (theme or whatsoever) via control center. If I change UseTheme to false in kdmrc as suggested above, I do get some of the changes I've made (clock, greeting text) but the user list is useless (very small and you can't actually choose a user) and the right part of the greeting window is cut out, because it extends over the screen edge. The latter could be explained by a too long greeting text (though I think KDM should handle that more cleverly, and there should be a separate bug for it). See my comment in bug 87302 also.

Implemented in kde4.

Changed in kdebase:
assignee: jr → nobody
status: Confirmed → Fix Committed

wontfix for kde3.

Changed in kdebase:
status: Fix Committed → Won't Fix
Changed in kdebase:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.