Comment 6 for bug 278471

Same here, using Intrepid for weeks and updating daily. Didn't update during the weekend and today's (monday's) update triggered the annoying flickering behavior. These are the packages that were updated today:

update-motd; landscape-common; landscape-client; libgomp1; gcc-4.3-base; libstdc++6; cpp-4.3; gcc-4.3; g++-4.3; libstdc++6-4.3-dev; libgcc1; binutils; python2.5; python2.5-minimal; libqt4-opengl-dev; libqt4-dev; libqt4-xmlpatterns; qt4-qtconfig; libqt4-qt3support; libqt4-gui; libqt4-designer; libqt4-core; libqt4-script; libqt4-dbus; libqt4-test; libqt4-webkit; libqt4-assistant; libqt4-help; libqt4-network; libqt4-sql-mysql; libqt4-sql; libqt4-svg; libqt4-opengl; libqtgui4; libqt4-xml; libqtcore4; kdelibs5-dev; kdelibs-bin; kdelibs5-data; kdelibs5; adept; binutils-static; libck-connector0; consolekit; gwenview; kamera; libkdecorations4; libkwineffects1; kde-window-manager; kdebase-workspace-bin; libplasma2; kdebase-workspace-data; kdebase-workspace-libs4+5; kdm; kgamma; kgrubeditor; klipper; kruler; ksnapshot; ksysguardd; ksysguard; libavutil49; libavcodec51; libpam-ck-connector; libpostproc51; linux-libc-dev; linux-restricted-modules-common; linux-source-2.6.27; splix; systemsettings; xserver-xorg-input-evdev; xserver-xorg-video-radeon; xserver-xorg-video-ati; kcolorchooser; kdegraphics-strigi-plugins; kolourpaint4; konqueror-plugin-searchbar; libksane0; libokularcore1; mencoder; mplayer; okular; skype; skype-common; linux-image-2.6.27-5-generic; linux-restricted-modules-2.6.27-5-generic; alsa-oss; linux-generic; linux-image-generic; linux-restricted-modules-generic; linux-headers-2.6.27-5; linux-headers-2.6.27-5-generic; linux-headers-generic; libkipi5; libkipi-common

I don't think it's the new kernel's fault because I booted with the old kernel and the problem continues. This is my video card (from lspci):

00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)