unable to save user-places.xbel

Bug #627815 reported by Scott Kitterman
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Invalid
Undecided
Unassigned
kde4libs (Ubuntu)
Fix Released
High
Jonathan Riddell
Maverick
Fix Released
High
Unassigned
Natty
Fix Released
High
Jonathan Riddell

Bug Description

I'm getting an error from kded both in the live session and after install: "Unable to save bookmarks in /home/{USERNAME}/.local/share//user-places.xbel. Reported errror was: Insufficient permissions in target directory.. This error message will only be shown once. The cause of the error needs to be fixed as quickly as possible which is most likely a full hard drive.

Hard drive is not full and permissions look OK.

tags: added: iso-testing
description: updated
Revision history for this message
Scott Kitterman (kitterman) wrote :

This is generated by kfile it looks like.

affects: Ubuntu Maverick → kde4libs (Ubuntu Maverick)
tags: added: kubuntu
Revision history for this message
Scott Kitterman (kitterman) wrote :

I've only seen this on plasma-netbook, never on plasma-desktop. With plasma-netbook it is very common (viritually every install).

I have observed that plasma-netbook tends to start later in the KDE startup sequence than plasma-desktop. My theory is that this error is due to a timing issue where ~./local/share doesn't exist yet.

Revision history for this message
Scott Kitterman (kitterman) wrote :

Marking it confirmed due to seeing it with multiple ISOs on multiple machines. Marking it high since user experience during first run is very important and the warning is very scary sounding.

Changed in kde4libs (Ubuntu Maverick):
importance: Undecided → High
status: New → Confirmed
summary: - unable to save userplaces.xbel
+ unable to save user-places.xbel
Revision history for this message
Scott Kitterman (kitterman) wrote :

The process appears to start in kfile/kfileplacessharedbookmarks.cpp, The error is raised from kio/bookmarks/kbookmarkmanager.cc and the exact error type comes from kdecore/io/ksavefill.cpp.

Revision history for this message
Scott Kitterman (kitterman) wrote :

Dropping the milestone since even though I can reproduce this on multiple machines, no one else seems to be able to.

Revision history for this message
Alvin (alvind) wrote :

Yes, I can. Normal installation of the daily (15 sept) build maverick-desktop-amd64.iso

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 627815] Re: unable to save user-places.xbel

Good to know it's not just me. Was this using a CD or USB device?

Revision history for this message
Alvin (alvind) wrote :

Both actually. I installed from USB, then reinstalled from cd. On both occasions, the message was visible at first login.

Revision history for this message
Jonathan Riddell (jr) wrote :

Occured on today's desktop live CD running Plasma Desktop

Revision history for this message
Kevin J. Wangler (kevin-envail) wrote :

Just did a clean install of Kubuntu 10.10 beta from a USB stick and got this error on first login. (This is plasma-desktop, too, not netbook.) So the message is extraneous and can safely be ignored?

Revision history for this message
Scott Kitterman (kitterman) wrote :

As far as we know, it's harmless.

Revision history for this message
Jonathan Riddell (jr) wrote :

Slippery one this. Can't recreate on today's live CD.

Revision history for this message
José Lou Chang (obake) wrote :

I got this error on Kubuntu 10.10 RC upon login for the first time after a fresh install.

I am using a HP Pavilion dv6000 Laptop.

Revision history for this message
Alessandro Ghersi (alessandro-ghersi) wrote :

I don't have this problem running the live cd

Revision history for this message
Scott Kitterman (kitterman) wrote :

It doesn't happen every time. It's not clear why.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde4libs - 4:4.5.1-0ubuntu7

---------------
kde4libs (4:4.5.1-0ubuntu7) maverick; urgency=low

  * Add kubuntu_77_no_kbookmark_write_error.diff, nasty workaround for
    random error message on first login LP: #627815
 -- Jonathan Riddell <email address hidden> Mon, 04 Oct 2010 11:48:16 +0100

Changed in kde4libs (Ubuntu Maverick):
status: Confirmed → Fix Released
Changed in ubuntu-release-notes:
status: New → In Progress
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

This is already fixed. Why does it need mention in the release notes?

Revision history for this message
Scott Kitterman (kitterman) wrote :

It doesn't.

Changed in ubuntu-release-notes:
status: In Progress → Invalid
Revision history for this message
Scott Kitterman (kitterman) wrote :

Bug has re-appeared in Natty. Perhaps the patch got dropped?

Changed in kde4libs (Ubuntu):
milestone: ubuntu-10.10 → natty-alpha-3
status: Fix Released → New
Revision history for this message
Jonathan Riddell (jr) wrote :

SUSE planning to use a similar workaround https://build.opensuse.org/stage/request/show/62475

Martin Pitt (pitti)
Changed in kde4libs (Ubuntu Natty):
assignee: nobody → Jonathan Riddell (jr)
milestone: natty-alpha-3 → ubuntu-11.04-beta-1
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde4libs - 4:4.6.1-0ubuntu1

---------------
kde4libs (4:4.6.1-0ubuntu1) natty; urgency=low

  [ Michał Zając ]
  * New upstream release
  * Refreshed kubuntu_06_user_disk_mounting.diff
  * Refreshed kubuntu_77_ksambashare.diff
  * Refreshed *.install files

  [ Jonathan Riddell ]
  * Add back kubuntu_77_no_kbookmark_write_error.diff workaround for LP:
    #627815
 -- Michal Zajac <email address hidden> Sun, 27 Feb 2011 14:10:59 +0100

Changed in kde4libs (Ubuntu Natty):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers