Removing and readding the system tray in KDE doubles its size each time

Bug #944695 reported by Julius Schwartzenberg on 2012-03-02
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KDE Base Workspace
Unknown
Medium
kde-workspace (Ubuntu)
Undecided
Unassigned

Bug Description

When you remove and then readd the systemtray in KDE4. Its size is double every time. This problem is described here:
https://bugs.kde.org/show_bug.cgi?id=293472

The people in #plasma cannot reproduce it on KDE 4.8, so they wonder if Ubuntu maybe patched the system tray.

The expected result is that the systemtray stays the same size. The extra space it takes up is just empty. There appears to be a bug in a Ubuntu patch which keeps doubling a certain value.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: plasma-desktop 4:4.8.0b-0ubuntu5
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
Date: Fri Mar 2 11:29:18 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120204)
ProcEnviron:
 LANGUAGE=nl_NL
 TERM=xterm
 PATH=(custom, user)
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
SourcePackage: kde-workspace
UpgradeStatus: No upgrade log present (probably fresh install)

Created attachment 68573
Screenshot of panel after bug appeared.

Version: unspecified (using KDE 4.8.0)
OS: Linux

Removing the system tray and re-adding it to the panel makes it take up a lot more space.

Reproducible: Always

Steps to Reproduce:
1. Delete system tray from panel
2. Add system tray to panel

Actual Results:
System tray taking over twice the size it needs.

Expected Results:
System tray taking up its normal size.

Screenshot in attachment.

System is Kubuntu 11.10 with the KDE 4.8 PPA.

Created attachment 68574
Bug's manifestation in two rows system tray

Created attachment 68575
Bug in two rows

I can confirm this bug on Kubuntu 11.10 with the KDE 4.8 PPA. It seems to be also triggered when (for some reasons) plasma recovers from a crash, the system tray widgets gets twice the size from the way it was before the crash

Tim (tim-walsh) wrote :

Had the same problem and noticed when I looked at the system tray settings under "entries" there were lots of 'phantom'
entries which stops you resizing it down to the real size.

I finally found the answer here:
http://forum.kde.org/viewtopic.php?f=67&t=99419

In summary run the following command...

killall kded4 && kded4 &

It clears out all the entries and allows it to be resized.

A quick search (I could have missed others) it seems this problem has been reported (and marked as RESOLVED) several times in the last years, and in different versions:

https://bugs.kde.org/show_bug.cgi?id=300005 4.8.3
https://bugs.kde.org/show_bug.cgi?id=290982 4.8rc2
https://bugs.kde.org/show_bug.cgi?id=293472 4.8.0
https://bugs.kde.org/show_bug.cgi?id=240347 4.4.8

*** Bug 300005 has been marked as a duplicate of this bug. ***

Confirmed in current 4.9 beta2, it still happens after a plasma crash.

*** Bug 240347 has been marked as a duplicate of this bug. ***

*** Bug 290982 has been marked as a duplicate of this bug. ***

*** Bug 302231 has been marked as a duplicate of this bug. ***

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde-workspace (Ubuntu):
status: New → Confirmed

I have this issue with KDE 4.7.2.

Nasty workaround to remove these ghost entries from the system tray: Restarting the kded4 daemon -> killall kded4 && sleep 2 && kded4 &0

Still happening on 4.9.1. Here's a snapshot: http://imageshack.us/a/img692/9751/kdetraybug.jpg

Created attachment 74238
Snapshot

I have the same problem since upgrading to KDE 4.8. Also occurs in KDE 4.9.

I can confirm this (KUbuntu 12.10, KDE 4.9.2). The systemtray gets flooded with statusnotifieritems.

Workaround: System Tray Settings -> Entries and set them to "hidden".

Hi, also have the bug, because each 3-5 days I must restart plasma-desktop that consumes too much misc pixmaps.
The workaround is fine, but very annoying when you have dozens of icons nto deactivate ...

Is there a "shell" way to put icons from auto to hidden ?

And last, is there a way to define the default show policy for systray icons ? (using a regexp, or not) maybe a global policy ?

Thanks in advance.

PS: bug since Kubuntu 12.04

> The workaround is fine, but very annoying when you have dozens of icons nto
> deactivate ...
>
> Is there a "shell" way to put icons from auto to hidden ?
>
> And last, is there a way to define the default show policy for systray icons
> ? (using a regexp, or not) maybe a global policy ?

Don't do it manually. When the KDE4 daemon is restarted, the ghost entries disappear. The best workaround to create a script with the following content:

killall kded4 && sleep 2 && kded4 &0

And add a global shortcut (e.g Windows key+F3) in KDE to launch this script.

is that a trailing 0? Shouldn't it be:
killall kded4 && sleep 2 && kded4 &

(In reply to comment #18)
> is that a trailing 0? Shouldn't it be:
> killall kded4 && sleep 2 && kded4 &

No, it is meant to end with &0

Harald Sitter (apachelogger) wrote :

Hi there!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our packages. But don't worry! This issue is being tracked by the KDE developers at: https://bugs.kde.org/show_bug.cgi?id=293472. Once fixed in KDE's software, it will be included in Kubuntu once the KDE SC version the fix is in in reaches Kubuntu.

Thanks!

Changed in kde-workspace (Ubuntu):
status: Confirmed → Invalid
Changed in kde-workspace (Ubuntu):
status: Invalid → Confirmed

I suppose it was partially a bot above me. Even looking at the KDE bug for a single second shows that this problem is actually specific to the Ubuntu packages (and probably should belong stay here and closed there) and that the KDE developers are not looking for a fix.

There are quite a few Ubuntu-specific patches in Ubuntu's KDE 4 packages. We need to figure out which one causes this behavior.

Changed in kdebase-workspace:
importance: Unknown → Medium
status: Unknown → Confirmed

I don't think it is meant to end in just plain &0 because bash parses that as a command. Has the command been bitten by a missing angle bracket perhaps ?

[/testing: leveret@george ~]$ killall kded4 && sleep 2 && kded4 &0
[2] 30401
bash: 0: command not found
[/testing: leveret@george ~]$

Experiment and logic suggest that "greaterthan ampersand zero" may be what was originally typed before BZ mangling. Thankyou for this workaround.

Changed in kdebase-workspace:
status: Confirmed → Unknown

My Bash isn't strong enough to really understand what >&0 (greaterthan ampersand zero) means here. Doesn't this mean to redirect standard output to the same place handle 0 (i.e. stdin) goes? But in this case stdin is just the terminal? So it this case it would do nothing?

Hello!

This bug report was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this bug is already resolved in Plasma 5.

Accordingly, we hope you understand why we must close this bug report. If the issue described here is still present in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.