Cannot change widget style via kdesudo systemsetting

Bug #619519 reported by dw40 on 2010-08-17
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
KDE Base Workspace
Invalid
Medium
kde-workspace (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: systemsettings

Package name and version: systemsettings 4:4.5.0b-0ubuntu1~lucid1~ppa2

Affected are Lucid with Kde 4.5.0b from Kubuntu backport repositories as well as current Maverick Alpha 3 with Kde 4.5.0b.

What is expected to happen: When changing widget style (from Oxygen to Qtcurve, for example) in root's systemsettings via command "kdesudo systemsettings", style for kde applications run as root using kdesudo (e.g. kdesudo Dolphin) should use the style selected in root's systemsettings.

What happened instead: No matter what style is chosen in kdesudo systemsettings, widget style remains stuck at Oxygen. Preview of other styles looks fine, but they are never applied when clicking on "Apply".

For non-kdesudo applications everything works as expected. I've started a thread about this bug at kubuntu.org forum.

http://kubuntuforums.net/forums/index.php?topic=3113223.0

Felix Geyer (debfx) wrote :

Neither muon nor kpackagekit is run as root, so the widget style you select as root won't affect them.

Changed in kdebase-workspace (Ubuntu):
status: New → Invalid
Heimen Stoffels (vistaus) wrote :

It doesn't only apply to KPackageKit and Muon. It also applies to other root applications, for example Adept, kdesudo dolphin, kdesudo systemsettings, KDE Partition Manager and many more root apps.
So this bug is not invalid.

Changed in kdebase-workspace (Ubuntu):
status: Invalid → Confirmed
Yuri sss (yukihiro-ayaka) wrote :

I can confirm this. Affected are Lucid with Kde 4.5.0b from Kubuntu backport repositories as well as current Maverick Alpha 3 with Kde 4.5.0b.
For *all* Kde applications running as root using kdesudo (systemsettings, Dolphin, whatever else) it's the same: they always have only the Oxygen style, as you cannot set a different style for Kde apps running as root in kdesudo systemsettings - the preview of other styles works fine, but when you press "Apply", *nothing* happens - the style is never applied, it's always stuck at the Oxygen style.

description: updated
Heimen Stoffels (vistaus) wrote :

The duplicate status is wrong. Bug 600646 is about Ubiquity and NOT about windows running under kdesudo. And the mentioned package in the other bug thread doesn't fix the issue, so this clearly is a different bug.

Yuri sss (yukihiro-ayaka) wrote :

I can confirm this. The fix for 60046 does *nothing* to fix this bug, therefore it has to be considered a separate bug and *not* a duplicate.

Fenix-TX (jesusvpct) wrote :

A workaround to this bug:
- Install qt4-qtconfig
- Execute kdesudo qtconfig
- Select the style that you want (don't use Desktop Settings!!!, because is not working)
- Save your configuration

Now all kde apps opened with kdesudo have the style selected.

affects: kdebase-workspace (Ubuntu) → kde-workspace (Ubuntu)
Changed in kde-workspace (Ubuntu):
importance: Undecided → Wishlist
Maarten Bezemer (veger) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. There have been many changes in Kubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Kubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect 619519 and any other logs that are relevant for this particular issue.

Changed in kde-workspace (Ubuntu):
status: Confirmed → Incomplete

I'm can still reproduce the problem with Kubuntu 11.10 and KDE 4.8.0. When I used apport-collect, it said, "You are not the reporter of this problem report. It is much easier to mark a bug as a duplicate of another than to move your comments and attachments to a new bug." So, please let me know if you want me to add my logs to this report.

Maarten Bezemer (veger) wrote :

I think it would be good to attach your logs, especially the version you are using (and versions of depending packages).
So it is/becomes clear with what current versions the problem still exists. This was the intent of my question whether the issue is still present, as the last update was over a year ago...

At some point the KDE developers must be made aware of the problem, and we need at least the version information for it. If you are able to update the description with (up-to-date) steps to trigger/expose the issue it would be great as well. (to do so, click the icon right of 'Bug Description' on top of this page, or open this link: https://bugs.launchpad.net/ubuntu/+source/kde-workspace/+bug/619519/+edit )

Thanks a lot for your help!

Changed in kde-workspace (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → Incomplete

ApportVersion: 1.23-0ubuntu4
Architecture: amd64
DistroRelease: Ubuntu 11.10
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
NonfreeKernelModules: nvidia
Package: kde-workspace 4:4.8.0b-0ubuntu1~oneiric1~ppa3
PackageArchitecture: all
ProcVersionSignature: Ubuntu 3.1.0-1.1-generic 3.1.0-rc10
Tags: oneiric
Uname: Linux 3.1.0-1-generic x86_64
UnreportableReason: This is not a genuine Ubuntu package
UpgradeStatus: Upgraded to oneiric on 2011-10-16 (128 days ago)
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare vboxusers

tags: added: apport-collected oneiric

apport information

apport information

I didn't change the bug description at all, because the behavior is still exactly the same.

Maarten Bezemer (veger) wrote :

Thank you for taking the time to provide the extra information. This issue is an upstream one and it would be nice if you or somebody else having this issue, could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/KDE. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in kde-workspace (Ubuntu):
status: Incomplete → Confirmed
Artur Jewuła (arturro2) wrote :

I've also experienced this bug on my newly installed Kubuntu 11.10 64bit. With kdesudo systemsettings I can modify all settings (icons, colors, etc.) but not qtstyle. I can confirm that workaround from #6 comment (use of qtconfig) affects qt style in application run as root.

What is expected to happen: When changing widget style (from Oxygen to Qtcurve, for example) in root's systemsettings via command "kdesudo systemsettings", style for kde applications run as root using kdesudo (e.g. kdesudo Dolphin) should use the style selected in root's systemsettings.

What happened instead: No matter what style is chosen in kdesudo systemsettings, widget style remains stuck at Oxygen. Preview of other styles looks fine, but they are never applied when clicking on "Apply".

For non-kdesudo applications everything works as expected. I've started a thread about this bug at kubuntu.org forum.

This bug report originates from https://bugs.launchpad.net/ubuntu/+source/kde-workspace/+bug/619519 The comments on the LP report indicate that this is still a problem with KDE 4.8.0b

ALso a workaroun is mentioned in another comment:
 - Install qt4-qtconfig
 - Execute kdesudo qtconfig
 - Select the style that you want (don't use Desktop Settings!!!, because is not working)
 - Save your configuration

Now all kde apps opened with kdesudo have the style selected.

Maarten Bezemer (veger) wrote :

I notified the KDE developers with a summary of the information given in de description and the comments.

summary: - Cannot change widget style via kdesudo systemsetting under kde 4.5
+ Cannot change widget style via kdesudo systemsetting
Changed in kdebase-workspace:
importance: Unknown → Medium
status: Unknown → New

Similar to 194449, same resolution.

There is no need to run things as root, if there is a reason we've missed, please tell us.

*** This bug has been marked as a duplicate of bug 194449 ***

Changed in kdebase-workspace:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.