Can't log in with one user, other user log in fine - "Could not start ksmserver, check your installation"

Bug #1373792 reported by C K on 2014-09-25
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
kde-workspace (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,
I've upgraded some packages 2 days ago, mainly dbus related I think, and suddenly I cannot log into my KDE desktop anymore.
When logging in I can see the message "Could not start d-bus. Can you call qdbus?".
So after Googling I found the Solution to that bug "https://bugs.launchpad.net/ubuntu/+source/kde-workspace/+bug/1304805"

I did what comment #12 says: qdbus=QT_SELECT=qt4 qdbus

However I still cannot log in, now I get the following error for my user , also an XWindow :

"Could not start ksmserver, check your installation"

On my system I have two users, my main one: CkDev, and another one corck. When I log in as ckDev I get the following errors above, however when I log in with my user "corck" everything works fine. I've even created a new user "guest" and logged in with it and it works fine as well.

So next step I took, I removed ~/.kde and ~/.config and tried to log in, same error.

On another thread I read about killing "lightdm" and logging in using startx, so I switched to terminal mode, and stopped lightdm and executed "startx". Then my user ckDev is logging in straight away and I have my Desktop again, with some bugs like my webcam is not working anymore.

So I don't really know whats happening, but after I can log in with "corck" and "guest" I feels like these users are not using /usr/bin/startkde but another script, otherwise the Bug #1304805 should have affected them as well.

I'm on Kubuntu Trusty.

C K (chri-klocker) wrote :

I saw some threads on the issue "Could not start ksmserver, check your installation" that are talking about Nvidia Prime so I disabled Optimus and tried to use Intel graphics only, but that did not help either.

C K (chri-klocker) wrote :

Ok, I finally figured it out myself.

For others to replicate I describe how I did it.
As I new that I could log into KDE with other user accounts I first moved all hidden files ~/. to a new directory. Then I tried to log in and it worked. Next I started to move those files and folders back to my home directory ~/.
Then I figured out that .profile was causing it, better said I checked into what was causing it. I saw that the inclusion of my ~/bin directory was the root of the problem. In that directory I have a lot of executables, I think most or all of them were copied by RVM (Ruby Version Manager). Then I furthermore drilled untill I finally found the causing file(s).

I had 3 dbus executables in there, that were probably outdated and conflicted with newer libraries but were called by the /usr/bin/startkde script.

The files were:

dbus-cleanup-sockets
dbus-deamon
dbus-uuidgen

The dbus-deamon was the one to remove to be able to log in again.

I have no idea when, how and why these files where copied into the ~/bin folder.

Hope this will help others that experience the same.

C K (chri-klocker) on 2014-10-16
Changed in kde-workspace (Ubuntu):
status: New → Invalid
Tommy_CZ (t-kijas) wrote :

Hi, I have optimus, KDE4 and Ubuntu 14.04.
I have no folder bin in my home folder and it still says Could not start ksmserver. Check your installation.

It is clearly connected to optimus technology, especially NVIDIA drivers with primus.

Please reopen the bug.

Changed in kde-workspace (Ubuntu):
status: Invalid → Confirmed
aanno (thomas-pasch) wrote :

I suddenly have this problem as well, but neither ~/bin nor some optimus stuff is the culprit.

Ubuntu 14.04/utopic, Kde Plasma 5.2, amd64

aanno (thomas-pasch) wrote :

Added a brand-new user. Same problem, i.e. it happens for ALL users.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers