systemsettings doesn't scale down on lower resolutions

Bug #22846 reported by Philip Cain on 2005-09-29
46
Affects Status Importance Assigned to Milestone
kde-systemsettings (Ubuntu)
High
Jonathan Riddell

Bug Description

This was on Breezy build 20050927, fresh installation.

The System Settings application doesn't scale down on resolutions lower than
1024x768. For example, at 800x600, if you click Appearance and attempt to change
any setting within that section, the Administrator Mode, Reset, and Apply
buttons are below the screen (well below kicker). The window cannot be sized any
smaller.

This isn't good for accessibility; not every screen out there has been upgraded
to 1024x768 or higher. The Control Center used to have scrollbars in the content
arear for dealing with this. Perhaps they can be implemented?

Philip Cain (philipacamaniac) wrote :

Created an attachment (id=4216)
Screenshot

Appearance Module within System Settings. 800x600 resolution. Kicker is hidden
to the right.

Philip Cain (philipacamaniac) wrote :

Fresh installation of Breezy, all packages updated, and the problem still
exists. And, it is even more severe than previously thought. It affects all
resolutions simply because the System Settings application doesn't have a
vertical scrollbar.

How to recreate the problem at 1024x768 resolution:
1. Go the Printer Settings within System Settings app.
2. Add at least 3 printers to the list.
3. Can you hit Apply now? No!

You can recreate the problem at higher resolutions by going into the same
Printer Settings view and adding a lot of printers. This is just one example of
the necessity of scrollbars within System Settings.

Jonathan Riddell (jr) wrote :

It's a problem for kcontrol modules generally. Use alt+click and drag for now.

Jonathan Jesse (jjesse) wrote :

If you do need to make changes to the appearance you can close System Settings and it will tell you there
are unsaved items and if you would like to make the changes. If you do click yes, the changes you made
will be applied.
Not a very nice way to work around it.

Bastian Holst (bastianholst) wrote :

(In reply to comment #3)
> It's a problem for kcontrol modules generally. Use alt+click and drag for now.
>

That's right, but a ScrollView (like in KControl) would get it work. Another
thing that would improve the size managing of Systemsettings would be making the
KControl-modules smaller. They are often bigger than needed.

Matt Zimmerman (mdz) wrote :

*** Bug 24126 has been marked as a duplicate of this bug. ***

I faced the same issue on Kubuntu Dapper Flight 3 + Updates on 01/26/06.

Changed in kde-systemsettings:
status: Unconfirmed → Confirmed
Kenny Duffus (kduffus) wrote :

this is fixed in dapper

Changed in kde-systemsettings:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.