k3b fails to burn larger dvd images (about 4gb) when using wodim

Bug #481536 reported by menschmeier on 2009-11-12
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
k3b (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: k3b

k3b fails to burn a larger DVD image (about 4 GB). Burning a 600 MB image to a DVD was successful.

The difference is the usage of wodim. Burning the smaller image does not use wodim.

I used the same rewritable medium for both cases.

Here is the output when k3b fails the 4 GB iso image:
Devices
-----------------------
TSSTcorp CD/DVDW SN-S082D SS02 (/dev/sr0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Layer Jump] [%7]

System
-----------------------
Ubuntu: 9.10
K3b Version: 1.68.0
KDE Version: 4.3.2 (KDE 4.3.2)
QT Version: 4.5.2
Kernel: 2.6.31-14-generic

Used versions
-----------------------
cdrecord: 1.1.9

cdrecord
-----------------------
/usr/bin/wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits.
scsidev: '/dev/sr0'
devname: '/dev/sr0'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Wodim version: 1.1.9
SCSI buffer size: 64512
Beginning DMA speed test. Set CDR_NODMATEST environment variable if device
communication breaks or freezes immediately after that.
TOC Type: 1 = CD-ROM
Driveropts: 'burnfree'
Device type : Removable CD-ROM
Version : 5
Response Format: 2
Capabilities :
Vendor_info : 'TSSTcorp'
Identification : 'CD/DVDW SN-S082D'
Revision : 'SS02'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x0013 (DVD-RW restricted overwrite)
Profile: 0x0015 (DVD-R/DL sequential recording)
Profile: 0x0016 (DVD-R/DL layer jump recording)
Profile: 0x002B (DVD+R/DL)
Profile: 0x001B (DVD+R)
Profile: 0x001A (DVD+RW)
Profile: 0x0014 (DVD-RW sequential recording)
Profile: 0x0013 (DVD-RW restricted overwrite) (current)
Profile: 0x0012 (DVD-RAM)
Profile: 0x0011 (DVD-R sequential recording)
Profile: 0x0010 (DVD-ROM)
Profile: 0x000A (CD-RW)
Profile: 0x0009 (CD-R)
Profile: 0x0008 (CD-ROM)
Profile: 0x0002 (Removable disk)
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Driver flags : SWABAUDIO BURNFREE
Supported modes: PACKET SAO
Drive buf size : 1048576 = 1024 KB
FIFO size : 134217728 = 131072 KB
/usr/bin/wodim: WARNING: Could not manage to find medium size, and more than 90 mins of data.
Speed set to 2770 KB/s
Track 01: data 4470 MB
Total size: 5133 MB (508:37.96) = 2288847 sectors
Lout start: 5134 MB (508:39/72) = 2288847 sectors
Current Secsize: 2048
HINT: use dvd+rw-mediainfo from dvd+rw-tools for information extraction.
Starting to write CD/DVD at speed 2.0 in real SAO mode for single session.
Last chance to quit, starting real write in 2 seconds.
   1 seconds.
   0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... Errno: 5 (Input/output error), reserve track scsi sendcmd: no error
CDB: 53 00 00 00 00 00 22 EC CF 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 72 05 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x72 Qual 0x05 (no more track reservations allowed) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.001s timeout 200s
/usr/bin/wodim: Cannot open new session.
input buffer ready.
Writing time: 0.045s
/usr/bin/wodim: fifo had 2047 puts and 0 gets.
/usr/bin/wodim: fifo was 0 times empty and 0 times full, min fill was 100%.

cdrecord command:
-----------------------
/usr/bin/wodim -v gracetime=2 dev=/dev/sr0 speed=2 -sao driveropts=burnfree fs=128m -data -tsize=2288847s -

ProblemType: Bug
Architecture: amd64
Date: Thu Nov 12 21:22:29 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/k3b
InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: k3b 1.68.0~alpha3-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: k3b
Uname: Linux 2.6.31-14-generic x86_64
XsessionErrors: (polkit-gnome-authentication-agent-1:2140): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

menschmeier (baeckham) wrote :
Schily (schilling-fokus) wrote :

You are not using cdrecord but wodim. You thus cannot expect that
writing to DVDs works at all.

wodim is a fork made from a more than 4 year old cdrecord version
by adding plenty of bugs and by replacing the mature DVD support
from the original cdrecord by something half baken. Note that if
you use wodim instead of cdrecord you most likely also have a
buggy variant from mkisofs called "genisoimage" that creates
defective filesystems and in addition does not support files
> 4 GB and UTF-8 coded character sets.

I recommend to install revent original software, it has no known
bugs

ftp://ftp.berlios.de/pub/cdrecord/alpha/

http://cdrecord.berlios.de/

In your specific case, you also first need to call "cdrecord blank=all"
as the disk was written in a mode that is not compatible with SAO
recording.

Rohan Garg (rohangarg) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner.
There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test the current Ubuntu development version (10.10). If you can test it, and it is still an issue, we would appreciate if you could upload updated logs by running apport-collect <bug #>, and any other logs that are relevant for this particular issue.

Changed in k3b (Ubuntu):
status: New → Incomplete
Harald Sitter (apachelogger) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as requested in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the "Status" column, and change the status back to "New". Thanks again!

Changed in k3b (Ubuntu):
status: Incomplete → Invalid
Joe User (axyz-yahoo) wrote :

Please re-open this problem report.

This problem still exists with a brand new installation of kubuntu 10.10.

I cannot burn dual-layer DVD's if the data to be burned requires the second DVD layer.

I can build the cdrtools-3.00 as suggested by Schilly, and burn the DVD's just fine with the same data and hardware.

This prolem has existed for a long time. Let's fix this by replacing wodim with the latest and greatest cdrecord.

piccobello (piccobello) wrote :

I have exactly the same problem.
I'm using Kubuntu Natty, and there still is no repo of the cdburning group.
As soon as it's there I will check if the problem persists with cdrecord.
This bug should be reopened.

piccobello (piccobello) wrote :

I can confirm that cdrecord from cdrtools-3.01 has no problem in burning the large image.
Unfortunately the cdburning group seems to have stopped releasing packages a long time ago..???
I do not want to dive into what seems to be a long lasting dispute among developers and package releasers,
but it would be good to at least reopen this bug..
Can anybody let me know what information is necessary? Thanks a lot

Changed in k3b (Ubuntu):
status: Invalid → Confirmed
Heitor Moreira (heitormsilva) wrote :

This bug affects me also. I'm using Kubuntu 11.10 and getting the same output in k3b when I try to burn in a DVD-RW medium "/usr/bin/wodim: Cannot open new session.".

I was able to burn the same iso file using the same medium, OS, and drive using the following command: growisofs -dvd-compat -speed=2 -use-the-force-luke=bufsize:32m -Z /dev/dvdrw=/path/to/the/file.iso

Heitor Moreira (heitormsilva) wrote :

To find out why all this trouble is happening, see here (if you haven't yet): http://cdrecord.berlios.de/private/linux-dist.html

doru001 (headset001) wrote :

You find here full instructions about how to move from wodim to cdrtools. No problems after that. http://ubuntuforums.org/showpost.php?p=11833837&postcount=26

You may want to also check http://www.troubleshooters.com/linux/coasterless.htm

Marcin (swistak-mu) wrote :

Same here bug still egzists.

Btw, as a workaround suggestions from @Heitor worked. Thanks a lot man!

workaround_1, not requiring compile form source

https://launchpad.net/~brandonsnider/+archive/cdrtools

cd /usr/bin
sudo rm wodim
sudo rm genisoimage
sudo rm readom

sudo ln -s cdrecord wodim
sudo ln -s mkisofs genisoimage
sudo ln -s readcd readom

workaround_2 via IgnorantGuru https://launchpad.net/~ignorantguru

# Open a terminal window (try CTRL+ALT+T) and enter
# the following commands

# install compiler tools
sudo apt-get install build-essential

# Make sure you're in the home folder
cd ~

# Make a working folder and change to it
mkdir cdrtools
cd cdrtools

# Download latest cdrtools from http://cdrecord.berlios.de/private/linux-dist.html
wget ftp://ftp.berlios.de/pub/cdrecord/alpha/cdrtools-beta.tar.gz

# Unpack
tar xzf cdrtools-beta.tar.gz

# CD to the directory cdrtools is in.
cd cdrtools-2.01.01

# Compile and install
make
sudo make install

# Files are installed to /opt/schily
# (you may want to change their ownership to root:root)
sudo chown root:root /opt/schily/bin/*

# Move the following files (some will be links) from /usr/bin to a junk folder...
sudo mkdir /opt/schily/replacedfiles
sudo mv /usr/bin/cdrecord /opt/schily/replacedfiles
sudo mv /usr/bin/genisoimage /opt/schily/replacedfiles
sudo mv /usr/bin/mkisofs /opt/schily/replacedfiles
sudo mv /usr/bin/readom /opt/schily/replacedfiles
sudo mv /usr/bin/wodim /opt/schily/replacedfiles

# Create links:
sudo ln -s /opt/schily/bin/cdrecord /usr/bin/cdrecord
sudo ln -s /opt/schily/bin/mkisofs /usr/bin/genisoimage
sudo ln -s /opt/schily/bin/mkisofs /usr/bin/mkisofs
sudo ln -s /opt/schily/bin/readcd /usr/bin/readom
sudo ln -s /opt/schily/bin/cdrecord /usr/bin/wodim
sudo ln -s /opt/schily/bin/readcd /usr/bin/readcd
sudo ln -s /opt/schily/bin/mkhybrid /usr/bin/mkhybrid
sudo ln -s /opt/schily/bin/cdda2wav /usr/bin/cdda2wav

# Remove working folder
cd ~
sudo rm -r cdrtools

@schily
https://launchpad.net/~schilling-fokus

Thank you MUCH and MORE! I hope you publish your own PPA unless you are Brandon Snider

@devs

the information you require?

http://troubleshooters.com/linux/coasterless.htm

http://ubuntuforums.org/showthread.php?t=851707
http://ubuntuforums.org/showthread.php?p=5552123

see also: https://bugs.launchpad.net/ubuntu/+source/cdrkit/+bug/149076

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers