[needs-packaging] 1.24.6 is not packaged in wily

Bug #1481556 reported by Curtis Hovey on 2015-08-05
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju-core (Ubuntu)
Undecided
Unassigned

Bug Description

Juju 1.24.6 is currently proposed to be the next stable Juju release. The juju team want this version also proposed for wily. This release supports systemd for local charm development and testing

[SRU Information]

juju-core has a stable release exception in https://wiki.ubuntu.com/StableReleaseUpdates/MicroReleaseExceptions, including for major version updates.

[Devel Fix]

[sinzui] Prepare source package, and diffs: DONE
[rbasak] Review package and upload of new upstream release with packaging review.

[Pre-QA tasks]

[rbasak] Upload to the development release (wily-proposed): DONE

[QA Status]

Since there are multiple verifications required, they are listed here as a work item whiteboard status type thing rather than try and track them in a single tag. Please do not mark verification-done or remove block-proposed until all following items have passed. If any of these items fail, this bug should be marked verification-failed immediately.

[sinzui] Upstream QA test against Wily: DONE
[sinzui] Upstream release process complete: DONE

Manual tests required:

[sinzui] Test juju-quickstart against wily-proposed: DONE
[sinzui] Test juju-deployer against wily-proposed: DONE
[sinzui] Test client and cloud server upgrade from main/updates: DONE
[sinzui] Test client manual bootstrap and add-machine: DONE

Curtis Hovey (sinzui) wrote :

The juju-code source package does *not* pass adt tests at the moment because of a regression in wily. Per bug1480310, we know 1.24.4 did pass the tests, as did 1.24.3, but a change to the systemd package last week broke stable jujus as well as 1.24.4. We blieve systemd-223-1ubuntu1 is at fault...reverting to systemd-222-2ubuntu1 fixes juju 1.23.x and 1.24.x

description: updated

Hi Robie and all interested parties.

I have linked a source package branch to update Juju to 1.24.5 in wily.

The debian diff can be seen at
http://people.canonical.com/~curtis/wily-juju-1.24.5/debian.diff

There are several kinds of changes in the juju-core release files reflected
in debian/copyright that I can summarise:

1. Go packages dropped:
   * src/bitbucket.org/kardianos/osext
   * src/bitbucket.org/kardianos/service
   * src/code.google.com/p/go.crypto
   * src/code.google.com/p/winsvc

2. Go packages added
   [1] note 2 packages had licence issues that I reported upstream during
   development of 1.24.0. This point release has the upstream fixes, we
   avoided the need to document licensing exceptions:
   * src/github.com/ajstarks/svgo
   * src/github.com/altoros/gosigma
   * src/github.com/coreos/go-systemd
   * src/github.com/dustin/go-humanize
   * src/github.com/godbus/dbus
   * src/github.com/juju/govmomi
   * src/github.com/juju/jujusvg
   * src/github.com/juju/persistent-cookiejar
   * src/github.com/juju/replicaset
   * src/golang.org/x/oauth2
   * src/google.golang.org/api
   * src/google.golang.org/cloud
   * src/gopkg.in/errgo.v1 [1]
   * src/gopkg.in/juju/charm.v5
   * src/gopkg.in/juju/charmstore.v4 [1]
   * src/gopkg.in/macaroon-bakery.v0
   * src/gopkg.in/macaroon.v1

3. Projects moved from launchpad.net; inflating the diff:
   * src/launchpad.net/goamz -> src/gopkg.in/amz.v3
   * src/launchpad.net/goose -> src/gopkg.in/goose.v1

4. Forks of upstream golang to fix issues in golang 1.2 system packages:
   * src/github.com/gabriel-samfira/sys
   * src/github.com/juju/govmomi/vim25/xml
   * src/github.com/juju/httpprof
   * src/github.com/juju/xml

5. Fixes for copyright issues in response to the bugs we reported previously:
   * src/github.com/juju/cmd
   * src/github.com/juju/gojsonpointer
   * src/github.com/juju/gojsonreference
   * src/github.com/juju/gojsonschema
   * src/github.com/juju/juju
   * src/github.com/juju/utils

6. Packages updated to get fixes or new API:
   * src/github.com/juju/blobstore
   * src/github.com/juju/names
   * src/github.com/juju/testing
   * src/golang.org/x/crypto
   * src/gopkg.in/check.v1
   * src/gopkg.in/mgo.v2
   * src/gopkg.in/natefinch/lumberjack.v2
   * src/launchpad.net/gomaasapi

I audited the embedded go packages based on a diff of the dependencies.tsv
http://people.canonical.com/~curtis/wily-juju-1.24.5/deps.diff
and this script to identify undocumented deps:

    for dep in $(cat src/github.com/juju/juju/dependencies.tsv | cut -f 3); do
        grep -q "Last verified commit $dep" debian/copyright || echo "Review $dep"
    done

The actual diff between 1.22.6 and 1.24.5 is a mind-numbing 1,123,938 lines;
http://people.canonical.com/~curtis/wily-juju-1.24.5/1.22.6-1.24.5.diff.gz

I singled out src/githib.com/juju/juju for special attention since files
are moved in and out the project;
http://people.canonical.com/~curtis/wily-juju-1.24.5/juju.diff.gz

summary: - [needs-packaging] 1.24.4 is not packaged in wily
+ [needs-packaging] 1.24.5 is not packaged in wily
description: updated
Robie Basak (racb) wrote :

debian/copyright looks good to me (after a very long and tedious review) - good job. I've made a few minor changes I will post here.

I'm getting autopkgtest failures when run against wily-proposed though:

client PASS
upstart-local-provider FAIL non-zero exit status 1
upstart-manual-provider FAIL non-zero exit status 1
future-local-provider FAIL non-zero exit status 1
future-manual-provider FAIL non-zero exit status 1

I presume that the tests need to be updated to use systemd instead of switching to upstart.

I'm EOD now and am out until Monday now, but I can sync with you next week on what needs to be done next and who will do what. The tedious part looks good - we just need dep8 tests to be amended so they pass and then we can upload.

Curtis Hovey (sinzui) wrote :

Hi Robie.

I have updated the juju-core source package branch per you suggestions. I applied your 2 patches. I also added gccgo-5 as the preferred compiler for wily ppc64el and arm64 to match packaging changes from the juju stable ppa. I updated the local and manual tests to only install upstart when the test host has systemd and the juju version is less then 1.23. I am attaching the debian diff.

I pushed my change to a *new* branch because we need to substitute juju-core 1.24.6 to address issues introduced by Go 1.5 that entered wily after I first recommended 1.24.5. Juju 1.24.5 doesn't work with go 1.5. 1.24.6 has compatibility fixes. I had to increase the ram to my adt qemu tests to build the packages; go 1.5 needs more memory that Go 1.4, 1.3, and 1.2. See lp:~sinzui/ubuntu/wily/juju-core/wily-1.24.6

Curtis Hovey (sinzui) wrote :

This is the diff between juju-core 1.24.5 and 1.24.6 All the changes are to the principal
project: src/github.com/juju/juju/. There are 10 new files each with the
expected copyright and license:
    +// Copyright 2015 Canonical Ltd.
    +// Licensed under the AGPLv3, see LICENCE file for details.
There remaining modified files did not change copyright or licence. The diff is small and intelligible.

Curtis Hovey (sinzui) on 2015-09-22
summary: - [needs-packaging] 1.24.5 is not packaged in wily
+ [needs-packaging] 1.24.6 is not packaged in wily
description: updated
Robie Basak (racb) wrote :

Uploaded to Wily with some minor changes. Curtis, please pull these in: https://git.launchpad.net/~ubuntu-server/ubuntu/+source/juju-core/+git/packaging/log/

Changed in juju-core (Ubuntu):
status: New → Fix Committed
Curtis Hovey (sinzui) on 2015-09-24
description: updated
Curtis Hovey (sinzui) on 2015-09-24
description: updated
Curtis Hovey (sinzui) on 2015-09-24
description: updated
Curtis Hovey (sinzui) on 2015-09-24
description: updated
tags: added: verification-done
removed: verification-needed
Curtis Hovey (sinzui) wrote :

I certify that juju 1.24.6 is suitable for local charm development and testing using both trusty and wily containers. Users of wily juju 1.24.6 can create new environments in private and public clouds. Wily juju 1.24.6 can maintain environments back to 1.18.1 (including 1.22.6 which wily currently has). Upgrades of clients and environments from juju 1.22.6 to 1.24.6 work without need of configuration changes. Wily juju 1.24.6 can manually provision environments and add-machines.

Curtis Hovey (sinzui) on 2015-09-28
description: updated
tags: removed: block-proposed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juju-core - 1.24.6-0ubuntu1

---------------
juju-core (1.24.6-0ubuntu1) wily; urgency=medium

  * New upstream release (LP: #1481556).
  * d/copyright updated for Juju 1.24.6 (Last verified commit changes).
  * d/tests/* Run tests with upstart when Juju version before 1.23.
  * Prefer gccgo-5 for ppc64el and arm64 in build-deps.

 -- <email address hidden> (Curtis C. Hovey) Wed, 22 Sep 2015 15:27:01 +0000

Changed in juju-core (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers