Wording of authentication dialog is unclear - "System policy prevents installation/removal of device drivers" but it doesn't prevent it

Bug #799725 reported by Matthew Paul Thomas
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Fix Released
Low
Unassigned
jockey (Ubuntu)
Fix Released
Low
Robert Roth
Precise
Fix Released
Low
Martin Pitt

Bug Description

Ubuntu 11.04

1. Install Ubuntu on a machine for which Jockey thinks a proprietary driver is the best choice.
2. Launch "Additional Drivers".
3. Select the driver and choose "Activate".

What happens: An authentication alert appears saying "System policy prevents installation/removal of device drivers".

What should happen: The alert for letting you do something shouldn't claim that system policy prevents it from being done at all.

Following the example of Ubuntu Software Center, the text could read "To install or remove device drivers, you need to authenticate.".

Related branches

Revision history for this message
Brendan Donegan (brendan-donegan) wrote :

Totally agree. This must be very confusing for less experienced users.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in jockey (Ubuntu):
status: New → Confirmed
Revision history for this message
Brendan Donegan (brendan-donegan) wrote :

I'd still suggest this be Low Importance as the text goes on to explain that authentication is required.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

summary: - "System policy prevents installation/removal of device drivers" - no it
- doesn't
+ Wording of authentication dialog is unclear - "System policy prevents
+ installation/removal of device drivers" but it doesn't prevent it
Changed in jockey (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Robert Roth (evfool)
Changed in jockey (Ubuntu):
assignee: nobody → Robert Roth (evfool)
Robert Roth (evfool)
tags: added: bitesize
Robert Roth (evfool)
Changed in jockey (Ubuntu):
assignee: Robert Roth (evfool) → nobody
tags: added: string-fix
Robert Roth (evfool)
Changed in jockey (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Robert Roth (evfool)
Revision history for this message
Martin Pitt (pitti) wrote :

Thanks Robert for the branch! However, as this changes user visible strings and thus breaks translations, and we are past UIF, I subscribed the ubuntu translators for their input. Do you think the benefit of better strings outweighs breaking translations here, and do you think we can catch up with the translations quickly enough?

Revision history for this message
Robert Roth (evfool) wrote :

@Martin: just checked, we have approximately 30 complete translations, and the 4 new strings would require translations in at least these languages, and maybe the better strings are not worth breaking the translations, so I think we can wait until OO is released, and merge the new strings afterwards.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Revision history for this message
Martin Pitt (pitti) wrote :

Right, targetting for P then.

Revision history for this message
David Planella (dpm) wrote :

While I agree with the change, I'm not also not sure if we should break the string freeze here.

Also, by changing the string, wouldn't we breaking consistency with the wording other applications use for such dialogs? I think I've seen "System policy [...]" in many other applications than just jockey

Revision history for this message
Martin Pitt (pitti) wrote :

I merged Robert's patch into trunk, will hit Ubuntu in early P cycle.

Changed in jockey (Ubuntu):
status: In Progress → Fix Committed
Ahmed Shams (ashams)
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → oneiric-8-system-administration
status: New → Confirmed
milestone: oneiric-8-system-administration → none
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.9.5-0ubuntu1

---------------
jockey (0.9.5-0ubuntu1) precise; urgency=low

  * New upstream release:
    - When connecting to D-BUS fails, improve error message to let users know
      what to do. Thanks Martin Owens.
    - jockey/oslib.py: Work with current PackageKit version. Thanks to Hedayat
      Vatankhah. (Not relevant for Ubuntu branch)
    - More user-friendly authentication messages on driver operations. Thanks
      Robert Roth. (LP: #799725)
    - Only ask for confirmation in check_composite if --confirm has been set.
      Thanks to Evan Dandrea. (LP: #855042)
    - examples/fake.modaliases: add -updates examples
    - Fix no space typo in VMWare drivers. Thanks Robert Roth. (LP: #722936)
    - detection.py: Fix crash if Driver ID does not have a package field.
      (LP: #837495)
  * debian/control: Add polkit-kde-1 dependency. (LP: #872442)
 -- Martin Pitt <email address hidden> Wed, 26 Oct 2011 08:40:31 +0200

Changed in jockey (Ubuntu Precise):
status: Fix Committed → Fix Released
Revision history for this message
Paul White (paulw2u) wrote :

Belatedly closing the Papercuts task as issue fixed some time ago.

Changed in hundredpapercuts:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers