jockey-gtk weird installed driver display

Bug #278071 reported by Jurriaan on 2008-10-04
58
This bug affects 2 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Undecided
Martin Pitt

Bug Description

After installing Itrepid Beta and installing nvidia drivers with hardware-drivers, I get the following window after clicking on the hardware drivers icon. It repeats the driver ~7 times or so.
The problem itself isnt repeatable, I can't get the same results after starting jockey-gtk again.

See attached screenshot for more information

Jurriaan (jurriaan) wrote :
Alberto Milone (albertomilone) wrote :

1) Please post the output of this command:
apt-cache policy jockey-gtk jockey-common

2) type (ignore any error):

sudo killall jockey-backend

sudo rm -R /var/cache/jockey

sudo /usr/share/jockey/jockey-backend --debug

(keep it running in the background)

and post what happens

sudo

Jurriaan (jurriaan) wrote :

I'll test it as soon as possible, but the problem itself isn't repeatable. Somehow I can't get the same results. When i launched jockey-gtk for a second time I got the normal jockey-gtk window.

Martin Pitt (pitti) wrote :

That really looks funny. However, without a recipe for reproducing this there is little we can do, I'm afraid. I keep this as "incomplete". As soon as you found it out, can you please report back here? If you can't let's blame sun radiation and forget about it. :-)

Thanks, Martin

Changed in jockey:
status: New → Incomplete
Jurriaan (jurriaan) wrote :

@Martin: Yeah it sure looks funny. I'm aware that you could do nothing with only a screenshot, but i'll try to reproduce it when i've time(reinstalling when final is out)

@Alberto: Here's the output, nothing special.

Alberto Milone (albertomilone) wrote :

Unfortunately I can't see the cause of the problem. Feel free to reopen the bug report if you manage to reproduce the problem again.

Martin Pitt (pitti) wrote :

I close the bug for now. If you get it again, please set it back to confirmed. Thanks!

Changed in jockey:
status: Incomplete → Invalid
Martin Pitt (pitti) wrote :

This was just reported again in bug 280952. I still have no idea how to reproduce it, though.

Changed in jockey:
status: Invalid → Incomplete
Martin Pitt (pitti) wrote :

This happens when clicking on the tray icon multiple times while the application is already open. I can reproduce it now.

Changed in jockey:
assignee: nobody → pitti
status: Incomplete → In Progress
Alberto Milone (albertomilone) wrote :

I have fixed this bug in revision 480 in my bazaar branch:
https://code.launchpad.net/~albertomilone/jockey/jockey-generic

Martin Pitt (pitti) wrote :

Thanks, Alberto. That works, but has the nasty effect that it reinitializes the tree view very often.

I did a different approach now which makes sure to not reinitialize it if it was already, and also added GTK and KDE test cases. KDE is confirmed to be fine.

http://bazaar.launchpad.net/~jockey-hackers/jockey/trunk/revision/499

Changed in jockey:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5~beta3-0ubuntu7

---------------
jockey (0.5~beta3-0ubuntu7) jaunty; urgency=low

  * Merge changes from trunk:
    - Prevent corrupting the tree view when clicking on the tray applet
      multiple times. (LP: #278071)
    - Update translations from Rosetta.
  * data/handlers/nvidia.py: Unblacklist nvidia driver version 96, it has been
    fixed in intrepid-proposed (see LP #251107). (LP: #293107)

 -- Martin Pitt <email address hidden> Mon, 10 Nov 2008 17:24:09 +0100

Changed in jockey:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers