[hardy] Can't enable restricted drivers from the live CD

Bug #197264 reported by Pat Leamon on 2008-03-01
44
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Undecided
Colin Watson
jockey (Ubuntu)
Medium
Unassigned

Bug Description

1) The release of Ubuntu you are using, via 'cat /etc/lsb-release' or System -> About Ubuntu.
Reproduce in Hardy Alpha 5 and 6 Live CD

2) What you expected to happen
Boot into live CD. Enable desktop effects to show off to friends after I enable restricted drivers from the Hardware Drivers tool.

3) What happened instead
From the LiveCD, I can't install restricted drivers. Opening "Hardware drivers" shows "no proprietary drivers are in use on this system" and a empty list without any graphic cards listed in it.

Pat Leamon (pleamonhp) wrote :

Oh, forgot to add some hardware details:
AMD64 X2 3800
Nvidia 7600GS
Viewsonic VA902 19" LCD
nVidia based motherboard (MCP55)

Pat Leamon (pleamonhp) wrote :
Pat Leamon (pleamonhp) wrote :
Colin Watson (cjwatson) wrote :

I'm not sure where this belongs, but it definitely isn't casper (perhaps it should be displayconfig-gtk?). Please reassign further as appropriate.

Travis Watkins (amaranth) wrote :

Perhaps displayconfig-gtk doesn't understand what to do when you have no xorg.conf

Saivann Carignan (oxmosys) wrote :

Thanks for your bug report and for your contribution to ubuntu. You bug report actually describe two different issues.

#1 : displayconfig-gtk is completely empty, this bug has been fixed in latest hardy alpha 6 release, this is bug 178061.

#2 : A problem while trying to install restricted drivers through Hardware drivers (the good package name for this ubuntu component is "jockey"). You did not actually give a lot of details about this problem.

To avoid confusion, I will remove the part that speaks about the issue #1 in your description and I will change the package to jockey. Since I can reproduce it here with a ATI mobility radeon x300 card, I set the status to confirmed. Thanks for your contribution to ubuntu!

description: updated
Changed in displayconfig-gtk:
importance: Undecided → Medium
status: New → Confirmed
Pat Leamon (pleamonhp) wrote :

Actually my problem IS that I can't enable the desktop effects. Am I required to go through hoops before I enable this functionality on the live CD? If so, why? This doesn't leave a great impression for people testing out ubuntu which is what the liveCD is for.

Saivann Carignan (oxmosys) wrote :

nvidia does not provide open source drivers for their nvidia cards so a restricted driver must be installed in order to gain the possibility to use compiz, however, it appears that installing the restricted driver from the LiveCD is not possible (it was possible in the past) but now jockey only show a empty list and does not give you the possibility to install the driver. The fact that you can't use compiz is caused by this bug.

Pat Leamon (pleamonhp) wrote :

To me, there are (still) multiple issues here.

1) As a user trying out ubuntu, desktop effects simply fail.

The problem with this is that there is no indication of why it failed. I know that it's probably because it's running the open source drivers. That's why I tried to find out what was running via jockey/displayconfig (which were both broken). I believe that a normal user probably wouldn't make that connection in the first place.

I think the desktop effects UI should give better feedback here if drivers are the issue, perhaps to the point of launching jockey to use alternate drivers. Perhaps that's out of scope and an improvement, not a bug.

I'm not sure if jockey is supposed to ask you if you want to use restricted drivers on startup of the live CD or not. That is also something that would also make using desktop effects a bit easier.

2) Jockey isn't working - it's showing a blank list.

Saivann Carignan (oxmosys) wrote :

I also believe that it's possible to improve this, however, it is always very important to speak about one specific bug by bug report or it becomes very hard for developers to work with launchpad so we should keep this bug only about the missing restricted drivers inside the LiveCD.

You can look to see if someone already posted the same bug against the fact that the desktop effect message does not suggest the user to look if there are restricted drivers to install before compiz can be enabled. If you don't find a bug already posted about that issue, you can post a new one about that specific wish. Thanks for your contribution so far!

Martin Pitt (pitti) wrote :

I am currently at a conference without access to booting live CDs and computers which need restricted drivers, so I'm afraid I need some help here. I believe the issue is due to one of two things:

 (1) The live system does not have restricted enabled in the apt sources.

 (2) The live system was built without running apt-get update.

In order to find this out, can you please check in a running live system:

  * apt-cache show nvidia-glx

Does this output the package information, or nothing? Does it work after "sudo apt-get update"? If yes, it is (2), if not, it is probably (1). In the case of (2), jockey should work after apt-get update, too.

Changed in ubuntu-cdimage:
status: New → Incomplete
Saivann Carignan (oxmosys) wrote :

I just booted my Dell inspiron laptop with Hardy beta live CD. It has a ATI card which can work with fglrx ATI drivers. It is properly detected by jockey only once Hardy is installed, but not on the live CD.

apt-cache show nvidia-glx gives informations about the package without needing apt-get update or anything else, directly after booting the Live CD :

Package: nvidia-glx
Priority: optional
Section: restricted/x11
Installed-Size: 11992
...

However, jockey does not detect any drivers for my card. If I enable universe and multiverse, run apt-get update and restart jockey, jockey still does not detect anything.

Martin Pitt (pitti) wrote :

Saivann, thank you! So it seems that the live CD itself is alright. Can you please do

  jockey-gtk --list --debug 2>&1 | tee /tmp/debug.log

under the live system and attach /tmp/debug.log here?

Changed in ubuntu-cdimage:
status: Incomplete → Invalid
Changed in jockey:
status: Confirmed → Incomplete
Saivann Carignan (oxmosys) wrote :

Martin Pitt : Thanks for working on this!

I booted again Hardy beta live CD and did what you asked, debug.log attached.

lspci -nn | grep VGA :
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M22 [Mobility Radeon X300] [1002:5460]

apt-cache policy jockey-gtk :
  Installed: 0.3.2-0ubuntu2

ChrisLees (christopher-lees) wrote :

Sorry I don't have time at the moment to boot up a live disc - I'm about to deliver a new Ubuntu computer to someone. But this new computer also exhibited the same problem as Saïvann Carignan - no ATI driver listed in Jockey, even after adding all the repos and doing sudo apt-get update. Installing Ubuntu, then running Jockey on the installed system worked fine.

My main system has an EN8600GT, my friend's new computer has an integrated ATI Radeon X1250.

Changed in jockey:
status: Incomplete → Confirmed
Martin Pitt (pitti) on 2008-04-10
Changed in jockey:
status: Confirmed → Invalid
Martin Pitt (pitti) wrote :

Thanks, this showed the problem:
WARNING: modinfo for module fglrx failed: modinfo: could not open /lib/modules/2.6.24-12-generic/volatile/fglrx.ko: No such file or directory
WARNING: modinfo for module nvidia_new failed: modinfo: could not open /lib/modules/2.6.24-12-generic/volatile/nvidia_new.ko: No such file or directory

So for some reason those are not generated on the live system, although linux-restricted-modules should be installed.

Changed in ubuntu-cdimage:
status: Invalid → Confirmed
Colin Watson (cjwatson) wrote :

We deliberately don't link those modules on the live CD, because doing so takes up huge amounts of memory and they're never used by default. See casper/scripts/casper-bottom/38disable_restricted_manager.

jockey will have to generate these if the user asks for them, I'm afraid.

Changed in jockey:
status: Invalid → Confirmed
Changed in ubuntu-cdimage:
status: Confirmed → Won't Fix
assignee: nobody → kamion
Markus Korn (thekorn) wrote :

I also get this issue with the latest version of the live CD.

ubuntu@ubuntu:~$ lspci -nn | grep VGA
06:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8600 GT [10de:0402] (rev a1)
ubuntu@ubuntu:~$ apt-cache policy jockey-gtk
jockey-gtk:
  Installiert:0.3.3-0ubuntu7
  Mögliche Pakete:0.3.3-0ubuntu7
  Versions-Tabelle:
 *** 0.3.3-0ubuntu7 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Markus

Andrew Min (andrewmin) wrote :

I've got this error on my Radeon x300 on my _install_, not just the live CD. Note that restricted-manager-kde in Gutsy could pick it up correctly. Here's the error:

WARNING: modinfo for module fglrx failed: modinfo: could not find module fglrx

WARNING: modinfo for module nvidia_new failed: modinfo: could not find module nvidia_new

WARNING: modinfo for module nvidia failed: modinfo: could not find module nvidia

WARNING: modinfo for module nvidia_legacy failed: modinfo: could not find module nvidia_legacy

Martin Pitt (pitti) wrote :

Andrew, that sounds like bug 227198.

Martin Pitt (pitti) wrote :

Andrew, well, there are slightly different error messages. Can you please open a new bug against jockey? Thanks!

Andrew Min (andrewmin) wrote :

Sorry, the bug I filed against was marked as a duplicate of this. I guess it was a mismark.

Mario Limonciello (superm1) wrote :

This should be more doable now due to the split of jockey into a frontend/backend (the backend can completely invoke and control restarting gdm/xsession).

Saivann Carignan (oxmosys) wrote :

Thanks, I will test this with intrepid alpha 4 with nvidia and ATI.

Saivann Carignan (oxmosys) wrote :

Thank you very much, this bug is now fixed.

However, after trying it, another important bug can be reproduced : If you enable nvidia drivers from the LiveCD session and then install ubuntu, your freshly installed intrepid alpha 4 will fall into X failsafe mode on the first boot. This seems to be due to partially persistence of the LiveCD environment. I filed this problem in bug 258486 . If a ubuntu developer can take a look at it, this might not necessary be jockeys fault.

Changed in jockey:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers