{karmic] package ipppd 1:3.12.20071127-0ubuntu5 failed to install/upgrade: subprocess installed post-installation script returned error exit status 127

Bug #414537 reported by Hellsgator on 2009-08-16
360
This bug affects 59 people
Affects Status Importance Assigned to Milestone
isdnutils (Ubuntu)
Medium
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Medium
Unassigned

Bug Description

Binary package hint: isdnutils

no info, just failed to install again.

ProblemType: Package
Architecture: i386
Date: Sun Aug 16 21:57:30 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script returned error exit status 127
NonfreeKernelModules: wl
Package: ipppd 1:3.12.20071127-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
SourcePackage: isdnutils
Title: package ipppd 1:3.12.20071127-0ubuntu5 failed to install/upgrade: subprocess installed post-installation script returned error exit status 127
Uname: Linux 2.6.31-5-generic i686

Hellsgator (hellsgate) wrote :
Rolf Leggewie (r0lf) wrote :

seems to be a long-standing and unfixed problem. There are a lot of duplicate reports. Confirming.

tags: added: karmic
Changed in isdnutils (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

As Rafael correctly points out in bug 396408, the root cause of the problem seems to be calling /MAKEDEV instead of /sbin/MAKEDEV

Rolf Leggewie (r0lf) wrote :

I'll try to tackle this.

Changed in isdnutils (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
Rolf Leggewie (r0lf) wrote :

Here is my suggested fix for karmic

Changed in isdnutils (Ubuntu):
assignee: Rolf Leggewie (r0lf) → nobody
Rolf Leggewie (r0lf) wrote :

ping sponsors

Benjamin Drung (bdrung) on 2009-09-23
Changed in isdnutils (Ubuntu):
assignee: nobody → Benjamin Drung (bdrung)
status: Confirmed → In Progress
Benjamin Drung (bdrung) wrote :

The fix is already applied in Debian. Uploading now. Thanks for your contribution.

Changed in isdnutils (Ubuntu):
assignee: Benjamin Drung (bdrung) → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package isdnutils - 1:3.12.20071127-0ubuntu6

---------------
isdnutils (1:3.12.20071127-0ubuntu6) karmic; urgency=low

  * replace calls to ./MAKEDEV with /sbin/MAKEDEV (LP: #414537)
    That was the easiest fix ever to close 18 bugs ;-)

 -- Rolf Leggewie <email address hidden> Sat, 29 Aug 2009 05:18:47 +0200

Changed in isdnutils (Ubuntu):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

I think 0ubuntu6 from karmic should be pushed back to Jaunty. Subscribing sponsors.

Benjamin Drung (bdrung) wrote :

Please follow https://wiki.ubuntu.com/StableReleaseUpdates and provide a debdiff for jaunty.

Rolf Leggewie (r0lf) wrote :

I think the diff is obvious and simple enough for anyone looking at it to understand that no further lengthy discourse is necessary.

Benjamin Drung (bdrung) wrote :

Can you provide a debdiff (the version and the targeted release need to be modified)?

Rolf Leggewie (r0lf) wrote :

Essentially, it's already attached to this bug: http://launchpadlibrarian.net/30958633/LP414537.debdiff

Do a "sed s/karmic/jaunty/" on it and you're done

Benjamin Drung (bdrung) wrote :

No, that's not all.
You have to adjust the version: 1:3.12.20071127-0ubuntu6 -> 1:3.12.20071127-0ubuntu5.1
-proposed is missing: karmic -> jaunty-proposed
I have uploaded it now.

James Ferguson (jpferg1) wrote :

Hello new support system: I have a request. We troglodytes who are trying to work through these problems as users come to the forum for insight and answers. While we are smart and learning more, it is still very frustrating to have these chains of missives between experts that essentially are way too shorthand to be usable.

"Do a "sed s/karmic/jaunty/" on it and you're done " -----what the heck does this mean?

"I have uploaded it now." -------to whom, where? How do I solve this problem on MY computer?

Thanks.

Changed in isdnutils (Ubuntu Karmic):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted isdnutils into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in isdnutils (Ubuntu Jaunty):
status: New → Fix Committed
tags: added: verification-needed
Benjamin Drung (bdrung) wrote :

@James: Yes, the discussion between Rolf and me was very technical and refers to packaging. The upload was done to jaunty-proposed and the package was now accepted. Now your part starts: Please test it (see the previous comment from Martin).

Changed in isdnutils (Ubuntu):
assignee: nobody → Arnab Nandy (arnab-nandy7)
Steve Beattie (sbeattie) wrote :

I have reproduced the failure to install of isdnutils/ipppd 1:3.12.20071127-0ubuntu5 from jaunty due to the incorrect path to MAKEDEV and can confirm that the version of isdnutils/ipppd in jaunty-proposed, 1:3.12.20071127-0ubuntu5.1, does in fact install successfully. I don't have access to ISDN, so I can't tell if the packages work beyond that; it would be great if others affected by this bug could report back any results they have using these packages before they get pushed to jaunty-updates. Thanks.

tags: added: jaunty verification-done
removed: verification-needed
Changed in isdnutils (Ubuntu):
assignee: Arnab Nandy (arnab-nandy7) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package isdnutils - 1:3.12.20071127-0ubuntu5.1

---------------
isdnutils (1:3.12.20071127-0ubuntu5.1) jaunty-proposed; urgency=low

  * replace calls to ./MAKEDEV with /sbin/MAKEDEV (LP: #414537)
    That was the easiest fix ever to close 18 bugs ;-)

 -- Rolf Leggewie <email address hidden> Thu, 15 Oct 2009 15:49:59 +0200

Changed in isdnutils (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in isdnutils (Ubuntu Jaunty):
status: Fix Released → Fix Committed
Martin Pitt (pitti) on 2009-11-04
Changed in isdnutils (Ubuntu Jaunty):
status: Fix Committed → Fix Released
To post a comment you must log in.