Please merge irssi 0.8.14-1(main) from debian unstable(main)

Bug #406890 reported by Bhavani Shankar on 2009-07-30
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
irssi (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: irssi

Debian has a new version to be merged

irssi (0.8.14-1) unstable; urgency=low

  * New upstream release, dropping wallops-fix patch.
  * Refreshed quilt patches.
  * Bumped Standards-Version to 3.8.2.

 -- Gerfried Fuchs <email address hidden> Wed, 29 Jul 2009 12:55:04 +0200

Related branches

Bhavani Shankar (bhavi) wrote :
Download full text (4.8 KiB)

Upstream changelog excerpt:

------------------------------------------------------------------------
r5081 | ahf | 2009-07-28 19:38:36 +0000 (Tue, 28 Jul 2009) | 1 line
Changed paths:
   M /irssi/trunk/NEWS
   M /irssi/trunk/configure.in

Release: 0.8.14
------------------------------------------------------------------------
r5080 | ahf | 2009-07-22 19:45:51 +0000 (Wed, 22 Jul 2009) | 1 line
Changed paths:
   M /irssi/trunk/src/fe-common/core/fe-log.c

Move the autolog_ignore_targets logic a bit around; fixes #673.
------------------------------------------------------------------------
r5079 | ahf | 2009-06-07 11:50:55 +0000 (Sun, 07 Jun 2009) | 1 line
Changed paths:
   M /irssi/trunk/NEWS

Typo spotted by RichiH.
------------------------------------------------------------------------
r5078 | ahf | 2009-06-04 21:04:59 +0000 (Thu, 04 Jun 2009) | 1 line
Changed paths:
   M /irssi/trunk/irssi.conf

Make /reset an alias for /set -default and /unset an alias for /set -clear.
------------------------------------------------------------------------
r5076 | ahf | 2009-05-24 15:51:49 +0000 (Sun, 24 May 2009) | 1 line
Changed paths:
   M /irssi/trunk/irssi.conf

We got #irssi on IRCnet back. Fix irssi.conf to reflect this.
------------------------------------------------------------------------
r5075 | jilles | 2009-05-22 12:48:02 +0000 (Fri, 22 May 2009) | 2 lines
Changed paths:
   M /irssi/trunk/src/fe-text/gui-readline.c

Allow ctrl+home/ctrl+end to go to the beginning/end of scrollback.

------------------------------------------------------------------------
r5068 | jilles | 2009-05-15 11:54:33 +0000 (Fri, 15 May 2009) | 5 lines
Changed paths:
   M /irssi/trunk/src/fe-common/irc/fe-events.c

Fix out of bounds access in event_wallops().

bug #662
Submitted by: nemo

------------------------------------------------------------------------
r5065 | jilles | 2009-05-13 21:01:55 +0000 (Wed, 13 May 2009) | 4 lines
Changed paths:
   M /irssi/trunk/irssi-version.sh

Do not put a space between awk's -F and its argument.
Solaris's /usr/bin/awk chokes on the space.
Bug #672

------------------------------------------------------------------------
r5064 | jilles | 2009-05-13 19:27:20 +0000 (Wed, 13 May 2009) | 11 lines
Changed paths:
   M /irssi/trunk/src/irc/core/servers-redirect.c

Accept 354 (WHOX reply) as a /who reply too (for redirection).

Ignore the parameters for matching because 354 does
not have a fixed format.

This helps irssi-proxy with clients that use WHOX,
such as xchat (away checking). WHOX works on ircu
and charybdis 3.1 servers.

Bug #671

------------------------------------------------------------------------
r5063 | Geert | 2009-04-27 19:00:48 +0000 (Mon, 27 Apr 2009) | 2 lines
Changed paths:
   M /irssi/trunk/irssi.conf

Renamed IRCnet #irssi to #irssi.org

------------------------------------------------------------------------
r5062 | jilles | 2009-04-26 20:54:49 +0000 (Sun, 26 Apr 2009) | 5 lines
Changed paths:
   M /irssi/trunk/Makefile.am

Fix make install without write privilege to the source directory
by not using a temp file in there for irssi-version.h.
Note that this will still not work if the source has changed
since it w...

Read more...

Bhavani Shankar (bhavi) wrote :
tags: added: merge upgrade
Changed in irssi (Ubuntu):
status: New → Confirmed

irssi (0.8.14-1ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes: LP: #406890
    - debian/patches: 03firsttimer_text
      + Adapt it so it tells you about connecting to irc.ubuntu.com and
        joining #ubuntu instead of irc.debian.org and #debian.
    - debian/patches: 90irc-ubuntu-com

 -- Bhavani Shankar <email address hidden> Thu, 30 Jul 2009 19:12:55 +0530

Changed in irssi (Ubuntu):
status: Confirmed → New
Changed in irssi (Ubuntu):
status: New → Confirmed
Changed in irssi (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Sarah Hobbs (hobbsee)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package irssi - 0.8.14-1ubuntu1

---------------
irssi (0.8.14-1ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes: LP: #406890
    - debian/patches: 03firsttimer_text
      + Adapt it so it tells you about connecting to irc.ubuntu.com and
        joining #ubuntu instead of irc.debian.org and #debian.
    - debian/patches: 90irc-ubuntu-com

 -- Bhavani Shankar <email address hidden> Thu, 30 Jul 2009 19:12:55 +0530

Changed in irssi (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers