XPS 13 9310 Tiger Lake Unable to boot 20.10 after intel-microcode update 3.20201110.0ubuntu0.20.10.1

Bug #1903883 reported by jaypz
54
This bug affects 5 people
Affects Status Importance Assigned to Milestone
intel-microcode (Ubuntu)
Critical
Alex Murray

Bug Description

XPS 13 9310 Tiger Lake i7 running Ubuntu 20.10 (machine came with Ubuntu 20.04 from the OEM)

Update to intel-microcode 3.20201110.0ubuntu0.20.10.1 on reboot causes what looks like a black screen with corrupted artifacts on it and the system restarts, from dmesg upon booting into fallback kernel I these errors from previous boot

[ 1.286211] kernel: [Hardware Error]: event severity: fatal
[ 1.286217] kernel: [Hardware Error]: Error 0, type: fatal
[ 1.286218] kernel: [Hardware Error]: section_type: Firmware Error Record Reference
[ 1.286218] kernel: [Hardware Error]: Firmware Error Record Type: SOC Firmware Error Record Type2
[ 1.286219] kernel: [Hardware Error]: Revision: 2
[ 1.286220] kernel: [Hardware Error]: Record Identifier: 8f87f311-c998-4d9e-a0c4-6065518c4f6d

[ 1.286365] kernel: [Hardware Error]: Error 1, type: fatal
[ 1.286365] kernel: [Hardware Error]: section_type: Firmware Error Record Reference
[ 1.286366] kernel: [Hardware Error]: Firmware Error Record Type: SOC Firmware Error Record Type2
[ 1.286366] kernel: [Hardware Error]: Revision: 2
[ 1.286367] kernel: [Hardware Error]: Record Identifier: 8f87f311-c998-4d9e-a0c4-6065518c4f6d

Kernel with this issue is linux-image-5.8.0-28-generic, falling back to 5.8.0-26-generic in GRUB results in the machine booting up fine

I've tried rebooting several times with the machine on and off power supply and get the same result each time
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu50
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
DistributionChannelDescriptor:
 # This is the distribution channel descriptor for the OEM CDs
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-focal-amd64-20200502-85
DistroRelease: Ubuntu 20.10
InstallationDate: Installed on 2020-10-07 (35 days ago)
InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 20200502-05:58
Package: intel-microcode 3.20201110.0ubuntu0.20.10.1
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/usr/bin/zsh
ProcVersionSignature: Ubuntu 5.8.0-26.27-generic 5.8.14
Tags: groovy
Uname: Linux 5.8.0-26-generic x86_64
UpgradeStatus: Upgraded to groovy on 2020-11-02 (8 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

Revision history for this message
jaypz (jaypz) wrote : Dependencies.txt

apport information

tags: added: apport-collected groovy
description: updated
Revision history for this message
jaypz (jaypz) wrote : ProcCpuinfoMinimal.txt

apport information

Revision history for this message
jaypz (jaypz) wrote : Re: XPS 1310 Tiger Lake Unable to boot 20.10 after intel-microcode update 3.20201110.0ubuntu0.20.10.1

added apport info after booting into usable 5.8.0-26-generic kernel

summary: - XPS 1310 Tiger Lake Unable to boot 20.10 after intel-microcode update
+ XPS 13 9310 Tiger Lake Unable to boot 20.10 after intel-microcode update
3.20201110.0ubuntu0.20.10.1
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in intel-microcode (Ubuntu):
status: New → Confirmed
Revision history for this message
Craig (craigtlandry) wrote :

I am having this same issue. Here's a photo (attached) of my screen when booting.

Machine is exact same model as described in original bug report here. I am on kernel 5.6.0-1033-oem though, which was installed at the same time as intel-microcode:amd64 3.20201110.0ubuntu0.20.04.1.

Changed in intel-microcode (Ubuntu):
importance: Undecided → Critical
Revision history for this message
Craig (craigtlandry) wrote :

I've installed a prior intel-microcode version (3.20191115.1ubuntu3) and can verify that all is back to normal.

tags: added: regression-update
tags: added: focal
Alex Murray (alexmurray)
Changed in intel-microcode (Ubuntu):
assignee: nobody → Alex Murray (alexmurray)
Revision history for this message
Nick Piper (nickholus) wrote :

For anyone struggling to recover, note you can add 'dis_ucode_ldr' to your cmdline in grub to disable the microcode loading, and this will let you boot your regular kernel.

Revision history for this message
Alex Murray (alexmurray) wrote :

Thanks for reporting this issue - thanks @superrm1 for forwarding it upstream - https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files/issues/44 - I'll push an update soon which reverts just this single microcode for the intel-microcode package in Ubuntu.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package intel-microcode - 3.20201110.0ubuntu0.20.10.2

---------------
intel-microcode (3.20201110.0ubuntu0.20.10.2) groovy-security; urgency=medium

  * SECURITY REGRESSION: Some CPUs in the Tiger Lake family sig=0x806c1
    fail to boot (LP: #1903883)
    - remove 06-8c-01/0x000806c1 microcode

 -- Alex Murray <email address hidden> Thu, 12 Nov 2020 09:54:10 +1030

Changed in intel-microcode (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package intel-microcode - 3.20201110.0ubuntu0.20.04.2

---------------
intel-microcode (3.20201110.0ubuntu0.20.04.2) focal-security; urgency=medium

  * SECURITY REGRESSION: Some CPUs in the Tiger Lake family sig=0x806c1
    fail to boot (LP: #1903883)
    - remove 06-8c-01/0x000806c1 microcode

 -- Alex Murray <email address hidden> Thu, 12 Nov 2020 09:54:34 +1030

Changed in intel-microcode (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package intel-microcode - 3.20201110.0ubuntu0.18.04.2

---------------
intel-microcode (3.20201110.0ubuntu0.18.04.2) bionic-security; urgency=medium

  * SECURITY REGRESSION: Some CPUs in the Tiger Lake family sig=0x806c1
    fail to boot (LP: #1903883)
    - remove 06-8c-01/0x000806c1 microcode

 -- Alex Murray <email address hidden> Thu, 12 Nov 2020 09:55:08 +1030

Changed in intel-microcode (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
jaypz (jaypz) wrote :

thanks all for the quick fix and reporting upstream! <3

Revision history for this message
Pierre (p-laloutre) wrote :

I've been struck by the exact same bug on a Core m3-6Y30 (affecting Ubuntu 20.04 but also 18.04 with corresponding package) all the same after updating to the 3.20201110.0ubuntu0.20.04.1 version.

The 3.20201110.0ubuntu0.20.04.2 fix is not helping. I have to keep the 3.20200609.0ubuntu0.20.04.2 to avoid being stuck at "Loading initial ramdisk".

Not too sure how I should report this considering all the open reports on the launchpad page: https://bugs.launchpad.net/ubuntu/+source/intel-microcode

information type: Public → Public Security
information type: Public Security → Public
Revision history for this message
Alex Murray (alexmurray) wrote :

@Pierre - can you please open a new bug report via `ubuntu-bug intel-microcode` and we can follow up there - thanks!

Revision history for this message
Philippe (philippe734) wrote :

The bug is still occur with Intel Core i3-6006U running Ubuntu 20.04 up to date, even after updated intel-microcode to version 3.20201110.0ubuntu0.20.04.2
So, I downgrade to 3.20191115.1ubuntu3 and Ubuntu 20.04 can boot.

Revision history for this message
Alex Murray (alexmurray) wrote :

@philippe734 - yours is not the same CPU as this bug report so can you please file a separate bug by running the following in a terminal

ubuntu-bug intel-microcode

And we can follow up there. Thanks.

Revision history for this message
Yuan-Chen Cheng (ycheng-twn) wrote :

to check if your cpu is in the list, it seems we can get it from /proc/cpuinfo as value

  cpu family-model-stepping

if it's 06-8c-01 (which is 6-140-1 in decimal), then you will have this issue.

Revision history for this message
Gary Wang (gary-c-wang) wrote :

@jaypz and @Pierre,
Is the release fix able to the issue by following new release?
https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files/releases/tag/microcode-20210608
Thanks
Gary

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.