New version of intel-microcode freezes computer

Bug #1760264 reported by QkiZ on 2018-03-31
This bug affects 9 people
Affects Status Importance Assigned to Milestone
intel-microcode (Ubuntu)

Bug Description

The problem appears on 3.20180312.0~ubuntu17.10.1 version. System freeze completely on login screen. Can't move mouse and switch to virtual console. After downgrade to 3.20170707.1 made in recovery mode everything back to normal. I have Intel Core i7-4700HQ.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: intel-microcode 3.20170707.1
ProcVersionSignature: Ubuntu 4.13.0-37.42-lowlatency 4.13.13
Uname: Linux 4.13.0-37-lowlatency x86_64
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
Date: Sat Mar 31 06:26:06 2018
InstallationDate: Installed on 2015-02-13 (1141 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
SourcePackage: intel-microcode
UpgradeStatus: Upgraded to artful on 2017-10-20 (161 days ago)

QkiZ (qkiz) wrote :
Paul Nickerson (pgn674) wrote :

For me, both intel-microcode 3.20180312.0~ubuntu17.10.1 amd64 and linux-image-4.13.0-37-generic 4.13.0-37.42 amd64 got installed at the same time. On my next boot and every boot after that, my computer would hang hard after I typed in my password at the login screen and hit enter. My cursor would appear on a black screen, and then it hung.

I did not try downgrading intel-microcode, but I did try selecting linux-image-4.13.0-36-generic 4.13.0-36.40 amd64 in GRUB on boot. That did work.

So I believe we may have found two different workarounds to the same bug, maybe.

I was able to SSH into the computer from a different machine while at the login screen and run journalctl -f before I tried to log in, and that got me more log entries than were written to disk. But, I still feel like I did not get to see the final actions before the hang; they never got logged or didn't make it over the SSH tunnel.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in intel-microcode (Ubuntu):
status: New → Confirmed
QkiZ (qkiz) wrote :

After intel-microcode package install Linux image is generated with new microcode so that's why your previous Linux image contains precious microcode. I marked intel-microcode as held to skip updating this package, till it will be fixed.

I have a Dell XPS 13 9343 and I already had the same error when I installed the (now withdrawn) BIOS Update A14. The notebook was irregularly completely frozen. I could provoke the freeze immediately by changing the WLAN in the network manager of Gnome. During the connection with the new WLAN, the computer is reliably frozen.

This was fixed by downgrading to BIOS Update A13.

I now have the exact same problem with the latest intel-microcode update. The system freezes at the moment a WLAN connection is (re-)established. The workaround here is either to use the previous version of intel-microcode or to deactivate the intel-microcode package.

An update of the kernel to another version had only helped me for a short time. After the second or third reconnect at the latest, the computer has completely hung up again.

I replaced the original XPS 13 Broadcom W-LAN module with the Intel Wireless 8260 module.

Michael Mauch (michael-mauch) wrote :

Same problem on a Core i7 2600 (Sandy Bridge) with 3.20180312.0~ubuntu16.04.1.

Adding dis_ucode_ldr to grub's kernel command line temporarily (see /usr/share/doc/intel-microcode/README.Debian.gz) let me boot again, so I can try to download the older package.

Michael Mauch (michael-mauch) wrote :

Here's a serial log made with picocom and script on a Raspberry Pi.

It contains the end of a shutdown, a boot with the microcode loader active (search for " 0.0000" to find the start of the boot, or "Tainted" to get to the error), and a successful boot with dis_ucode_ldr.

I know that tainted kernels make maintainers unhappy. I need these modules for my DVB card. If that log is useful at all, I could make a log with an original kernel.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers