intel_reg_dumper crashed with SIGABRT in __libc_start_main()

Bug #1316454 reported by Franz Hsieh on 2014-05-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Ara Pulido
Trusty
Undecided
Unassigned
intel-gpu-tools (Ubuntu)
Undecided
Timo Aaltonen
Trusty
Undecided
Unassigned

Bug Description

[Impact]
An error dialog will be shown after user login to the desktop environment.
The error is :

The intel_reg_dumper raise SIGABRT on Intel ValleyView Gen7 [8086:0f31] platform.

Bumping intel-gpu-tools to 1.7 as SRU is unrealistic, and backporting new hw support didn't fix it, so the easiest way to work around this issue is to not abort() when it fails to detect the chip gen related register maps. This should prevent core dumps and the crash reports.

[Test Case]
This issue can be reproduced by running the command:

# sudo intel_reg_dumper
Gen2/3 Ranges are not supported. Please use unsafe access. (Core dump)

[Regression potential]
None really, it just won't dump core which hardly anything relies on..

DistroRelease: Ubuntu 14.04
InstallationDate: Installed on 2014-05-02 (0 days ago)
InstallationMedia: Ubuntu 14.04 "Trusty" - Build amd64 LIVE Binary 20140502-08:19

Franz Hsieh (franz-hsieh) wrote :
Franz Hsieh (franz-hsieh) wrote :

The intel_reg_dump of intel-gpu-tools v1.6 works fine.

affects: xserver-xorg-video-intel → oem-priority
Changed in oem-priority:
importance: Undecided → High
description: updated
description: updated
description: updated
Ara Pulido (ara) on 2014-05-14
Changed in oem-priority:
assignee: nobody → Ara Pulido (apulido)
Franz Hsieh (franz-hsieh) wrote :

Attach error dialog snapshot.

Timo Aaltonen (tjaalton) wrote :

I can reproduce it on broadwell and valleyview (baytrail)

Changed in intel-gpu-tools (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → Triaged
Timo Aaltonen (tjaalton) wrote :

fixed in utopic

Changed in intel-gpu-tools (Ubuntu Trusty):
status: New → Triaged
Changed in intel-gpu-tools (Ubuntu):
status: Triaged → Fix Released
Franz Hsieh (franz-hsieh) wrote :

@Timo

Will it be back ported to trusty?

Timo Aaltonen (tjaalton) wrote :

Yes, I've just uploaded a version to trusty-proposed that makes intel-reg-dumper not abort() when it checks the supported register map. That should prevent crashes which is all that can be backported..

Changed in intel-gpu-tools (Ubuntu Trusty):
status: Triaged → In Progress
Chris J Arges (arges) wrote :

Hi Timo, can you update the bug description with the SRU template? Also I'd like to know why removing the abort() call makes sense, because in the 1.7-1 version that call is still present. Is the abort() call the right way to handle that code path?
Thanks,

Timo Aaltonen (tjaalton) on 2014-06-25
description: updated

Hello Franz, or anyone else affected,

Accepted intel-gpu-tools into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/intel-gpu-tools/1.3-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in intel-gpu-tools (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Ara Pulido (ara) on 2014-07-02
Changed in oem-priority:
status: New → In Progress
Timo Aaltonen (tjaalton) wrote :

works for me, marked verification-done

tags: added: verification-done
removed: verification-needed
Franz Hsieh (franz-hsieh) wrote :

I have installed and verified the intel-gpu-tools 1.3-0ubuntu2.1 on target machine, the issue is fixed.

The verification of the Stable Release Update for intel-gpu-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package intel-gpu-tools - 1.3-0ubuntu2.1

---------------
intel-gpu-tools (1.3-0ubuntu2.1) trusty-proposed; urgency=medium

  * dont-abort-regdumper.diff: No need to abort() on unsupported systems.
    (LP: #1316454)
 -- Timo Aaltonen <email address hidden> Tue, 24 Jun 2014 13:15:46 +0300

Changed in intel-gpu-tools (Ubuntu Trusty):
status: Fix Committed → Fix Released
Ara Pulido (ara) on 2014-07-04
Changed in oem-priority:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers