after upgrade to 1.14.0-2.1ubuntu0.1 0 dpkg --configure ror

Bug #941867 reported by zarquon42 on 2012-02-27
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
insserv (Ubuntu)
High
Unassigned
Lucid
High
Unassigned
Natty
High
Unassigned
Oneiric
High
Unassigned
sysvinit (Ubuntu)
High
Unassigned

Bug Description

Description: Ubuntu 11.10
Release: 11.10

Installed: 1.14.0-2.1ubuntu0.1
  Candidate: 1.14.0-2.1ubuntu0.1
  Version table:
 *** 1.14.0-2.1ubuntu0.1 0
        990 http://ie.archive.ubuntu.com/ubuntu/ oneiric-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1.14.0-2.1 0
        990 http://ie.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages

After upgrade to 1.14.0-2.1ubuntu0.1 0 from proposed, the following errors show up:
Setting up insserv (1.14.0-2.1ubuntu0.1) ...
mv: `/etc/rc0.d/S90halt' and `/etc/rc0.d/S90halt' are the same file
dpkg: error processing insserv (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 insserv
E: Sub-process /usr/bin/dpkg returned an error code (1)

Reverting to the version from oneiric/main solves the problem.

Kay Parker (kayparker) wrote :

got the same problem with natty/proposed.

zarquon42 (zarquon42) wrote :

ok - after distribution upgrade to precise beta1 - this wrecked the system: intiscripts cannot be configured due to the same error. And a lot of necessary packages remain unconfigurable. ....reinstalling

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in insserv (Ubuntu):
status: New → Confirmed

This same issue occurred on my upgrade to 12.04 beta 2.

Let the system unbootable with the new kernel because initrd wasn't there.

Booting an old kernel (11.10) left me with no (wireless) networking, and although X started, the mouse didn't work.

Fortunately I was able to unpack the initscripts package, add a '&' to the end of the 'mv' lines, rebuild and install that, then re-run apt-get upgrade.

The above is far beyond most users ability, who would be looking at a trashed laptop - I suggest we raise the fix priority !

Colin Watson (cjwatson) on 2012-03-31
Changed in insserv (Ubuntu):
importance: Undecided → High
assignee: nobody → Canonical Foundations Team (canonical-foundations)
alfredtrebouchet (alexwp) wrote :

Having the same problem:

mv: target `/etc/rc0.d/S90halt' is not a directory
dpkg: error processing insserv (--configure):
 subprocess installed post-installation script returned error exit status 1

update-rc.d: warning: resolvconf stop runlevel arguments (none) do not match LSB Default-Stop values (0 6)
Errors were encountered while processing:
 insserv

joe4379 (joe4379-n) wrote :

I have this issue on 11.10 without a release-upgrade.

Steve Langasek (vorlon) on 2012-04-14
Changed in insserv (Ubuntu Lucid):
status: New → Incomplete
status: Incomplete → Triaged
importance: Undecided → High
Changed in insserv (Ubuntu Natty):
status: New → Triaged
importance: Undecided → High
Changed in insserv (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → High
Steve Langasek (vorlon) on 2012-04-14
no longer affects: sysvinit (Ubuntu Lucid)
no longer affects: sysvinit (Ubuntu Natty)
no longer affects: sysvinit (Ubuntu Oneiric)
Changed in insserv (Ubuntu):
status: Confirmed → Invalid
Changed in sysvinit (Ubuntu):
status: New → Triaged
importance: Undecided → High
joe4379 (joe4379-n) wrote :

Upgrading to insserv_1.14.0-2.1ubuntu2 using the launchpad deb fixed it for me.

joe4379 (joe4379-n) wrote :

That is, the Precise version works for me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sysvinit - 2.88dsf-13.10ubuntu11

---------------
sysvinit (2.88dsf-13.10ubuntu11) precise; urgency=low

  * Only try to move links in /etc/rc{0,6}.d that match "S0*". LP: #941867.
 -- Steve Langasek <email address hidden> Fri, 13 Apr 2012 22:46:53 -0700

Changed in sysvinit (Ubuntu):
status: Triaged → Fix Released
Steve Langasek (vorlon) on 2012-04-16
Changed in insserv (Ubuntu Lucid):
status: Triaged → In Progress
Changed in insserv (Ubuntu Natty):
status: Triaged → In Progress
Changed in insserv (Ubuntu Oneiric):
status: Triaged → In Progress

Hello zarquon42, or anyone else affected,

Accepted insserv into lucid-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in insserv (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in insserv (Ubuntu Natty):
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

Hello zarquon42, or anyone else affected,

Accepted insserv into natty-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in insserv (Ubuntu Oneiric):
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

Hello zarquon42, or anyone else affected,

Accepted insserv into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Binson Fugz (nosniv1106) on 2012-04-17
Changed in insserv (Ubuntu):
status: Invalid → Confirmed
assignee: Canonical Foundations Team (canonical-foundations) → Binson Fugz (nosniv1106)
Changed in insserv (Ubuntu Lucid):
status: Fix Committed → Confirmed
assignee: nobody → Binson Fugz (nosniv1106)
Steve Langasek (vorlon) on 2012-04-17
Changed in insserv (Ubuntu Lucid):
status: Confirmed → Fix Committed
assignee: Binson Fugz (nosniv1106) → nobody
Changed in insserv (Ubuntu):
assignee: Binson Fugz (nosniv1106) → nobody
status: Confirmed → Invalid
Bartosz Kosiorek (gang65) wrote :

insserv from proposal works perfeclty for meon Lucid Lynx:

$ apt-cache policy insserv
insserv:
  Zainstalowana: 1.12.0-14
  Kandydująca: 1.12.0-14ubuntu0.2
  Tabela wersji:
     1.12.0-14ubuntu0.2 0
        500 http://pl.archive.ubuntu.com/ubuntu/ lucid-proposed/main Packages
 *** 1.12.0-14 0
        500 http://pl.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
a@a:~$ sudo apt-get install insserv
[sudo] password for a:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie... Gotowe
Sugerowane pakiety:
  bootchart
Następujące pakiety zostaną zaktualizowane:
  insserv
1 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 35 nieaktualizowanych.
Konieczne pobranie 69,2kB archiwów.
Po tej operacji zostanie dodatkowo użyte 8192B miejsca na dysku.
Pob: 1 http://pl.archive.ubuntu.com/ubuntu/ lucid-proposed/main insserv 1.12.0-14ubuntu0.2 [69,2kB]
Pobrano 69,2kB w 3s (20,6kB/s)
(Odczytywanie bazy danych ... 136181 plików i katalogów obecnie zainstalowanych.)
Przygotowanie do zastąpienia insserv 1.12.0-14 (wykorzystując .../insserv_1.12.0-14ubuntu0.2_i386.deb) ...
Rozpakowanie pakietu zastępującego insserv ...
Przetwarzanie wyzwalaczy dla man-db...
Konfigurowanie insserv (1.12.0-14ubuntu0.2) ...

a@a:~$ apt-cache policy insserv
insserv:
  Zainstalowana: 1.12.0-14ubuntu0.2
  Kandydująca: 1.12.0-14ubuntu0.2
  Tabela wersji:
 *** 1.12.0-14ubuntu0.2 0
        500 http://pl.archive.ubuntu.com/ubuntu/ lucid-proposed/main Packages
        100 /var/lib/dpkg/status
     1.12.0-14 0
        500 http://pl.archive.ubuntu.com/ubuntu/ lucid/main Packages

tags: added: verification-done-lucid
tags: added: verification-done
removed: verification-done-lucid verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package insserv - 1.12.0-14ubuntu0.2

---------------
insserv (1.12.0-14ubuntu0.2) lucid-proposed; urgency=low

  * Only try to move links in /etc/rc{0,6}.d that match "S0*". LP: #941867.

insserv (1.12.0-14ubuntu0.1) lucid-proposed; urgency=low

  [ Adam Stokes ]
  * Add 200_hide_insserv_on_ubuntu.patch: Move insserv out of system path
    to disuade package maintainers from invoking it directly. (LP:
    #858122)

  [ Evan Broder ]
  * Fix the shutdown sequence if it was broken by insserv being run at
    some point in the past.
 -- Steve Langasek <email address hidden> Fri, 13 Apr 2012 22:08:39 -0700

Changed in insserv (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package insserv - 1.14.0-2ubuntu0.11.04.2

---------------
insserv (1.14.0-2ubuntu0.11.04.2) natty-proposed; urgency=low

  * Only try to move links in /etc/rc{0,6}.d that match "S0*". LP: #941867.

insserv (1.14.0-2ubuntu0.11.04.1) natty-proposed; urgency=low

  [ Adam Stokes ]
  * Add 200_hide_insserv_on_ubuntu.patch: Move insserv out of system path
    to disuade package maintainers from invoking it directly. (LP:
    #858122)

  [ Evan Broder ]
  * Fix the shutdown sequence if it was broken by insserv being run at
    some point in the past.
 -- Steve Langasek <email address hidden> Fri, 13 Apr 2012 22:07:25 -0700

Changed in insserv (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package insserv - 1.14.0-2.1ubuntu0.2

---------------
insserv (1.14.0-2.1ubuntu0.2) oneiric-proposed; urgency=low

  * Only try to move links in /etc/rc{0,6}.d that match "S0*". LP: #941867.

insserv (1.14.0-2.1ubuntu0.1) oneiric-proposed; urgency=low

  [ Adam Stokes ]
  * Add 200_hide_insserv_on_ubuntu.patch: Move insserv out of system path
    to disuade package maintainers from invoking it directly. (LP:
    #858122)

  [ Evan Broder ]
  * Fix the shutdown sequence if it was broken by insserv being run at
    some point in the past.
 -- Steve Langasek <email address hidden> Fri, 13 Apr 2012 22:07:04 -0700

Changed in insserv (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers