inkscape should recommend rather than suggest libgnomevfs2-extra

Bug #496223 reported by Georg Sauthoff on 2009-12-13
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned
inkscape (Debian)
Fix Released
Unknown
inkscape (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: inkscape

Hi,

using Ubuntu Karmic, the 'File -> Import From Open Clipart Library, Search' feature fails with:

Failed to receive the Open Clip Art Library RSS feed. Verify if the server name is correct in Configuration->Import/Export (e.g.: openclipart.org)

Under 'File -> Inkscape Preferences, Import/Export' there is this server configured:

openclipart.org

Looks like a regression from the fixed Bug #210336. Somebody commented there this regression in Karmic, too.

Didn't know, if I should reopen this bug, or open a new one (since the old one is fixed, and this one has a different cause).

Best regards

Related branches

Alex Valavanis (valavanisalex) wrote :

I've tested this in karmic with Inkscape 0.47~pre4-0ubuntu1, and everything seems fine. Which version of Inkscape are you using?

Georg Sauthoff (g-sauthoff) wrote :

I am using the same version.

Hm, I don't have gnome installed - ah, this gives me an idea:

$ inkscape

(inkscape:7711): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libhttp.so' (/usr/lib/gnome-vfs-2.0/modules/libhttp.so: cannot open shared object file: No such file or directory)

manually installing libgnomevfs2-extra fixes this problem.

Thus, the inkscape package should depend on libgnomevfs2-extra.

Btw, I noticed that the preview in the openclipart import dialog is broken for some pictures. To reproduce: Search for 'cpu' and then click on some images:

** Message: Gdk::PixbufError in SVGPreview::showImage
** Message: Gdk::PixbufError in SVGPreview::showImage
** Message: Gdk::PixbufError in SVGPreview::showImage

are printed to the console ...

jazzynico (jazzynico) on 2009-12-30
tags: added: openclipart packaging
jazzynico (jazzynico) wrote :

Since this is a packaging issue, I close this bug in Inkscape project.

I can't reproduce the second issue (PixbufError) on Ubuntu 9.10, Inkscape 0.47pre4 and latest dev version.
Not sure it's related to OpenClipArt. Could you please open a separate report for this bug?
Thanks.

Changed in inkscape:
status: New → Invalid
Alex Valavanis (valavanisalex) wrote :

Confirming that removing libgnomevfs2-extra breaks the openclipart import search function. I think "depends" is a bit too much - inkscape can still run fine without this library (except for the missing OCAL functionality). "recommends" seems more appropriate.

summary: - inkscape open clipart import fails
+ inkscape should recommend rather than suggest libgnomevfs2-extra
Changed in inkscape (Ubuntu):
status: New → Confirmed
Alex Valavanis (valavanisalex) wrote :

Forwarded to Debian. Waiting for acknowledgment

Changed in inkscape (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in inkscape (Debian):
status: Unknown → New
Changed in inkscape (Ubuntu):
assignee: nobody → Jose Ernesto Davila (josernestodavila)
status: Triaged → In Progress
Changed in inkscape (Ubuntu):
status: In Progress → Confirmed
assignee: Jose Ernesto Davila (josernestodavila) → nobody
Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
Changed in inkscape (Ubuntu):
assignee: nobody → Nathan Williams (nathwill)
su_v (suv-lp) wrote :

> waiting on bug #946715

<quote from #946715>
in inkscape, if libgnomevfs2-extra is not installed, the import from openclipart.org will fail.
</quote #946715>

Note: in the next major stable Inkscape 0.49, the (just recently merged) new dialog for 'Import Clip Art…' will no longer depend on libgnomevfs2-extra (uses GIO instead as backend).
Packages based on the current stable release branch lp:inkscape/0.48.x still do though (there is one more bug-fix release planned before 0.49 gets out later this year, no ETA).

See also bug #734417 and the linked blueprint there.

in that case, seems like this should be fix committed?

Changed in inkscape (Ubuntu):
assignee: Nathan Williams (nathwill) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.3.1-0ubuntu2

---------------
inkscape (0.48.3.1-0ubuntu2) precise; urgency=low

  * promote libgnomevfs2-extra to recommends (lp: #496223)
 -- Nathan Williams <email address hidden> Tue, 06 Mar 2012 20:01:01 +0100

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
Changed in inkscape (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.