"wait-for-root" delay the boot for 25 seconds more than old "sleep"

Bug #498485 reported by Id2ndR on 2009-12-19
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: initramfs-tools

Version : Lucid
Cause of this behavior : upgrade initramfs-tools from 0.92bubuntu57 to 0.92bubuntu60

On my system (laptop Toshiba U200) there was no disk activity during 5 seconds after the kernel was loaded and then the system booted. With the upgrade of initramfs-tools there is no disk activity for 30 seconds and then the system boots. This happen with the new process wait-for-root that replace the old process sleep. Look at the bootchart for more information.

Architecture: i386
DistroRelease: Ubuntu 10.04
Package: initramfs-tools 0.92bubuntu60
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
ProcVersionSignature: Ubuntu 2.6.32-8.12-generic
Tags: lucid
Uname: Linux 2.6.32-8-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Id2ndR (id2ndr) wrote :
Id2ndR (id2ndr) wrote :

apport-collect data

description: updated
tags: added: apport-collected

This is the second invocation waiting for your swap device. Could you attach your /etc/initramfs-tools/conf.d/resume file for me?

Changed in initramfs-tools (Ubuntu):
status: New → Incomplete
Steve Magoun (smagoun) wrote :

This happens to me too. Looks like /etc/fstab and the resume file have the wrong UUID for the swap partition.

steve@steve-desktop:~$ cat /etc/initramfs-tools/conf.d/resume
RESUME=UUID=fec09290-454d-488c-a09e-18ad1eb6aeb8

steve@steve-desktop:~$ ls -l /dev/disk/by-uuid/
total 0
lrwxrwxrwx 1 root root 10 2009-12-21 06:36 61d94963-4e1c-44bf-ad22-e29ed5a9da30 -> ../../sda5
lrwxrwxrwx 1 root root 10 2009-12-21 06:36 697c52e3-a331-4f70-9a4d-74472baf3177 -> ../../sda6

steve@steve-desktop:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda6
UUID=61d94963-4e1c-44bf-ad22-e29ed5a9da30 / ext3 relatime,errors=remount-ro 0 1
# /dev/sda7
UUID=fec09290-454d-488c-a09e-18ad1eb6aeb8 none swap sw 0 0
/dev/sda5 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

steve@steve-desktop:~$ blkid
/dev/sda1: LABEL="Disk 1 Partition 1" TYPE="ntfs"
/dev/sda5: UUID="61d94963-4e1c-44bf-ad22-e29ed5a9da30" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda6: UUID="697c52e3-a331-4f70-9a4d-74472baf3177" TYPE="swap"

steve@steve-desktop:~$ sudo sfdisk -l /dev/sda

Disk /dev/sda: 3738 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start End #cyls #blocks Id System
/dev/sda1 * 0+ 2933 2934- 23567323+ 7 HPFS/NTFS
/dev/sda2 2934 3737 804 6458130 f W95 Ext'd (LBA)
  end: (c,h,s) expected (1023,254,63) found (665,254,63)
/dev/sda3 0 - 0 0 0 Empty
/dev/sda4 0 - 0 0 0 Empty
/dev/sda5 2934+ 3671 738- 5927953+ 83 Linux
/dev/sda6 3672+ 3737 66- 530113+ 82 Linux swap / Solaris

Steve Magoun (smagoun) wrote :

I corrected the UUID of the swap partition in /etc/fstab and /etc/initramfs-tools/conf.d/resume so it matched the UUID reported by blkid. Then I ran update-initramfs. After these changes, the long delay is gone.

Id2ndR (id2ndr) wrote :

I can confirm that the UUID wasn't correct in my resume file too. I corrected it and the delay is gone.

fabien@fabien-laptop:~$ cat /etc/initramfs-tools/conf.d/resume
RESUME=UUID=1514290c-5be2-4ef4-8e32-b7e0acef12ea
fabien@fabien-laptop:~$ grep swap /etc/fstab
# swap was on /dev/sda6 during installation
UUID=37c7d142-f044-470a-8277-4294daf6a942 none swap sw 0 0
fabien@fabien-laptop:~$ sudo vim /etc/initramfs-tools/conf.d/resume
fabien@fabien-laptop:~$ sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-2.6.32-9-generic

Eddie Hung (eddieh) wrote :

Roger that for me too. I just upgraded from Karmic using update-manager -d a few days ago, so maybe there's something wrong in the install procedure.

Steve Magoun (smagoun) wrote :

FWIW, my system started out as Hardy. I upgraded H->I->J->K->L. I don't recall ever having touched /etc/fstab and certainly never touched /etc/initramfs-tools/conf.d/resume.

Changed in initramfs-tools (Ubuntu):
status: Incomplete → Confirmed
Sebastian Geiger (lanoxx) wrote :

i just checked any i had this error too, bot in the resume file and in fstab there were wrong swap uuids (i compared the values to /dev/disk/by-uuid, and corrected them)
this was probably my own fault since i repartitioned a few times and also recreated the swap file, but still i guess there should be something that notifies the user, maybe a check could be integrated into the computer janitor?

Sebastian Geiger (lanoxx) wrote :

to confirm my last post, the delay is now gone. at first i forgot to run:
sudo update-initramfs -u
now it works and here is the difference:
Before: http://img203.imageshack.us/img203/3951/marslucid201004281.png
After: http://img530.imageshack.us/img530/337/marslucid201004284.png

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers