There is no vfat module in the 2.6.24-17 initrd

Bug #236021 reported by cato on 2008-05-30
22
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Evan
Hardy
Undecided
Evan

Bug Description

The initramfs lacks vfat support. This means that Wubi users coming from a FAT Windows partition will be able to install (casper has vfat), but they will be left with an unbootable system at the first update-initramfs.

TEST CASE:
Install Ubuntu using Wubi on a Windows FAT partition and install all available updates. Reboot and you will be presented with an initramfs prompt.

A debdiff of the proposed upload can be found here:
http://launchpadlibrarian.net/14826146/initramfs-tools-0.39-0.39.1.debdiff

Agostino Russo (ago) wrote :

Based on a very quick code scan, I believe that this is an old bug never discovered rather than a recent regression (now that I think of it, I did see other people in the past unable to mount from vfat after kernel upgrade).

The initrd in the live cd explicitly adds vfat via casper hooks:

./hooks/casper:manual_add_modules vfat

but the same does not hold for regular initramfs-tools.

In particular, there is no vfat reference in initramfs-tools/hook-functions auto_add_modules>base and dep_add_modules. So when a new initramfs is generated there is no vfat.

Changed in initramfs-tools:
status: New → Confirmed
Agostino Russo (ago) wrote :

One way to address this is to add vfat to initramfs-tools/hook-functions

--- hook-functions 2008-05-30 14:04:09.000000000 +0100
+++ hook-functions.ago 2008-05-30 14:04:41.000000000 +0100
@@ -207,7 +207,7 @@
        base)
                for x in ehci-hcd ohci-hcd uhci-hcd usbhid usb-storage ext2 \
                ext3 isofs jfs nfs reiserfs udf xfs af_packet atkbd i8042 \
- virtio_pci; do
+ virtio_pci vfat; do
                        manual_add_modules "${x}"
                done
        ;;

Another way is to add a hook (/usr/share/initramfs-tools/hooks/vfat) via lupin-support that makes sure that vfat gets into the initrd.

=======/usr/share/initramfs-tools/hooks/vfat===========
#! /bin/sh -e

PREREQ=""

prereqs () {
    echo "$PREREQ"
}

case $1 in
prereqs)
    prereqs
    exit 0
    ;;
esac

. /usr/share/initramfs-tools/hook-functions

manual_add_modules vfat

exit 0

Agostino Russo (ago) wrote :

Colin, Evan, I cannot generate debdiffs at the moment and/or test the patches, but I would appreciate if you could check/test/release one of the above (or similar) patches as a matter of urgency as I expect a lot of users to be affected by this (all vfat wubi users will end up in busybox after kernel upgrade).

Colin Watson (cjwatson) on 2008-05-30
Changed in initramfs-tools:
assignee: ago → evand
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.85eubuntu40

---------------
initramfs-tools (0.85eubuntu40) intrepid; urgency=low

  * Add vfat support to the initramfs (LP: #236021).

 -- Evan Dandrea <email address hidden> Fri, 30 May 2008 12:50:50 -0400

Changed in initramfs-tools:
status: Confirmed → Fix Released
Evan (ev) on 2008-05-30
Changed in initramfs-tools:
assignee: nobody → evand
milestone: none → ubuntu-8.04.1
status: New → Confirmed
Evan (ev) wrote :
Changed in initramfs-tools:
status: Confirmed → Fix Committed
description: updated
description: updated
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

cato (catonano) wrote :

I'm the one who opened this bug report.

Is a test on my side supposed to be taken as good ?

Sorry for the dumb question, this is the first time a take part into such a process.

Tha's because I tested the proposed patch.

1) I booted with the 2.6.24-16 kernel
2) I changed the row no. 210 ( I think) in the /usr/share/initramfs-tools/hook-functions file and switched from

virtio_pci; do

to

virtio_pci vfat ... etc (as in the patch)... ; do

3) I rebuilt the initramfs image
4) booted with the 2.6.24-17 kernel

it works ! I'm in the 2.6.24-17 right now !

Thanks so much, people !
Bye
Cato

Martin Pitt (pitti) wrote :

Thanks for testing! Indeed, verification by the bug submitter is heavily appreciated.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in initramfs-tools:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers