Bug in upgrade 2.6.24-17-31-generic for UBUNTU 8.04

Bug #236932 reported by Szabó András on 2008-06-02
4
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Unassigned

Bug Description

 After installing Ubuntu 8.04 with wubi-8.04.exe on D: partition, near
 an XPHome on Fat 32, it works perfectly (2.6.24-16-generic), starts
 with usual login (name and password) and successfully can be used.

 After recently upgrading to 2.6.24-17-31-generic and rebooting does
 not offers the usual login (name and password) but appears a black
 screen and the following text on it:

 BusyBox v1.1.3 (Debian 1:1.1.3-5ubuntu12) Built-in shell (ash)
 Enter 'help' for a list of built-in commands.
 (initramfs)

Now any command found in the help list of commands, even if with correct
 syntax as red from the BusyBox documentation nothing happens but
 a text appears: command can not find, etc.

 I can not stop this shell to continue with the log-in procedure!
 Ctrl-Alt-Del gets me back to reboot and all happens again, except,
 when I press ESC and select the 2.6.24-16-generic instead of 17-gen.
 After these operation I can log-in and use the system.
 This behaviour is not user friendly, specially to unskilled users who
 do not know how to act and never wants to use terminal like
 commands, only the graphic shell!!!!

Is this a possible bug or it could be intentional? (This last option is not in
 accordance with the indicated Ubuntu project aims.)

The noticed behaviour is when after the prompt that is (initramfs) I write:
'busybox exit' it answers with: 'there is no or missing applet'
and waits an other command. Hi! If commands starts with 'busybox' always
there is the same answer and, if only a command is given according to the
busybox syntax the answer always command not found.
The circle is closed!

András Szabó
<email address hidden>

Thomas Kluyver (takluyver) wrote :

Best guess bug filing

I'm afraid you may not find it easy to get help for this, if, as I suspect, it's related to wubi. Wubi is a relatively new thing, and I suspect that much of the community is running Linux the conventional way, without using Windows. But good luck nonetheless.

Colin Watson (cjwatson) wrote :

This is probably the lack of vfat in the initramfs, for which a fix is in progress.

Colin Watson (cjwatson) wrote :

(Oh, and of course this is a bug, not intentional!)

Szabó András (szabo-a-a-g) wrote :

Bug in upgrade to 2.6.24-17-generic & to 2.6.24-18-generic in UBUNTU 8.04

Hi everybody,

Long time nobody answered this problem up to now.
First of all, thanks for the comments!

Finally, I started both kernel versions in recovery mode and I could find out the reason of the problem without finding the solution.

There were in both cases the same failure report:

Begin: Running /scripts/local-premount
mount: Mounting /dev/disk/by-uuid/9068-E8C6
    on /root failed: no such device
mount: Mounting /root on /host failed: invalid argument
ALERT! /host/ubuntu/disks/root.disk does not exists.
   Dropping to a shell!

BusyBox v1.1.3 (Debian 1:1.1.3-5ubuntu12) Built-in shell (ash)
 Enter 'help' for a list of built-in commands.
 (initramfs)

When checked the HDD D:\ partition under Windows or
under Ubuntu (running in grub the kernel 2.6.24.16-generic
instead of the two unoperable ones of 17 and 18 gen.)
I found there the ubuntu and all the claimed subdirectories
and the disks that were not found by the 17 and18 kernels.

Possibly, during the upgrade with dpkg one of the configuration
files were wrong due to a bug and when started the 'ash' shell it
could not work and react to any command because of the missing
necessary 'background' virtual disk contents. This is why the
BusyBox did not give a correct response and I could not achieve to exit.

What can be and where to find the wrong script or configuration file to repair.
Maybe, one of you give me the answer, but I am unable to correct
the corresponding init.rd file if it is the responsible.

I tried to correct the problem writing into the terminal the followings:

 sudo dpkg --clear-avail && sudo apt-get update
and
 sudo dpkg --configure -a

Nothing happened.

In the /boot/grub/menu.lst I found:

title Ubuntu 8.04, kernel 2.6.24-17-generic
root (hd0,4)/ubuntu/disks
kernel /boot/vmlinuz-2.6.24-17-generic root=UUID=9068-E8C6 loop=/ubuntu/disks/root.disk ro single
initrd /boot/initrd.img-2.6.24-17-generic

title Ubuntu 8.04, kernel 2.6.24-16-generic
root (hd0,4)/ubuntu/disks
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=9068-E8C6 loop=/ubuntu/disks/root.disk ro quiet splash
initrd /boot/initrd.img-2.6.24-16-generic

The above is the same in case of kernel 2.6.24-18-generic.

Maybe somebody corrects the problem and this short
description of the failure report will help to find the bad spot.

Thanks again and, until the problem has been solved i am using
the kernel 2.6.24-16-generic.

By the way! Can I delete the useless parts and files installed
and how?

András Szabó

Agostino Russo (ago) wrote :

The fix has been released and the new initramfs-tools packages should be ok

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers