Comment 0 for bug 1496163

On Skylake, the skl_dmc firmware is failing to load. From dmesg:

[ 0.728803] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1.bin failed with error -2
[ 0.728817] [drm:i915_firmware_load_error_print [i915]] *ERROR* failed to load firmware i915/skl_dmc_ver1.bin (0)

This means the GPU can't enter its lowest available power states, plus many display hotplugging scenarios (that only the skl_dmc firmware can handle) are broken.

On a whim I tried some other firmware versions:

1) pointed the skl_dmc_ver1.bin symlink to skl_dmc_ver1_18.bin (instead of skl_dmc_ver1_19.bin)

2) downloaded the latest (skl_dmc_ver1_21.bin) and pointed the skl_dmc_ver1.bin symlink to it

But neither corrected the situation.

Thanks!

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: linux-image-4.2.0-10-generic 4.2.0-10.11
ProcVersionSignature: Ubuntu 4.2.0-10.11-generic 4.2.0
Uname: Linux 4.2.0-10-generic x86_64
ApportVersion: 2.18.1-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: oem 1251 F.... pulseaudio
CurrentDesktop: Unity
Date: Tue Sep 15 16:21:24 2015
HibernationDevice: RESUME=UUID=637df075-0afa-420f-a3ca-342be8bf297f
IwConfig:
 enp4s0 no wireless extensions.

 lo no wireless extensions.
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 04f2:0833 Chicony Electronics Co., Ltd
 Bus 001 Device 002: ID 046d:c05a Logitech, Inc. M90/M100 Optical Mouse
 Bus 001 Device 004: ID 058f:6364 Alcor Micro Corp. AU6477 Card Reader Controller
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: System manufacturer System Product Name
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-10-generic root=UUID=f967534a-9cc3-4d1a-a7f3-72d28959e3c6 ro i915.verbose_state_checks=1 quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.2.0-10-generic N/A
 linux-backports-modules-4.2.0-10-generic N/A
 linux-firmware 1.147
RfKill:

SourcePackage: linux
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/19/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0403
dmi.board.asset.tag: Default string
dmi.board.name: Z170-P D3
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0403:bd08/19/2015:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnZ170-PD3:rvrRevX.0x:cvnDefaultstring:ct3:cvrDefaultstring:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer