unable to read /tmp/mkinitramfs_*

Bug #1075422 reported by dino99 on 2012-11-06
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Debian)
Fix Released
Unknown
initramfs-tools (Ubuntu)
High
Dimitri John Ledkov

Bug Description

Raring i386 testing (dpkg 1.16.9ubuntu1)

For the new kernel installation from kernel-ppa, i'm downloading the required debs into an empty folder where i can then run dpkg -i from there.

Here is the warning i get while installing a kernel:

....
update-initramfs: Generating /boot/initrd.img-3.6.6-030606-generic
WARNING: could not open /tmp/mkinitramfs_kG4Wwd/lib/modules/3.6.6-030606-generic/modules.builtin: No such file or directory
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.6.6-030606-generic /boot/vmlinuz-3.6.6-030606-generic
....

Then the installation seems to end normally.

dino99 (9d9) on 2012-11-06
description: updated
tags: added: i386 raring
Raphaël Hertzog (hertzog) wrote :

This is not a dpkg bug but one that is triggered by update-initramfs from initramfs-tools. Thus reassigning.

affects: dpkg (Ubuntu) → initramfs-tools (Ubuntu)
Dimitri John Ledkov (xnox) wrote :

This is a known bug, fixed in debian.
Please cherry-pick the patch... or complete the initramfs-tools merge.

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
dino99 (9d9) wrote :

Hopes you devs find the time to fix this error. Tried the latest 310.19 from edgers ppa, but still get this issue:

update-initramfs: Generating /boot/initrd.img-3.7.0-030700rc5-generic
modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
Aborted (core dumped)
WARNING: could not open /tmp/mkinitramfs_iuhZhv/lib/modules/3.7.0-030700rc5-generic/modules.builtin: No such file or directory

dino99 (9d9) wrote :

debbugs #659866 : Bug is archived. No further changes may be made.

dino99 (9d9) wrote :
Changed in initramfs-tools (Debian):
status: Unknown → Fix Released
Changed in initramfs-tools (Ubuntu):
importance: Undecided → High
assignee: nobody → Dmitrijs Ledkovs (xnox)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.103ubuntu0.4

---------------
initramfs-tools (0.103ubuntu0.4) raring; urgency=low

  * [71ece149] Cherry pick mkinitramfs: Copy modules.builtin into initramfs
    (Closes: #659866) (LP: #1075422).
 -- Dmitrijs Ledkovs <email address hidden> Tue, 04 Dec 2012 11:51:05 +0000

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.