keyboard doesn't work to enter password with encrypted partitions ubuntu 13.10 saucy

Bug #1238194 reported by Felix Moreno on 2013-10-10
302
This bug affects 60 people
Affects Status Importance Assigned to Milestone
initramfs-tools
Undecided
Unassigned
initramfs-tools (Ubuntu)
Critical
Unassigned
Precise
Undecided
Unassigned
Saucy
Critical
Unassigned

Bug Description

[Justification]
With the kernel in 13.10, some systems use a different USB host driver than previously. Failing to include this driver in the initramfs causes regressions for users who need to interact with the system in early boot using a USB keyboard, such as users with an encrypted root filesystem. Such systems are not bootable with this host driver missing.

[Test case]
1. On an affected system, reboot to a kernel from 13.04.
2. Install the initramfs-tools package from -proposed.
3. Reboot to the kernel from 13.10.
4. Verify that you are able to type your passphrase at the prompt in the initramfs.

[Regression potential]
Minimal. The update-initramfs script will ignore missing modules (such as the many other modules in the list which are built-ins), and the only change made is to copy the module into the initramfs: it will only be loaded in the initramfs if udev determines it's needed, just as it would load it after switching to the root filesystem.

Is the same problem as here but in the new ubuntu 13.10 saucy https://bugs.launchpad.net/bugs/1066376

I just can't use (i can install) a encrypted partition because when is time to introduce the password to unlock partition keyboard is not working.

I don't know how to edit a bug to report it afects other version of ubuntu so i created this new bug...

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
tags: added: regression-release regression-update
tags: added: ubuntu-bug
tags: added: 13.10 ubuntu
tags: added: saucy
summary: - keyboard doesn't work to enter password with panda and encrypted
- partitions ubuntu 13.10 saucy
+ keyboard doesn't work to enter password with encrypted partitions ubuntu
+ 13.10 saucy
description: updated
Steve Langasek (vorlon) on 2013-10-13
tags: removed: regression-release regression-update
Jacob Nielsen (j.nielsen) wrote :

Probably a duplicate: https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1239306

Adding the modules hid, usbhid, hid_generic, hid_logitech, hid_logitech_dj and mac_hid to /etc/initramfs-tools/modules and updating doesn't fix it.

On my Haswell-based laptop, which also runs Saucy, the same keyboard works fine pre-boot. But if I move the laptop disk to my desktop it doesn't anymore. (The desktop mainboard is an old Biostar ta690g.)

Jacob Nielsen (j.nielsen) wrote :

Adding the module ohci_pci (and only that) to /etc/initramfs-tools/modules and updating fixed it in my case.

Felix Moreno (felix-justdust) wrote :

Jacob My problem is that the partition is encrypted so i can't enter in a functional ubuntu to edit, do you know if is possible to edit this file only in the boot time?

Jacob Nielsen (j.nielsen) wrote :

From a live CD you should be able to open your encrypted root, then set up a chroot there and update the initramfs on the boot partition. Will take a bit of googling...

Antti Haapalahti (girstu) wrote :

Samo problem, Added

hid
usbhid
hid_generic
ohci_pci

to

 /etc/initramfs-tools/modules
and did update-initramfs -u

that worked for me.

Mahiar Mody (mahiarmody) wrote :

I installed Ubuntu 13.10 (Saucy Salamander) today using the "64-bit PC (AMD64) desktop image". However, after the reboot, my wireless keyboard was not detected and so could not enter the pass-phrase to continue booting Ubuntu.

So forced to revert back to Ubuntu 13.04, which does not have this issue.

Richard Laskey (rlaskey) wrote :

This one hit me when I upgraded from 13.04. Really bad bug. I am lucky enough to have a PS/2 keyboard on hand where the system is installed, so I can get in just fine via that. Used to work perfectly in 13.04, and 12.10.

I had used the option to encrypt the entire system from the 12.10 installer, haven't been messing with it since. Wired USB keyboard does not work, to include not lighting up nor any sort of activity. Keyboard does work after that step, when booting the rest of the OS.

Took me a while to find this bug, too, and considering it can lock people out of their systems, there may be many more who have experienced this than have reported it here.

Would be happy to send across any files or details that may be of assistance.

brandon smith (tofutuxx) wrote :

Jacob Nielsen (j.nielsen) wrote on 2013-10-17: #3
Adding the module ohci_pci (and only that) to /etc/initramfs-tools/modules and updating fixed it in my case.

Worked for me. Loaded a previous kernel in recovery mode to add. Thanks Jacob.

lbausch (lbausch) wrote :

Also tried the solution provided by Jacob Nielsen, worked for me and I'm finally able to use my system again. Used an older kernel (3.8) to boot and executed "sudo update-initramfs -u" after modifying /etc/initramfs-tools/modules with the additional line "ohci_pci".

Plecton (northend) wrote :

Same probelm after update.

I cleaned up all the earlier kernels because the space on my /boot partition was limited, so I was unable to use an earlier kernel. I had to download a LiveCD of Ubuntu 13.10 and boot it. Then I used cryptsetup to decrypt my existing hdd rootfs partition, and mount all LV partitions to a temporary folder. Next I setup the system mounts (dev, sys, proc, etc), and chroot-ed to the temporary folder. Then I edited the /etc/initramfs-tools/modules file with nano, added "ohci_pci" to it at the bottom, saved, and called "update-initramfs -u". Finally I unmounted and rebooted.

It worked.

People using pre-boot authentication might also want to modify the cryptsetup hook script. Go to the /usr/share/initramfs-tools/scripts/local-top/ folder and edit a file called "cryptroot". Find a line that says something like cryptkey = "Unlocking disk bla bla bla...\nEnter passphrase: " and change it to look like this:
cryptkey="Enter passphrase: "

This will remove the annoying UUID text from the auth screen on boot. You will instead see only a single line that says "Enter passphrase: ". Much cleaner.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.103ubuntu2

---------------
initramfs-tools (0.103ubuntu2) trusty; urgency=low

  * Include usbhid in the list of modules we probe in the panic function,
    since we may panic before udev runs and most keyboards are USB these
    days. Closes: #229732.
  * Add ohci_pci to the list of USB host modules included in the initramfs,
    needed on some systems and not a built-in driver in Ubuntu.
    LP: #1238194.
 -- Steve Langasek <email address hidden> Thu, 24 Oct 2013 13:40:43 -0700

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Fix Released
Steve Langasek (vorlon) on 2013-10-24
Changed in initramfs-tools (Ubuntu):
importance: Undecided → Critical
Changed in initramfs-tools (Ubuntu Saucy):
importance: Undecided → Critical
status: New → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in initramfs-tools (Ubuntu Precise):
status: New → Confirmed

Hello Felix, or anyone else affected,

Accepted initramfs-tools into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/initramfs-tools/0.103ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in initramfs-tools (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) on 2013-10-25
description: updated
Jacob Nielsen (j.nielsen) wrote :

The fix works for me:

* Restored /etc/initramfs-tools/modules to the original state (no active lines) and updated the initramfs
* Rebooted with break on the kernel line, no working keyboard as expected
* Enabled saucy-proposed and pinned it as per the wiki
* Installed initramfs-tools/saucy-proposed and got version 0.103ubuntu1.1 of initramfs-tools and initramfs-tools-bin
* Updated the initramfs
* Rebooted with break on the kernel line, keyboard is functional

tags: added: verification-done
removed: verification-needed
Neelson (nmahene) wrote :

I went throught the test case as described and installed version 0.103ubuntu1.1 and without noticing a newer kernel 3.11.-13 from proposed. It works with 3.11-13 but it still not with the current stable kernel 3.11-12, still no keyboard input in cryptsetup.

Adam Conrad (adconrad) wrote :

Hello Felix, or anyone else affected,

Accepted initramfs-tools into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/initramfs-tools/0.99ubuntu13.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in initramfs-tools (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
tags: added: verification-done-saucy
Felix Moreno (felix-justdust) wrote :

Hello, I hope this patch will be include in the ubuntu 13.10 cd image, or at least when installing if you click in download updates.

If is not, people will not be able to try or install ubuntu with encrypted partitions.

ps: To test it, how can I do it if after installing and creating encrypted partition i cant enter in to ubuntu to enable the proposal packets?? If somebody tell me how, I will test it. Bests.

c-m-l (c-m-l) wrote :

initramfs-tools 0.103ubuntu1.1 fixed the problem for me with kernel 3.11-12 (Saucy).

Rui Simoes (rms1979) wrote :

I continue with the same problem.

Rui Simoes (rms1979) wrote :

I have my system up to date with the last initramfs and kernel but the issue continue.

I dont have encripted partirions

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of initramfs-tools from saucy-proposed was performed and bug 1246771 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1246771 "bot-stop-nagging". Thanks!

tags: added: verification-failed
bluebomber (bluebomber) wrote :

Will someone please "explain to me like I'm 5 (in computer years)" why this was necessary? What's going on? When I upgraded to 13.10, my keyboard stopped working completely after GRUB, and I'm left an "(initramfs)" prompt without a working keyboard. I had to boot an older kernel (thank goodness I had one!), append "ohci_pci" to /etc/initramfs-tools/modules, then run "update-initramfs", and I don't know anything about what any of those steps do, what ohci_pci is, what initramfs is, or why these steps were required.

Thanks!

tags: removed: verification-failed
Keith Finnie (keith-finnie) wrote :

I ran into the same problem with my keyboard non-functional after upgrading from 13.04 to 13.10, with encrypted boot filesystem. Appending ohci_pci to /etc/initramfs-tools/modules and invoking update-initramfs -u resolved my problem. I feel lucky as having the older kernel still available made this relatively easy to execute. That and having my tablet available (while my ubuntu computer was unusable) to hunt up this bug reference to find a solution.

Pär Lindfors (paran) wrote :

After upgrading to saucy my system was unbootable due to this bug. initramfs-tools 0.103ubuntu1.1 fixed the problem for me.

Pär Lindfors (paran) wrote :

Why is this bug listed as affecting Precise? I don't see any comments in this bug, or any of the duplicates, that mentions anything other than hitting this after installing or upgrading to saucy.

I certainly did not have this bug in precise which I was running until a few weeks ago. I then upgraded to quantal, then to raring and finally to saucy and only got this bug on saucy.

Mahiar Mody (mahiarmody) wrote :

Is this patch included in the ubuntu 13.10 iso cd image? If not, when is it likely to be included?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.103ubuntu1.1

---------------
initramfs-tools (0.103ubuntu1.1) saucy; urgency=low

  * Add ohci_pci to the list of USB host modules included in the initramfs,
    needed on some systems and not a built-in driver in Ubuntu.
    LP: #1238194.
 -- Steve Langasek <email address hidden> Thu, 24 Oct 2013 15:33:27 -0700

Changed in initramfs-tools (Ubuntu Saucy):
status: Fix Committed → Fix Released
Stéphane Graber (stgraber) wrote :

This change is needed in precise too because of the backport of the kernel stack which will cause the same problem there in the next point release. It'd be great if someone could test the package there too.

Jacob Nielsen (j.nielsen) wrote :

Tested on precise (12.04.3): Installing linux-generic-lts-saucy (3.11.0-14) broke the keyboard in busybox; installing initramfstools/proposed (0.99ubuntu13.4) then fixed it again.

Felix Moreno (felix-justdust) wrote :

I just reupgraded from 13.04 to 13.10 and now it works, I can use keyboard to uncrypt the hard drive, good.

tags: added: verification-done-precise
removed: verification-needed
Mahiar Mody (mahiarmody) wrote :

Felix did you have to do anything special at the time of upgrading? Or was it just like upgrading normally? Did you have to enable the installing of Saucy proposed packages? Did you choose to download updates as well?

Please let me know. Thank you.

Felix Moreno (felix-justdust) wrote :

Nothing, just upgrade from 13.04 to 13.10, I saw while upgrading that kernel 3.11.13 was installed that seems the one fixed with the initramfs... I don't know what would happen if you download a cd-image, but upgrading works now in the same computer that didn't.

Felix Moreno (felix-justdust) wrote :

ps: I did not enable the proposed packages.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.99ubuntu13.4

---------------
initramfs-tools (0.99ubuntu13.4) precise; urgency=low

  * Add ohci_pci to the list of USB host modules included in the initramfs,
    needed on some systems and not a built-in driver in Ubuntu.
    LP: #1238194.
 -- Steve Langasek <email address hidden> Thu, 24 Oct 2013 23:47:17 -0700

Changed in initramfs-tools (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Mahiar Mody (mahiarmody) wrote :

Thanks for your reply Felix.

Yesterday, I too updated from Raring (13.04) to Saucy (13.10 ) without specifying saucy proposed or raring proposed and the update happed successfully. After the update, upon reboot, the wireless keyboard was detected ok and I could enter the password for the encrypted partion.

On a separate note, attempting to install from the Saucy ISO CD image fails even when "Download updates" is selected. Perhpas this could be because the package had not been released to -updates as detailed above by Stéphane Graber. So installing from Saucy ISO CD image with "Download Updates" selected might work from today. (I had tried installing from ISO image yesterday).

So, to install Saucy from an ISO CD Image, I first installed Raring (13.04) from the 13.04 ISO CD image, then download the 13.04 updates (without downloading the Raring updates, I kept getting errors while attempting to upgrade to Saucy), and then after the 13.04 updates were installed, I opted to upgrade to Saucy Salamander (13.10). All was ok from that point on.

pahnin (pahninsd) wrote :

I used to have this bug and I used the work around, to add 'ohci_pci' to initramfs modules file and updating the initramfs as quoted above multiple times.

Everything was smooth, but after recent update, today, my wireless keyboard did not work while I was trying to enter password for my encrypted hard disk.

But I accidentally found out when I was in recovery mode that after some time,
it detected the wirless adapter and keyboard started working,
but it took more than 2,3 mins for the kernel to detect the wireless keyboard.

Just posting this because someone else might find this useful, and if its a bug that can be fixed.

I am also affected by this bug on my LG R400 laptop and neither the current release of initramfs-tools nor adding ohci_pci or other possible parameters solved the problem. I still have to use older kernels in order to be able to type disk encryption password. New kernels cannot activate the keyboard.

Current initramfs-tools version: 0.103ubuntu1.1

Dave (dlgawley) wrote :

Fix needs to be added to the Ubuntu 14.04 amd64 server daily builds as well. Once you start the install it no longer recognized the USB keyboard (IDRAC6 Enterprise KVM keyboard) on Dell PowerEdge Servers.

GoldenBunip (james-medcalf) wrote :

Downloaded the latest version from the site today and this is STILL an issue. Makes setting up a simple box with encryption impossible on a system that only has USBs. Makes for a very bad user experience right from the start, as I have to reinstall all over again and leave off ANY security.

David Reiss (davidn) wrote :

I'm running into this on 13.04 (upgraded from 12.10). I can boot into the old 3.5.0 kernel, but 3.8.0 and any newer kernels don't work (and I've tried an assortment from the mainline ppa).

I've also tried adding all the mentioned modules to /etc/initramfs-tools/modules, and none of that works either.

I'd like to upgrade to a newer kernel. I'd consider doing a release upgrade to 13.10, except based on the comments here, it doesn't sound like that would fix anything.

My keyboard is a "17ef:6009 Lenovo ThinkPad Keyboard with TrackPoint" (attached to a desktop machine).

Does anyone have any ideas for how I can use a newer kernel or ubuntu release with this system (besides reinstalling without full-disk encryption)?

Anatoli (anatoli) wrote :

In my case it was not enough to add ohci_pci, it was also necessary to add hid_logitech and hid_logitech_dj (my keyboard was Logitech wireless). I also added (just in case) hid_microsoft, hid_apple and mac_hid. This fixed the problem.

I hit that bug with 14.04 Final Beta. Both keyboard and mouse are not working --- cannot login.

Michael M. Rach (michael-rach) wrote :

I am running 13.10 as a virtual host on a HP Proliant Mini Server. When I upgrade to linux-image-3.11.0.19-generic, the USB mouse and keyboard and the network drivers no longer function. I can enter the Grub boot screen and if I boot using kernel ...18 everything works.

everflux (tklaunchpad) wrote :

Please verify that you have the "-extras" package for your kernel installed. At least for me it fixed the issue.

vak (khamenya) wrote :

Microsoft Natural Ergonomic Keyboard 4000 is also not responding in initrd/initramfs phase in Ubuntu 14.04.

I've added:

hid
usbhid
hid_generic
ohci_pci

to

 /etc/initramfs-tools/modules

and did update-initramfs -u

It did NOT help.

josh1986 (josh1986) wrote :

I have Microsoft Natural Ergonomic Keyboard 4000 too. And I cant solve this problem on Ubuntu 14.04, 14.10 and even 15.04

cnceo (cnceo) wrote :

I'm having this Problem in 14.10 after upgrading the kernel. My keybord is a Microsoft Wired Keyboard 600. Adding any of the suggested moduls (even hid_microsoft) did not solve the problem.

The only workaround for me is to hit reset on my computer to get a grub menu, afterwards I'm getting the text-based interface, where my keyboard works and I can enter the passphrase...

Peter Ruibal (fmoo) wrote :

I'm getting bit by this (or something very similar to this) after upgrading from 14.10 to 15.04.

Happy to provide any debug logs, run experimental packages, etc.

Brian Murray (brian-murray) wrote :

@Peter - please open a new bug report using "ubuntu-bug plymouth".

Philipp (san03) wrote :

@Peter:

I had the same issue after upgrading to 15.04. and this kernel module solved it. Maybe it helps in your case as well?

I added

hid-logitech-hidpp
to
 /etc/initramfs-tools/modules

then
sudo update-initramfs -u

as described here: http://askubuntu.com/questions/613139/ubuntu-15-04-usb-devices-powered-off-at-encrypted-root-password-prompt

Victor (aie0-com) wrote :

Happens for me also in Ubuntu 14.04.2 on laptop lenovo 410S

Rodrigo (rodri84cels) wrote :

Happens to me too, Ubuntu 15.04 on lenovo t450s

After the kernel update to 3.19.0-30, the keyboard doesn't work, if I select the 3.19.0-28 it works.

dreh23 (johannes-amorosa-7) wrote :

Happens to me as well. Same setup as Rodrigo.

Lenovo t450s and Ubuntu 15.04. kernel 28 works and 30 not.

Silicomancer (private-g) wrote :

Same here with Kubuntu 15.10 and a Toshiba Satellite Pro.

I don't have a workaround yet.

I am also struck by this using 14.04 and full disk-encryption.

Adding

hid
usbhid
hid_generic
ohci_pci

to the /etc/initramfs-tools/modules did NOT help either. I only have keyboard on grub menu, yet cannot use my external keyboard nor mouse after that stage.

Kevin Lyda (lyda) wrote :

I'm experiencing the same problem on a 14.04 system. It can't find it's root partition which is on lvm. When it drops to an initramfs shell the keyboard fails to work; the keyboard did work at the grub menu. I've tried most of the workarounds here and so far none work.

Kind of annoying really.

tsde (havetobeunknown) wrote :

I'm facing the exact same issue on HP EliteBook 850 G2. I use Ubuntu 15.04 and I'm stuck with using kernel 3.19.0-28. Each time I try to use a more recent kernel, I can't use any keyboard when prompted for my encryption password.

This is REALLY annoying. Any feedback on this one ?

james campbell (e-y) wrote :

Experiencing the same issue on 14.04 LTS (3.13.0-34-generic) when visualizing via Xen. Using full disk encryption and am unable to use the keyboard to enter the decryption pass phrase from Xen Center Console.

Anonymous (reason) wrote :

also try the line

hid-rmi

for Razer Blade model computers. Cheers~

Floyd42 (axelheider) wrote :

I'm seeing a similar behavior after the upgrade to 3.19.0-32-generic #37~14.04.1-Ubuntu on both a Dell 2570 and 8570 Notebook. Logitech Keyboard works fine in grub, but password entry for disk encryption does no longer works. Have to use the notebook keyboard for this.

Floyd42 (axelheider) wrote :

Seem this is a happening somewhere else also, see https://bugzilla.redhat.com/show_bug.cgi?id=1204392

Teemu Toivola (vergo) wrote :

I encountered this issue while using a "Lenovo ThinkPad Compact USB" keyboard with 3.19.0-33-generic. For this keyboard and most likely many recent Lenovo Thinkpads the correct module that needs to be added to /etc/initramfs-tools/modules is "hid-lenovo". Executing "update-initramfs -u -k all" after the addition will update the initramfs of all installed kernels, not only the currently used one. Some older kernels (at least 3.13.0-nn-generic) may require "hid-lenovo-tpkbd" instead as the module appear to have been renamed at some point.

Timothy Baker (tih) wrote :

I am encountering this same issue running 15.10 as a VM in hyper-v as generation 2 vm.
I can't work around it as there is no vm, and disk is encrypted, Sucks as i'll have to reinstall from scratch. Any fix that can be made during install? I tried the update-initramfs -u -k all but it doesn't fix the issue.

Danielhok (ffggfvghhygtjhg) wrote :

Hello,
I was using previously Linux Mint and then I had the idea that I'll change my system to Ubuntu Mate.
After the installing and rebooting I faced immediately the same problem as the guys here.

I can only login if I choose the kernel in the recovery mode. I'm using at the moment the newest kernel 4.4.0-040400.
I can't imagine why I have this problem.

I've tried to add "ohci_pci" to the initramfs-tools/modules but with no effort.

I'm using a Razer Deathstalker Chroma as keyboard and I wonder if there is missing support to my keyboard?
It is connected to a USB-Hub together with my Mouse and the Hub goes to a USB 3.0 Port on my Motherboard.

Maybe I have to connect my keyboard directly to my PC?

Can someone pls help me?
This problem is still actual and I guess a lot of people are still suffering.

I guess this problem could be solved easily but someone shall take a look at it and help us users to solve it.
We want to be better then Windows and therefore we have to do something!!!!

Do not just say Linux is better, safer and whatsoever, help the people which are suffering on a stupid simple problem.

Guys I appreciate ur help!
Daniel

tsde (havetobeunknown) wrote :

I was aslo stuck for months with kernel 3.19.0-28 on Ubuntu 15.04 but I found a work around that worked for me:

- open /etc/default/grub
- Delete the "quiet splash" value from the line beginning with GRUB_CMDLINE_LINUX_DEFAULT. The line should look like GRUB_CMDLINE_LINUX_DEFAULT=""
- save your changes and run sudo update-grub to update the grub configuration

When you restart, the splash screen is disabled leaving only the text console prompting you for your password. My keyboard seems to work using the console but not using the splash screen. Hope this'll help some of you.

This is only a workaround though, so this issue should definitely be investigated further.

Mike Butash (michael-butash) wrote :

I recently upgraded my trusty kernel from 3.16 to 3.19, and got hit with this bug with a logitech wireless keyboard. Seems all the kernel builds are omitting critical hid drivers in the initrd, yet again. Add in the fact my current mobo bios just simply wouldn't let grub catch my shift to break the boot menu to single mode. Very ugly, very not happy day.

Since I've gone to 4.4 kernel, and see the same issue with it, so it seems persistent and unfixed still at least on trusty repos. With 4.4, at least wired keyboard works, so I've been just keeping a second one around until I got to hunt for this more.

The recovery is obviously not pretty, and this has happened a few times I remember, as I've used luks since ~2008. It would be extremely nice if upstream or at least the vendor packagers run regression tests for this LUKS use case in particular formulated to avoid stranding people at their disk unlock menus and figuring out how to make a boot disk without the system they were just using.

Adam Felson (adam-ubuntu) wrote :

As recently as kubuntu 16.04, it is not fixed if the user switches to the nvidia video driver.
I tried several times to switch back to nouveau and back with no luck.
About 95% of the time I'd get a blank screen; no prompt. The rest of the time I'd get the unlock prompt but keyboard input was ignored.
The fact that the update manager is also broken in kubuntu 16.04 doesn't help. I was able to switch back and forth using 'ubuntu-drivers devices' and apt-get. I also tried 'update-initramfs -u' incase hid/usb was somehow not there.

What finally worked was to change grub to 'quiet nosplash' -- get rid of the splash screen.

Same here - fresh install of Ubuntu 16.04 - and the exact behavior Adam describes above (Encryption with proprietary Nvidia driver). 'quiet nosplash' works.

Chris Judge (cjudge) wrote :

Same here: upgraded to Ubuntu 16.04 from 14.04. Keyboard does not work after soft reboot. After a hard reboot/power cycle, must use recovery boot option.

As per information in this thread, I checked /etc/initramfs-tools/modules - it contains only #comments.

Using nvidia driver 367.35.

Have just applied the "nosplash" fix suggested by Adam Felson and am about to reboot.

Chris Judge (cjudge) wrote :

"nosplash" fixed it for me.

Marcos Alano (mhalano) wrote :

Same here, I'm installed Ubuntu 16.04.1 on a Dell Vostro 1520 with NIVIDA 340.xx driver and I can't type, but I can press Ctrl-Alt-Del to reboot. I will look for other fix thank nosplash to avoid to lose the beatiful screen. :)

DWon (dubbcd) wrote :

I have sda5_crypt enabled, replaced new GTX1070 with Nvidia driver.
decrpting password area not allowing to type in anything, even keyboard connection is checked.

#68 works for me

Folkert (folkert-meeuw-n) wrote :

When I installed 14.04 TLS I had enabled sda5_crypt. Last year I did the upgrade from 14.04 TLS to 16.04 TLS.

And today, I don't think anything bad, I install the latest kernel version .59 or similar, by use of synaptic (well it's comfortable to me, too). When I do reboot the system it hangs at "Please unlock disk sda5_crypt:". I type in the password. And then I press the [enter] key on the keyboard. But nothing happins. I do a reboot and I try it again, and again, and again, and again. How boring, how stupid. At luncgh time I think something is wrong. I find this thread and so *uck the *ell. I'm wondering, a thread starting in 10/2013 and today is 01/2017. My job is tester software, and sometime it's not easy and actually I have a lot of headache, 'cause my productive system isn't usable anymore. I won't recommend in the future to install sda5_crypt on any system and I will recommend to delete it on any system, too.

I take a look on the entries for this issue begin at #68. But for me 'nosplash' is always enabled in the GRUB entries. I don't think the issue is in relation with the splash. I use the >e< option at booting and use the emacs editor to inspect/review the GRUB entries.

Rafael (rafael.rtd) wrote :

I was able to solve the problem by booting with an old kernel, editing /etc/initramfs-tools/initramfs.conf and replacing
MODULES=most
with
MODULES=dep
and then running sudo update-initramfs -u.
I think the problem was that initramfs was including a module xhci-plat-hcd which is buggy and not really required. I was seeing error messages of the type
... xhci_hcd ... HC died; cleaning up
and then couldn't enter my passphrase.
My computer is a MacBookPro 12,1.

Timothy Katje (tmkatje) wrote :

I'm surprised to continue seeing such behavior even on the latest release or 17.04. In my case, I'm running inside of a Hyper-V VM. I am able to type in my password only when using recovery mode. I will attempt to edit my startup config to disable the clean splash screen, but I think it's ridiculous that we have to manually modify configuration files just to type in a password for such a basic feature.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.