post-install script should not try to install autostart file in user's home dir

Bug #873386 reported by Jon Smirl on 2011-10-13
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Weather Indicator
High
Unassigned
indicator-weather (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Andrew Starr-Bochicchio

Bug Description

This package has also been seg faulting two or three times a day.

ProblemType: Package
DistroRelease: Ubuntu 11.10
Package: indicator-weather 11.05.31-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Thu Oct 13 10:34:11 2011
ErrorMessage: ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
PackageArchitecture: all
SourcePackage: indicator-weather
Title: package indicator-weather 11.05.31-0ubuntu2 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to oneiric on 2011-10-13 (0 days ago)

Jon Smirl (jonsmirl) wrote :

Relevant part of VarLogDistupgradeTermlog.gz:

Setting up indicator-weather (11.05.31-0ubuntu2) ...
Installing indicator-specific icons...
Installing indicator dconf schema...
Creating autostart files...
test: 31: /home/My: unexpected operator
mkdir: cannot create directory `/home/linus/.config': Not a directory
dpkg: error processing indicator-weather (--configure):
 subprocess installed post-installation script returned error exit status 1

Jon Smirl (jonsmirl) wrote :

Why is it going to /home/linus? That is my copy of Linus' kernel tree for building the kernel.

Does it think it is a user's dir just because it is in /home?

Jon Smirl (jonsmirl) wrote :

It can't create /home/linus/.config as a directory because /home/linus/.config is the config file for the kernel tree. But it shouldn't be touching that directory at all.

Changed in indicator-weather (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium

You're right. This should really be done by the program itself on first run, not by the post-install script. Targeting for a Stable Release Update.

Changed in indicator-weather (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → Medium
milestone: none → oneiric-updates
Changed in indicator-weather (Ubuntu):
status: Confirmed → Triaged
summary: - package indicator-weather 11.05.31-0ubuntu2 failed to install/upgrade:
- ErrorMessage: subprocess installed post-installation script returned
- error exit status 1
+ post-install script should not try to install autostart file in user's
+ home dir
Changed in indicator-weather (Ubuntu Oneiric):
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
status: Triaged → In Progress
Changed in weather-indicator:
importance: Undecided → High
milestone: none → foggy
status: New → Triaged
Changed in weather-indicator:
milestone: foggy → cloudy-9
status: Triaged → Fix Committed

Hello Jon, or anyone else affected,

Accepted indicator-weather into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in indicator-weather (Ubuntu Oneiric):
status: In Progress → Fix Committed
tags: added: verification-needed
Vadim Rutkovsky (roignac) wrote :

Verified in Oneric-proposed.
We'll add 'Run at startup' checkbox in Preferences for current user in future versions

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-weather - 11.05.31-0ubuntu3

---------------
indicator-weather (11.05.31-0ubuntu3) precise; urgency=low

  * Forward port fix for LP: #873386 from oneiric-proposed.
  * debian/copyright: Bring up-to-date with latest Dep-5 spec.

indicator-weather (11.05.31-0ubuntu2.1) oneiric-proposed; urgency=low

  * debian/postinst: Do not attempt to install autostart
    file in user's home directory (LP: #873386).
  * debian/patches/autostart.patch: Instead, check for file's
    existance at runtime. If it is not there, properly create it.
 -- Andrew Starr-Bochicchio <email address hidden> Fri, 04 Nov 2011 17:13:10 -0400

Changed in indicator-weather (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-weather - 11.05.31-0ubuntu2.1

---------------
indicator-weather (11.05.31-0ubuntu2.1) oneiric-proposed; urgency=low

  * debian/postinst: Do not attempt to install autostart
    file in user's home directory (LP: #873386).
  * debian/patches/autostart.patch: Instead, check for file's
    existance at runtime. If it is not there, properly create it.
 -- Andrew Starr-Bochicchio <email address hidden> Wed, 02 Nov 2011 11:51:55 -0400

Changed in indicator-weather (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in weather-indicator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers