do not see indicator-weather on the panel

Bug #765464 reported by Eugene on 2011-04-19
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Weather Indicator
Medium
Vadim Rutkovsky
indicator-weather (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: indicator-weather
I tried to restart it, reinstall it, click right next to network connection and so on. In indicator Log, seems that 1 line repeats:

2011-04-18 23:06:33,335 - DEBUG - Settings: DBus exception occurred, retrying ---> have no idea what it means. May be I screwed up something.

no indicator-weather on a panel

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: indicator-weather 11.04.10+repack-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
Architecture: i386
Date: Mon Apr 18 23:15:20 2011
ExecutablePath: /usr/bin/indicator-weather
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-weather
UpgradeStatus: No upgrade log present (probably fresh install)

Eugene (ylamanosau) wrote :
Eugene (ylamanosau) on 2011-04-19
description: updated
Mahyuddin Susanto (udienz) wrote :

Same here, indicator-weather not working at here

Changed in indicator-weather (Ubuntu):
status: New → Confirmed
Vadim Rutkovsky (roignac) wrote :

Could you please attach the log from ~/.cache/indicator-weather.log?

Changed in weather-indicator:
importance: Undecided → Medium
milestone: none → 11.04.23
status: New → Confirmed
Eugene (ylamanosau) wrote :

there are 2 logs.

Eugene (ylamanosau) wrote :
Vadim Rutkovsky (roignac) wrote :

Pushed a probable fix for this - increased sleep time up to 10 secs. If this doesn't help, please change bug status to New and attache new logs here

Changed in weather-indicator:
assignee: nobody → Vadim Rutkovsky (roignac)
status: Confirmed → Fix Committed
Changed in weather-indicator:
status: Fix Committed → Fix Released
Changed in indicator-weather (Ubuntu):
status: Confirmed → Fix Committed
Mike A. Kuznetsov (mike4gg) wrote :

The bug is still there on 11.04. No indicator at panel after launching and in logs:

2011-05-12 16:49:31,369 - INFO - ------------------------------
2011-05-12 16:49:31,369 - INFO - Started Weather Indicator from /usr
2011-05-12 16:49:31,369 - DEBUG - SingleInstance: writing new pid 12179
2011-05-12 16:49:31,371 - DEBUG - ProxyMonitor: loading dconf settings
2011-05-12 16:49:31,371 - DEBUG - ProxyMonitor: using direct connection
2011-05-12 16:49:31,372 - DEBUG - TimeFormatter: loading indicator-datetime settings: com.canonical.indicator.datetime
2011-05-12 16:49:31,372 - DEBUG - Time Formatter: time format changed
2011-05-12 16:49:31,373 - DEBUG - Indicator: creating
2011-05-12 16:49:31,381 - INFO - Monitoring UPower interface
2011-05-12 16:49:31,381 - DEBUG - Indicator: reading settings
2011-05-12 16:49:31,381 - DEBUG - Settings: preparing settings store
2011-05-12 16:49:56,404 - DEBUG - Settings: DBus exception occurred, retrying
2011-05-12 16:50:03,869 - DEBUG - Settings: DBus exception occurred, retrying
2011-05-12 16:50:31,887 - DEBUG - Settings: DBus exception occurred, retrying
2011-05-12 16:50:59,895 - DEBUG - Settings: DBus exception occurred, retrying

Vadim Rutkovsky (roignac) wrote :

Mike, which version are you using?

Don Myers (donmyers) wrote :

I have the indicator-weather installed on 2 other Ubuntu 11.04 boxes, and it displays fine. On my main box though, it will not display. I've tinkered with this ever since the release of 11.04 and can't make it work. It shows it is installed. I also checked that all of the files that installed when I installed it on the other two machines are installed. I've deleted everything and have done a fresh install through the software center. Any suggestions would be appreciated.

Timo Schneemann (timobauwan) wrote :

I have the same problem. Log in attachment. An my notebook with 11.04 (32bit) all works fine. On my desktop-computer (11.04, 32 bit) first it worked now since 2-3 days it runs with startup but i can see nothing.

Timo Schneemann (timobauwan) wrote :

I forgot to mention the Version: its from ppa: 11.05.01~natty2 (indicator-weather)

Changed in weather-indicator:
milestone: 11.04.24 → 11.05.15
status: Fix Released → Confirmed
Apteryx (maxco) wrote :

Had this problem too, then restarted my machine and bingo! it was there.

Changed in weather-indicator:
milestone: 11.05.30 → backlog
Donatas Burba (d.burba) wrote :

Still doesn't work for me

Changed in weather-indicator:
milestone: backlog → 11.05.31
status: Confirmed → Fix Released
Donatas Burba (d.burba) wrote :

At last it works! Thanks :)

Martin G Miller (mgmiller) wrote :

The Natty repositories are at version 11.04.10. When do you think they will be upgraded to the current version?

This actually depends on the package maintainer - we have already asked to
update the package, but no estimates on the date, sorry.

You may try using Stable ppa (ppa:weather-indicator-team/ppa) to get the
most recent version, which includes the fix

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-weather - 11.05.31-0ubuntu1

---------------
indicator-weather (11.05.31-0ubuntu1) oneiric; urgency=low

  * New upstream release.
   - Ported settings to dconf, which will solve a number of
     desktopcouch-related bugs
   - Fix for LP: #747733 "indicator-weather crashed with
     TypeError in next_page(): unknown type (null)"
   - Fix for LP: #756704 "Numbers (temperature etc.) do
     not use local number format"
   - Fix for LP: #770652 "sunrise and sunset info incorrect"
   - Fix for LP: #765464 "do not see indicator-weather on the panel"
   - Fix for LP: #769842 "Weather Indicator should clear up corrupted DB"
   - Fix for LP: #778941 "Weather Indicator can't be disabled"
   - Fix for LP: #796314 "ROUND_CEiLiNG error in Turkish locale"
   - Fix for LP: #780973 "indicator-weather crashed with Unauthorized in
     request(): ('unauthorized', 'Authentication required.')"
  * debian/control:
   - Adjust dependencies for desktop-couch to dconf transition.
   - Bump Standards-Version to 3.9.2.
   - Explictily depend on libgtk2.0-bin to ensure we have
     /usr/bin/gtk-update-icon-cache (LP: #808387).
  * Convert from python-support to dh_python2.
  * debian/rules:
   - Drop get-orig-source target, not needed.
   - Fix debian/postinst to check for symbolic links as well.
 -- Andrew Starr-Bochicchio <email address hidden> Tue, 12 Jul 2011 01:44:53 -0400

Changed in indicator-weather (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions