indicator-weather crashed with SIGSEGV in g_array_free()

Bug #1063643 reported by Vasile Rotaru on 2012-10-08
This bug affects 197 people
Affects Status Importance Assigned to Milestone
Weather Indicator
Medium
Unassigned
indicator-weather (Ubuntu)
Medium
Unassigned

Bug Description

Just happened

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: indicator-weather 11.11.28-0ubuntu1.2
ProcVersionSignature: Ubuntu 3.2.0-31.50-generic 3.2.28
Uname: Linux 3.2.0-31-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu13
Architecture: amd64
CrashCounter: 1
Date: Mon Oct 8 11:45:06 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/indicator-weather
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/indicator-weather
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fb2655f5f08 <g_array_free+24>: lock xadd %edx,0x18(%rdi)
 PC (0x7fb2655f5f08) ok
 source "%edx" ok
 destination "0x18(%rdi)" (0x7fb256fa5878) in non-writable VMA region: 0x7fb256f99000-0x7fb256fb3000 r-xp /usr/lib/x86_64-linux-gnu/libdbusmenu-glib.so.4.0.13
SegvReason: writing VMA /usr/lib/x86_64-linux-gnu/libdbusmenu-glib.so.4.0.13
Signal: 11
SourcePackage: indicator-weather
StacktraceTop:
 g_array_free () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libdbusmenu-glib.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libdbusmenu-glib.so.4
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: indicator-weather crashed with SIGSEGV in g_array_free()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Vasile Rotaru (vrotaru-md) wrote :

StacktraceTop:
 g_array_free (farray=0x7fb256fa5860, free_segment=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/garray.c:344
 prop_array_teardown (prop_array=0x2cb6980) at /build/buildd/libdbusmenu-0.6.2/./libdbusmenu-glib/server.c:945
 menuitem_property_idle (user_data=<optimized out>) at /build/buildd/libdbusmenu-0.6.2/./libdbusmenu-glib/server.c:1110
 g_main_dispatch (context=0x29b4be0) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:2539
 g_main_context_dispatch (context=0x29b4be0) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3075

Changed in indicator-weather (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
tags: added: running-unity
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-weather (Ubuntu):
status: New → Confirmed
tags: added: raring
information type: Private → Public
Sasa Paporovic (melchiaros) wrote :

Setting to confirmed in upstream project, because the crash affects 34 people.

Changed in weather-indicator:
status: New → Confirmed
Sasa Paporovic (melchiaros) wrote :

The crash occures the first time with version 11.11.28-0ubuntu1 in Ubuntu12.04 is is observable up to version 12.07.30-0ubuntu1 in Ubuntu13.04 development branch.

tags: added: bugpattern-needed
tags: added: quantal
Andre (ajx) wrote :

problem also existent on Precise 64bit with program version: 12.07.30 'Cloudy 10'

Henrique Barbosa (hmjbarbosa) wrote :

I can confirm that. Ubuntu 12.04 64bit and 11.11.28-0ubuntu1.3 crashes everyday. My system is fully updated so I am not sure why I did not get the latest version people are mentioning above.

Joshua Tasker (jtasker) on 2013-05-24
Changed in weather-indicator:
status: Confirmed → Fix Released
importance: Undecided → Medium
milestone: none → 13.05.17
To post a comment you must log in.