indicator-sound-service crashed with SIGABRT

Bug #738051 reported by miked on 2011-03-19
128
This bug affects 24 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
High
Conor Curran
Unity Foundations
High
Conor Curran
indicator-sound (Ubuntu)
Medium
Conor Curran

Bug Description

Binary package hint: indicator-sound

Ubuntu Natty Narwhal Alpha 3 ix386
On start-up crash/bug

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: indicator-sound 0.6.4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.36-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
CrashCounter: 1
Date: Fri Mar 18 22:24:14 2011
ExecutablePath: /usr/lib/indicator-sound/indicator-sound-service
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcCmdline: /usr/lib/indicator-sound/indicator-sound-service
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=C:en
 LANG=en_US.UTF-8
Signal: 6
SourcePackage: indicator-sound
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? () from /usr/lib/libpulse.so.0
 ?? () from /usr/lib/libpulse.so.0
Title: indicator-sound-service crashed with SIGABRT
UpgradeStatus: Upgraded to natty on 2011-03-15 (3 days ago)
UserGroups: adm audio cdrom dialout dip fax floppy fuse netdev nopasswdlogin plugdev sambashare tape video
XsessionErrors:
 (gnome-settings-daemon:1570): GdkPixbuf-CRITICAL **: gdk_pixbuf_format_get_name: assertion `format != NULL' failed
 (gnome-settings-daemon:1570): GdkPixbuf-CRITICAL **: gdk_pixbuf_format_get_name: assertion `format != NULL' failed
 (nautilus:1620): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed

miked (miked11) wrote :
visibility: private → public

StacktraceTop:
 sound_service_dbus_update_sound_state (self=0x847fa60, new_state=UNAVAILABLE) at sound-service-dbus.c:252
 device_sink_deactivated (self=0x8481768) at device.c:244
 pm_context_state_callback (c=0x8495b78, userdata=0x8481768) at pulseaudio-mgr.c:311
 pa_context_set_state (c=0x8495b78, st=PA_CONTEXT_FAILED) at pulse/context.c:302
 pa_context_fail (c=0x8495b78, error=11) at pulse/context.c:325

Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Conor Curran (cjcurran) on 2011-03-21
Changed in indicator-sound (Ubuntu):
assignee: nobody → Conor Curran (cjcurran)
Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
Conor Curran (cjcurran) wrote :

Can anybody give me more information on this crash ? Is it reproducible under certain scenarios ?

Conor

Changed in unity-foundations:
assignee: nobody → Conor Curran (cjcurran)
Changed in indicator-sound:
importance: Undecided → High
Changed in unity-foundations:
importance: Undecided → High
Conor Curran (cjcurran) wrote :

Okay can't confirm this for beta release. If anybody sees this could they please comment as such. it looks like some odd crash thrown on a dbus signal emit.

Jeroen Roovers (jer-gentoo) wrote :

Well, I have just filed a duplicate. It does indeed look rare.

Conor Curran (cjcurran) wrote :

The only thing I can see here is that there maybe a race condition whereby I try to send an initial state update over the bus but my dbus connection hasn't yet been establised properly. In the Natty release the DBus connection is created asynchronously unlike previously. Working up a patch ...

Conor Curran (cjcurran) on 2011-03-25
Changed in indicator-sound:
status: New → In Progress
Changed in unity-foundations:
status: New → In Progress
milestone: none → unity-3.8.0-beta
Conor Curran (cjcurran) wrote :

Scratch that, found the problem ... sillyness on my behalf.
I was calling g_error() instead of g_critical/g_warning hence the sigabrt.

Conor Curran (cjcurran) on 2011-03-25
Changed in indicator-sound:
status: In Progress → Fix Committed
Changed in unity-foundations:
status: In Progress → Fix Committed
Conor Curran (cjcurran) on 2011-03-25
Changed in indicator-sound (Ubuntu):
status: New → In Progress
Conor Curran (cjcurran) on 2011-03-28
Changed in indicator-sound:
milestone: none → 0.6.6
Conor Curran (cjcurran) on 2011-03-29
Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Committed
miked (miked11) wrote :

root@miked-desktop:/# lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04
root@miked-desktop:/#

Conor Curran (cjcurran) on 2011-04-04
Changed in indicator-sound:
status: Fix Committed → Fix Released
Changed in unity-foundations:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.6.6.1-0ubuntu1

---------------
indicator-sound (0.6.6.1-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Fix crash with SIGABRT (LP: #738051) (LP: #744304)
    - ensure that if the service crashes the indicator will not show
      multiple sliders
 -- Ken VanDine <email address hidden> Mon, 04 Apr 2011 10:02:19 -0400

Changed in indicator-sound (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers